Jump to content

Local Kodi meta-data, Emby first scan = DVD VIDEO_TS Issues


TrackZ
 Share

Go to solution Solved by Luke,

Recommended Posts

When I go into a movie's edit page and click to browse images or click the cloud button for any given image type, the window loads with all of the options, but it never actually loads the images to preview. I've sat with the window open for a good while.

 

This is using Windows 8.1 up to date with the most recent IE.

 

Thanks!

post-425-0-93609600-1389327542_thumb.jpg

Link to comment
Share on other sites

bloodtaker

i get this to happen on some media as well but if you click on the download part it will download just dont know what you are getting

 

its almost as if the request is timing out.

sometimes you can close and open it and it will work on most of the images.

if you click the blank area above the text where the image is supposed to be .

 

also this doesnt happen all the time mainly seems like when fanart itself is having problems like high load times to their site. which is where i think the main problem is since so many use them

Link to comment
Share on other sites

WWWestern

bloodtaker, the same behavior I see with all browsers. And so it was with the MetaBrowser and MCM. And then I blindly choose an option with a large number of votes.

 

Luke, I think that if the sources are also provided ready thumbs that we could show the dialog box, it would be significantly reduced waiting time when load images and our thumbs will be formed.

Link to comment
Share on other sites

  • 1 year later...
cw-kid

Hi

 

This doesn't seem to be working for me either, I am a new Emby user and have just installed version 3.0.5597.1 on to my WHS 2011 server. 

 

I have tried with Chrome and IE browsers, whenever I edit a movie title and go in to meta-data -> images. If I click the cloud icon on say the Primary one it says 0 of 0.

 

Same for the other images types. Here is the log file.

 

Thanks

Link to comment
Share on other sites

cw-kid

Hi

 

On the first scan Emby server has ever done I set it not to download artwork and meta-data from the Internet and for it not to save it in to the local folders.

 

Reason being I wanted Emby to import my movies using the existing local meta-data .nfo files and artwork that Kodi has already previously created. 

 

This seemed to work OK for movies that were video files such as .avi and .mkv.

 

However for DVD VIDEO_TS rips Emby does not import them correctly and does not show any of the meta-data that is in the .nfo file!

 

When Kodi exports all its .nfo files, for DVD VIDEO_TS rips it places the .nfo file inside of the VIDEO_TS folder and it names the file VIDEO_TS.nfo.

 

Here is how the existing Kodi artwork files and .nfo file look like on my file server.

 

554b98a18c055_EmbyDVD1.png

Here you can see the .nfo file Kodi created after I ran the export Video Library option in Kodi.

 

554b98b424223_EmbyDVD2.png

 

And here is how the resulting imported movie title looks in Emby, with no meta-data showing

 

554b990b90952_EmbyDVD3.png

 

Thanks

Link to comment
Share on other sites

  • Solution

Ok, we can add support for VIDEO_TS.nfo. I wasn't aware of that.

  • Like 1
Link to comment
Share on other sites

cw-kid

Ok, we can add support for VIDEO_TS.nfo. I wasn't aware of that.

 

Yes please or all of my movie DVD rips won't have any meta-data in Emby after the first scan. 

 

I am testing Emby with a small subset of my media content currently to get things working right. 

 

Eventually I'd like to do away with the centralised MySQL database for Kodi and integrate Kodi with Emby etc.

Link to comment
Share on other sites

cw-kid

Luke 

 

Can I ask you about Folder.jpg and Poster.jpg ?

 

Emby used Folder.jpg on its first scan, even though there were Poster.jpg files present as well. 

 

Reason why I still have Folder.jpg files is because they are the covers MyMovies.dk created ages ago. 

 

And when I moved to XBMC and then used the Artwork Downloader XBMC add-on, then that created all the new Poster.jpg images as well etc.

 

I could possibly delete all the old Folder.jpg files. 

 

Or is there a way to make Emby use the Poster.jpg files rather than the Folder.jpg files on its first scan, when we are using local meta-data and artwork files ?

 

Here you can see how the movies ended up looking like in Emby with the old MyMovies.dk cover images aka Folder.jpg files. 

 

554b543c89650_Emby1.png

 

Thanks

Link to comment
Share on other sites

it is currently not configurable so you'd have to remove them. i'd like to eventually make it configurable, but it's not right now

Link to comment
Share on other sites

cw-kid

it is currently not configurable so you'd have to remove them. i'd like to eventually make it configurable, but it's not right now

 

OK as I thought then. I'll have to delete them and hope I don't need them later.

 

I uninstalled MyMovies.dk from the WHS yesterday so should be OK and Kodi is using the Poster.jpg files. 

Link to comment
Share on other sites

cw-kid

Luke

 

While I have your attention I have one more problem with Emby at the moment. The Browse Online images doesn't seem to work, thread here with log file.

 

Seems quite hit and miss and usually isn't working for me, I restarted the Emby server a few times and it started working briefly but its not working again now.

 

Thanks

Link to comment
Share on other sites

check to make sure provider id's were read from your metadata - imdb, tmdb, tvdb, etc

Link to comment
Share on other sites

cw-kid

check to make sure provider id's were read from your metadata - imdb, tmdb, tvdb, etc

 

How do I do that?

 

Something in the Kodi .nfo files?

 

When I edit a movie title in Emby and select the images button, I can then see all the local artwork images being displayed OK.

 

But when I click the Cloud button "Browse Images" its not showing me the images from the cloud artwork sites. 

 

But sometimes it does work, sometimes not.

Edited by cw-kid
Link to comment
Share on other sites

your movies and tv series are probably missing those Id's. use the metadata manager. since you disabled downloading of internet metadata, it is up to you to fill in those Id's if they weren't' read from metadata.

Link to comment
Share on other sites

cw-kid

your movies and tv series are probably missing those Id's. use the metadata manager. since you disabled downloading of internet metadata, it is up to you to fill in those Id's if they weren't' read from metadata.

 

Oh I see where you mean, in the meta-data manager under the External IDs section.

 

All of the test movies in the Emby library now, appear to have an IMDB ID present already. 

 

The plan is once Emby has done its first scan and imported all the media content from Kodi using its .nfo files and artwork files.

 

I would then turn on in the Emby settings for the downloading of Internet meta-data. And I would then disable the Kodi Universal scrapers and just use Emby as the media management tool. Kodi would then use the "Local Information Only" Scraper and read the new .nfo files that Emby will be creating etc.

 

I've just added my personal API key for Fanart.tv in to the Emby settings as well, if that makes a difference. 

Edited by cw-kid
Link to comment
Share on other sites

cw-kid

I've re-enabled the setting in Emby for Internet meta-data downloading. And if I edit a TV show and select "Browse Images" its now showing me the online images again, so maybe that's why it wasn't working doh!  :wacko: I must have had it turned on earlier and then turned it off again and then forgot.

 

The Emby meta-data manager is fantastic! I have just downloaded Season posters for all the Test TV Shows I've got in the Emby Library.

 

For some reason Artwork Downloader in Kodi isn't downloading season posters. 

Edited by cw-kid
  • Like 1
Link to comment
Share on other sites

cw-kid

Well that works! I just deleted all the Folder.jpg files from the test movie folders and Emby after a few browser refreshes has defaulted to using the Poster.jpg images instead.

 

554bb6326d2a5_EmbyDVD4.png

  • Like 1
Link to comment
Share on other sites

cw-kid

Still having issues with "Browse Online Images" in the meta-data manager.

 

It seems for the movies that Emby imported using the local Kodi meta-data, I cannot browse online images for any of these titles. Looking in the External IDs section each title does have an ID present in the IMDB field but not for TheMovieDB field(s).

 

For two of these movie titles in the Emby library, I identified them using the meta-data manager. Seems as a result of doing this these two titles now also have an ID present in the TheMovieDB field as well. And for these two movie titles alone the browse online images works fine.

 

Attached is the Kodi created .nfo file for the title "The Equalizer (2014)"

 

I can see in this .nfo file this entry:

 

<imdbid>tt0455944</imdbid>

 

So once Emby has imported all the movies using the local Kodi .nfo files, I am expected to then manually add all the IDs for the TheMovieDB site to them?

 

Or some how on mass Identify all the titles using the Emby meta-data manager? 

 

How are the TheMovieDB ID fields meant to be populated when importing from Kodi .nfo files? 

 

Thanks

The Equalizer nfo.txt

Edited by cw-kid
Link to comment
Share on other sites

cw-kid

Seems my problem is related to not having any TheMovieDB IDs for the movie titles in the External IDs section of the meta-data manager.

 

See here for more details. 

Link to comment
Share on other sites

currently yes they're a bit dependent on Tmdb. It can be improved in the future. Keep in mind you're in the minority because you disabled internet metadata. Most people leave it on, the server then sees the Imdb Id, uses that get Tmdb metadata, merges it in, and then gets images using Tmdb. Since you disabled it those first parts never happened.

 

But even still many incoming nfo users already have the Tmdb id because a lot of other tools populate it, like metabrowser and mcm for example.

Link to comment
Share on other sites

cw-kid

Ok that all makes sense.

 

So if I have the Emby setting for download internet metadata enabled but not check the other option to save artwork files in to the folders and then I import all the movies and tv shows into Emby what would happen?

 

Would Emby still read the local Kodi .nfo files and use the existing local artwork files and then in addition fill in any blanks like the missing TheMovieDB IDs?

 

Thanks for your time explaining things!

Edited by cw-kid
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...