Jump to content


Photo

library scan freezing

osx server

  • Please log in to reply
12 replies to this topic

#1 geno27 OFFLINE  

geno27

    Advanced Member

  • Members
  • 44 posts
  • Local time: 12:55 PM

Posted 16 April 2015 - 10:23 PM

Since updating to server version 3.0.5582.0, I've noticed that the first library scan after starting the server is fine, but after that the library scan gets stuck at 0% until you shut down the server. Hitting stop causes it to freeze with a "stopping" message. Anyone else having this problem?

 

log


Edited by geno27, 16 April 2015 - 10:24 PM.


#2 stueeey OFFLINE  

stueeey

    Member

  • Members
  • 23 posts
  • Local time: 05:55 PM

Posted 20 April 2015 - 08:31 AM

Since updating to server version 3.0.5582.0, I've noticed that the first library scan after starting the server is fine, but after that the library scan gets stuck at 0% until you shut down the server. Hitting stop causes it to freeze with a "stopping" message. Anyone else having this problem?

 

log

same here.



#3 shadowcharly OFFLINE  

shadowcharly

    Newbie

  • Members
  • 3 posts

Posted 08 May 2015 - 08:16 AM

Same here,

 

Detected two strange things in the logs:

 

 

 

2015-05-08 12:35:31.0861 Info - App: Removing virtual season Doctor Who (2005)
2015-05-08 12:35:31.0869 Info - App: Creating Season Season Unknown entry for Doctor Who (2005)
2015-05-08 12:35:34.5366 Error - App: Error in Nfo
    *** Error Report ***
    Version: 3.0.5597.1
    Command line: /Applications/MediaBrowser.Server.Mac.localized/MediaBrowser.Server.Mac.app/Contents/MacOS/MediaBrowser.Server.Mac
    Operating system: Unix 14.3.0.0
    Processor count: 4
    64-Bit OS: False
    64-Bit Process: False
    Program data path: /Users/something/.config/mediabrowser-server
    Mono: 3.12.1 ((detached/0849ec7)
    Application Path: /Applications/MediaBrowser.Server.Mac.localized/MediaBrowser.Server.Mac.app/Contents/MonoBundle/MediaBrowser.Server.Mac.exe
    Text node cannot appear in this state. Line 2, position 1.
    System.Xml.XmlException
     at Mono.Xml2.XmlTextReader.ReadText (Boolean notWhitespace) [0x00000] in <filename unknown>:0
     at Mono.Xml2.XmlTextReader.ReadContent () [0x00000] in <filename unknown>:0
     at Mono.Xml2.XmlTextReader.Read () [0x00000] in <filename unknown>:0
     at System.Xml.XmlTextReader.Read () [0x00000] in <filename unknown>:0
     at Mono.Xml.XmlFilterReader.Read () [0x00000] in <filename unknown>:0
     at System.Xml.XmlReader.MoveToContent () [0x00000] in <filename unknown>:0
     at MediaBrowser.XbmcMetadata.Parsers.BaseNfoParser`1[MediaBrowser.Controller.Entities.TV.Episode].Fetch (MediaBrowser.Controller.Entities.TV.Episode item, System.Collections.Generic.List`1 userDataList, System.String metadataFile, System.Xml.XmlReaderSettings settings, CancellationToken cancellationToken) [0x00000] in <filename unknown>:0
     at MediaBrowser.XbmcMetadata.Parsers.BaseNfoParser`1[MediaBrowser.Controller.Entities.TV.Episode].Fetch (MediaBrowser.Controller.Entities.TV.Episode item, System.Collections.Generic.List`1 userDataList, System.String metadataFile, CancellationToken cancellationToken) [0x00000] in <filename unknown>:0
     at MediaBrowser.XbmcMetadata.Parsers.EpisodeNfoParser.Fetch (MediaBrowser.Controller.Entities.TV.Episode item, System.Collections.Generic.List`1 userDataList, System.Collections.Generic.List`1 images, System.Collections.Generic.List`1 chapters, System.String metadataFile, CancellationToken cancellationToken) [0x00000] in <filename unknown>:0
     at MediaBrowser.XbmcMetadata.Providers.EpisodeNfoProvider.Fetch (MediaBrowser.Controller.Providers.LocalMetadataResult`1 result, System.String path, CancellationToken cancellationToken) [0x00000] in <filename unknown>:0
     at MediaBrowser.XbmcMetadata.Providers.BaseNfoProvider`1+<GetMetadata>c__async0[MediaBrowser.Controller.Entities.TV.Episode].MoveNext () [0x00000] in <filename unknown>:0
    --- End of stack trace from previous location where exception was thrown ---
     at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x00000] in <filename unknown>:0
     at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[MediaBrowser.Controller.Providers.LocalMetadataResult`1[MediaBrowser.Controller.Entities.TV.Episode]].GetResult () [0x00000] in <filename unknown>:0
     at MediaBrowser.Providers.Manager.MetadataService`2+<RefreshWithProviders>c__async1[MediaBrowser.Controller.Entities.TV.Episode,MediaBrowser.Controller.Providers.EpisodeInfo].MoveNext () [0x00000] in <filename unknown>:0
    
2015-05-08 12:35:37.0355 Info - App: StartupTrigger fired for task: Log file cleanup
2015-05-08 12:35:37.0355 Info - App: Queueing task DeleteLogFileTask
 

 

And in another log, a repeating message saying that a user with id "something" could not be found.

 

 

2015-05-08 12:38:21.0382 Info - App: Refresh Channels Completed after 0 minute(s) and 0 seconds
2015-05-08 12:38:22.0370 Error - HttpAsyncTaskHandler: Error occured while Processing Request: User with Id e3d51704c5fa809bae5530229b96f4b1 not found
    *** Error Report ***
    Version: 3.0.5597.1
    Command line: /Applications/MediaBrowser.Server.Mac.app/Contents/MacOS/MediaBrowser.Server.Mac
    Operating system: Unix 14.3.0.0
    Processor count: 4
    64-Bit OS: False
    64-Bit Process: False
    Program data path: /Users/something/.config/mediabrowser-server
    Mono: 3.12.1 ((detached/0849ec7)
    Application Path: /Applications/MediaBrowser.Server.Mac.app/Contents/MonoBundle/MediaBrowser.Server.Mac.exe
    User with Id e3d51704c5fa809bae5530229b96f4b1 not found
    MediaBrowser.Controller.Net.SecurityException
     at MediaBrowser.Server.Implementations.HttpServer.Security.AuthService.ValidateUser (IServiceRequest request, IAuthenticationAttributes authAttribtues) [0x00000] in <filename unknown>:0
     at MediaBrowser.Server.Implementations.HttpServer.Security.AuthService.Authenticate (IServiceRequest request, IAuthenticationAttributes authAttribtues) [0x00000] in <filename unknown>:0
     at MediaBrowser.Controller.Net.AuthenticatedAttribute.RequestFilter (IRequest request, IResponse response, System.Object requestDto) [0x00000] in <filename unknown>:0
     at ServiceStack.ServiceStackHost.ApplyRequestFiltersSingle (IRequest req, IResponse res, System.Object requestDto) [0x00000] in <filename unknown>:0
     at ServiceStack.ServiceStackHost.ApplyRequestFilters (IRequest req, IResponse res, System.Object requestDto) [0x00000] in <filename unknown>:0
     at ServiceStack.Host.RestHandler.ProcessRequestAsync (IRequest httpReq, IResponse httpRes, System.String operationName) [0x00000] in <filename unknown>:0
    
2015-05-08 12:38:22.0370 Error - HttpAsyncTaskHandler: Error occured while Processing Request: User with Id e3d51704c5fa809bae5530229b96f4b1 not found
    *** Error Report ***
    Version: 3.0.5597.1
    Command line: /Applications/MediaBrowser.Server.Mac.app/Contents/MacOS/MediaBrowser.Server.Mac
    Operating system: Unix 14.3.0.0
    Processor count: 4
    64-Bit OS: False
    64-Bit Process: False
    Program data path: /Users/something/.config/mediabrowser-server
    Mono: 3.12.1 ((detached/0849ec7)
    Application Path: /Applications/MediaBrowser.Server.Mac.app/Contents/MonoBundle/MediaBrowser.Server.Mac.exe
    User with Id e3d51704c5fa809bae5530229b96f4b1 not found
    MediaBrowser.Controller.Net.SecurityException
     at MediaBrowser.Server.Implementations.HttpServer.Security.AuthService.ValidateUser (IServiceRequest request, IAuthenticationAttributes authAttribtues) [0x00000] in <filename unknown>:0
     at MediaBrowser.Server.Implementations.HttpServer.Security.AuthService.Authenticate (IServiceRequest request, IAuthenticationAttributes authAttribtues) [0x00000] in <filename unknown>:0
     at MediaBrowser.Controller.Net.AuthenticatedAttribute.RequestFilter (IRequest request, IResponse response, System.Object requestDto) [0x00000] in <filename unknown>:0
     at ServiceStack.ServiceStackHost.ApplyRequestFiltersSingle (IRequest req, IResponse res, System.Object requestDto) [0x00000] in <filename unknown>:0
     at ServiceStack.ServiceStackHost.ApplyRequestFilters (IRequest req, IResponse res, System.Object requestDto) [0x00000] in <filename unknown>:0
     at ServiceStack.Host.RestHandler.ProcessRequestAsync (IRequest httpReq, IResponse httpRes, System.String operationName) [0x00000] in <filename unknown>:0
    
2015-05-08 12:38:22.0370 Error - HttpAsyncTaskHandler: Error occured while Processing Request: User with Id e3d51704c5fa809bae5530229b96f4b1 not found
    *** Error Report ***
    Version: 3.0.5597.1
    Command line: /Applications/MediaBrowser.Server.Mac.app/Contents/MacOS/MediaBrowser.Server.Mac
    Operating system: Unix 14.3.0.0
    Processor count: 4
    64-Bit OS: False
    64-Bit Process: False
    Program data path: /Users/something/.config/mediabrowser-server
    Mono: 3.12.1 ((detached/0849ec7)
    Application Path: /Applications/MediaBrowser.Server.Mac.app/Contents/MonoBundle/MediaBrowser.Server.Mac.exe
    User with Id e3d51704c5fa809bae5530229b96f4b1 not found
    MediaBrowser.Controller.Net.SecurityException
     at MediaBrowser.Server.Implementations.HttpServer.Security.AuthService.ValidateUser (IServiceRequest request, IAuthenticationAttributes authAttribtues) [0x00000] in <filename unknown>:0
     at MediaBrowser.Server.Implementations.HttpServer.Security.AuthService.Authenticate (IServiceRequest request, IAuthenticationAttributes authAttribtues) [0x00000] in <filename unknown>:0
     at MediaBrowser.Controller.Net.AuthenticatedAttribute.RequestFilter (IRequest request, IResponse response, System.Object requestDto) [0x00000] in <filename unknown>:0
     at ServiceStack.ServiceStackHost.ApplyRequestFiltersSingle (IRequest req, IResponse res, System.Object requestDto) [0x00000] in <filename unknown>:0
     at ServiceStack.ServiceStackHost.ApplyRequestFilters (IRequest req, IResponse res, System.Object requestDto) [0x00000] in <filename unknown>:0
     at ServiceStack.Host.RestHandler.ProcessRequestAsync (IRequest httpReq, IResponse httpRes, System.String operationName) [0x00000] in <filename unknown>:0
    
2015-05-08 12:38:22.2056 Error - HttpAsyncTaskHandler: Error occured while Processing Request: User with Id e3d51704c5fa809bae5530229b96f4b1 not found
    *** Error Report ***
    Version: 3.0.5597.1
    Command line: /Applications/MediaBrowser.Server.Mac.app/Contents/MacOS/MediaBrowser.Server.Mac
    Operating system: Unix 14.3.0.0
    Processor count: 4
    64-Bit OS: False
    64-Bit Process: False
    Program data path: /Users/something/.config/mediabrowser-server
    Mono: 3.12.1 ((detached/0849ec7)
    Application Path: /Applications/MediaBrowser.Server.Mac.app/Contents/MonoBundle/MediaBrowser.Server.Mac.exe
    User with Id e3d51704c5fa809bae5530229b96f4b1 not found
    MediaBrowser.Controller.Net.SecurityException
     at MediaBrowser.Server.Implementations.HttpServer.Security.AuthService.ValidateUser (IServiceRequest request, IAuthenticationAttributes authAttribtues) [0x00000] in <filename unknown>:0
     at MediaBrowser.Server.Implementations.HttpServer.Security.AuthService.Authenticate (IServiceRequest request, IAuthenticationAttributes authAttribtues) [0x00000] in <filename unknown>:0
     at MediaBrowser.Controller.Net.AuthenticatedAttribute.RequestFilter (IRequest request, IResponse response, System.Object requestDto) [0x00000] in <filename unknown>:0
     at ServiceStack.ServiceStackHost.ApplyRequestFiltersSingle (IRequest req, IResponse res, System.Object requestDto) [0x00000] in <filename unknown>:0
     at ServiceStack.ServiceStackHost.ApplyRequestFilters (IRequest req, IResponse res, System.Object requestDto) [0x00000] in <filename unknown>:0
     at ServiceStack.Host.RestHandler.ProcessRequestAsync (IRequest httpReq, IResponse httpRes, System.String operationName) [0x00000] in <filename unknown>:0
    
2015-05-08 12:38:22.2282 Error - HttpAsyncTaskHandler: Failed to write error to response: {0}
    *** Error Report ***
    Version: 3.0.5597.1
    Command line: /Applications/MediaBrowser.Server.Mac.app/Contents/MacOS/MediaBrowser.Server.Mac
    Operating system: Unix 14.3.0.0
    Processor count: 4
    64-Bit OS: False
    64-Bit Process: False
    Program data path: /Users/something/.config/mediabrowser-server
    Mono: 3.12.1 ((detached/0849ec7)
    Application Path: /Applications/MediaBrowser.Server.Mac.app/Contents/MonoBundle/MediaBrowser.Server.Mac.exe
    Write failure
    System.IO.IOException
     at System.Net.Sockets.NetworkStream.Write (System.Byte[] buffer, Int32 offset, Int32 size) [0x00000] in <filename unknown>:0
     at SocketHttpListener.Net.ResponseStream.InternalWrite (System.Byte[] buffer, Int32 offset, Int32 count) [0x00000] in <filename unknown>:0
     at SocketHttpListener.Net.ResponseStream.Write (System.Byte[] buffer, Int32 offset, Int32 count) [0x00000] in <filename unknown>:0
     at System.IO.StreamWriter.FlushBytes () [0x00000] in <filename unknown>:0
     at System.IO.StreamWriter.FlushCore () [0x00000] in <filename unknown>:0
     at System.IO.StreamWriter.Flush () [0x00000] in <filename unknown>:0
     at ServiceStack.Text.JsonSerializer.SerializeToStream (System.Object value, System.Type type, System.IO.Stream stream) [0x00000] in <filename unknown>:0
     at ServiceStack.Text.JsonSerializer.SerializeToStream[Object] (System.Object value, System.IO.Stream stream) [0x00000] in <filename unknown>:0
     at ServiceStack.Serialization.JsonDataContractSerializer.SerializeToStream[Object] (System.Object obj, System.IO.Stream stream) [0x00000] in <filename unknown>:0
     at ServiceStack.Host.ContentTypes.<GetStreamSerializer>b__5 (IRequest r, System.Object o, System.IO.Stream s) [0x00000] in <filename unknown>:0
     at ServiceStack.Host.ContentTypes+<>c__DisplayClass2.<GetResponseSerializer>b__1 (IRequest httpReq, System.Object dto, IResponse httpRes) [0x00000] in <filename unknown>:0
     at ServiceStack.HttpResponseExtensionsInternal.WriteErrorToResponse (IResponse httpRes, IRequest httpReq, System.String contentType, System.String operationName, System.String errorMessage, System.Exception ex, Int32 statusCode) [0x00000] in <filename unknown>:0
     at ServiceStack.ServiceStackHost.OnUncaughtException (IRequest httpReq, IResponse httpRes, System.String operationName, System.Exception ex) [0x00000] in <filename unknown>:0
     at ServiceStack.HostContext.RaiseUncaughtException (IRequest httpReq, IResponse httpRes, System.String operationName, System.Exception ex) [0x00000] in <filename unknown>:0
     at ServiceStack.Host.Handlers.HttpAsyncTaskHandler.HandleException (IRequest httpReq, IResponse httpRes, System.String operationName, System.Exception ex) [0x00000] in <filename unknown>:0
    InnerException: System.Net.Sockets.SocketException
    The socket has been shut down
     at System.Net.Sockets.Socket.Send (System.Byte[] buf, Int32 offset, Int32 size, SocketFlags flags) [0x00000] in <filename unknown>:0
     at System.Net.Sockets.NetworkStream.Write (System.Byte[] buffer, Int32 offset, Int32 size) [0x00000] in <filename unknown>:0
    
2015-05-08 12:38:22.2382 Error - HttpAsyncTaskHandler: Error occured while Processing Request: User with Id e3d51704c5fa809bae5530229b96f4b1 not found
    *** Error Report ***
    Version: 3.0.5597.1
    Command line: /Applications/MediaBrowser.Server.Mac.app/Contents/MacOS/MediaBrowser.Server.Mac
    Operating system: Unix 14.3.0.0
    Processor count: 4
    64-Bit OS: False
    64-Bit Process: False
    Program data path: /Users/something/.config/mediabrowser-server
    Mono: 3.12.1 ((detached/0849ec7)
    Application Path: /Applications/MediaBrowser.Server.Mac.app/Contents/MonoBundle/MediaBrowser.Server.Mac.exe
    User with Id e3d51704c5fa809bae5530229b96f4b1 not found
    MediaBrowser.Controller.Net.SecurityException
     at MediaBrowser.Server.Implementations.HttpServer.Security.AuthService.ValidateUser (IServiceRequest request, IAuthenticationAttributes authAttribtues) [0x00000] in <filename unknown>:0
     at MediaBrowser.Server.Implementations.HttpServer.Security.AuthService.Authenticate (IServiceRequest request, IAuthenticationAttributes authAttribtues) [0x00000] in <filename unknown>:0
     at MediaBrowser.Controller.Net.AuthenticatedAttribute.RequestFilter (IRequest request, IResponse response, System.Object requestDto) [0x00000] in <filename unknown>:0
     at ServiceStack.ServiceStackHost.ApplyRequestFiltersSingle (IRequest req, IResponse res, System.Object requestDto) [0x00000] in <filename unknown>:0
     at ServiceStack.ServiceStackHost.ApplyRequestFilters (IRequest req, IResponse res, System.Object requestDto) [0x00000] in <filename unknown>:0
     at ServiceStack.Host.RestHandler.ProcessRequestAsync (IRequest httpReq, IResponse httpRes, System.String operationName) [0x00000] in <filename unknown>:0
 

 

Hope it helps because i have tried trashing the users.db file and reinstalling the server and ends up doing the same :(



#4 shadowcharly OFFLINE  

shadowcharly

    Newbie

  • Members
  • 3 posts

Posted 12 May 2015 - 04:59 AM

Same behaviour with Version 3.0.5597.1. :(
First scan after start up goes ok, whenever another library scan goes up, it freezes at 0%

#5 geno27 OFFLINE  

geno27

    Advanced Member

  • Members
  • 44 posts
  • Local time: 12:55 PM

Posted 05 June 2015 - 02:05 PM

I am continuing to see this problem with the mac server. I was wondering if there is any update on progress since I see other users also ran into this issue as well. I actually stopped using the mac server in April and went back to Windows because of all the issues The windows server works very well and I decided to try the mac again after a few months. I have updated to the latest server 3.0.5621.4 but it only seems to have gotten worse. If I am lucky the server will start up and complete one full scan. Any scans after that get stuck at 0%. Other times the server will just stop responding after awhile, which is usually accompanied by the server's version information disappearing from the dashboard page (as shown below). Trying to exit the server causes it to freeze and I have to restart my mac. At this point the mac server is unusable to me and I am wondering how it is working for others. I would continue to use the windows server but I only bring my mac when I travel. Which means I am forced to turn off emby and use plex now. Any help would be appreciated. Thanks.

 

log

 

5571e290ca270_ScreenShot20150605at12340P



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152578 posts
  • Local time: 12:55 PM

Posted 05 June 2015 - 02:19 PM

For starters, can you remove all plugins and then repeat the test? thanks.



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152578 posts
  • Local time: 12:55 PM

Posted 05 June 2015 - 02:20 PM

And then can you also post a log in a plain txt file? That format is difficult to read. Thanks.



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152578 posts
  • Local time: 12:55 PM

Posted 05 June 2015 - 02:46 PM

There is one error in your log though that I believe will be resolved for the  next release, so that will be worth trying.



#9 geno27 OFFLINE  

geno27

    Advanced Member

  • Members
  • 44 posts
  • Local time: 12:55 PM

Posted 05 June 2015 - 03:01 PM

Thanks for the quick response Luke.  I removed the plugins and restarted the server. The first library scan was fine but a few mins later the organize media files process started, which then restarted another library scan. According to the dashboard, the Organize process stopped at 99% and the library scan froze at 0%. However, the server itself does seem to hang up a lot less without the plugins, as I am now able to exit the server without freezing.

 

Here is the new log, hopefully it saved as plain txt. log

 

5571f192c207c_ScreenShot20150605at25222P



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152578 posts
  • Local time: 12:55 PM

Posted 05 June 2015 - 03:06 PM

try also refreshing the page just to make sure it's not simply an issue of the progress bar on the screen.



#11 geno27 OFFLINE  

geno27

    Advanced Member

  • Members
  • 44 posts
  • Local time: 12:55 PM

Posted 05 June 2015 - 03:12 PM

Yes it is still there after multiple page refreshes. In fact, its still there from when it originally started 20 mins ago. I have found previously that hitting the stop buttons only cause each process to show "Stopping" in red, which then remains there. Restarting the sever is the only way to get rid of it.



#12 shadowcharly OFFLINE  

shadowcharly

    Newbie

  • Members
  • 3 posts

Posted 17 June 2015 - 06:47 AM

Solved with version

Version 3.0.5641.4

 

At least the basic "Restart, let initial scan finish, force rescan in scheduled tasks" test i used to check for the library scan freeze ^.^

 

It seems to be working again, so thanks!



#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152578 posts
  • Local time: 12:55 PM

Posted 17 June 2015 - 11:10 AM

Well done.







Also tagged with one or more of these keywords: osx, server

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users