Jump to content

Subtitle display problem


fc7
 Share

Recommended Posts

First of all great app!

 

I have a problem with subtitles that I can repro with version 0.585 and 0.587.

When I play a show with subtitles (movies or tv it's the same) very often I see that instead of displaying the correct text for the scene the app will display several lines at a time (current scene and the next few seconds) showing the subtitle timing and for the next few seconds no subs will be displayed.

 

Please find attached two screenshots of the problem.

I can repro the issue with any video with subtitles enabled but I can't repro the problem with the web client or the iOS app. I also checked with other video players (vlc, infuse, kodi) and I couldn't repro the problem.

 

I also have a short video (15 secs or so) that I did while reproducing the issue. Let me know if you want me to upload it.

 

Thanks!

post-29162-0-18207100-1428436453_thumb.jpg

post-29162-0-24141300-1428436466_thumb.jpg

Edited by fc7
Link to comment
Share on other sites

FrostByte

I can't even get subtitles to load in most movies since 585 :)

Edited by FrostByte
Link to comment
Share on other sites

chessdragon136

Frost - Check 588, if not then i don't know

 

As for the issue at hand, I use a third party open source srt parser to go through the file and create the subs to display - looking at it there is either an issue with the srt file on that particular film or the parser isn't as robust as i believed... Either way im not sure what i can do short term.

 

I'll look into it but im not hopeful... 

  • Like 1
Link to comment
Share on other sites

you can instead download them in js format and you'll get an object with each line already separated for you

Link to comment
Share on other sites

Frost - Check 588, if not then i don't know

 

As for the issue at hand, I use a third party open source srt parser to go through the file and create the subs to display - looking at it there is either an issue with the srt file on that particular film or the parser isn't as robust as i believed... Either way im not sure what i can do short term.

 

I'll look into it but im not hopeful...

 

I can repro the problem with every video file with external subs I tried but only in this app. With any other app the subs play correctly.

If you want me to test anything just let me know.

  • Like 1
Link to comment
Share on other sites

chessdragon136

you can instead download them in js format and you'll get an object with each line already separated for you

 

Please tell me how to do this magical thing! I've obviously missed it / it came in after I made this!

Link to comment
Share on other sites

in the url you're using to download the subtitles just change the extension from srt to js

Link to comment
Share on other sites

chessdragon136

Ok tried the JS format but the returned result is not JSON compliant due to \r \n in the subtitle strings. Can you look at parsing the strings server side please. 

Link to comment
Share on other sites

  • 4 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...