Jump to content

[DEV]Vu+ / Enigma2 Live TV plugin


CompoUK
 Share

Recommended Posts

Hi,

I've started work on a new Vu+ / Enigma2 Live TV plugin.

I'm new to most of the technologies used in developing this so please be patient with me!

DEV version can now be installed.
It's now on Github so please feel free to help out with this plugin - https://github.com/CompoUK/MediaBrowser.Plugins.VuPlus

CompoUK.


Known Issues / Limitations

Genres are set to 'Unknown'.
No Series related functionality.
If paths are entered on the config page then remember to end them with a slash


Setup on Vu+ / Enigma2
Ensure openWebIf is installed and running - go into settings and make a note of them so they can be entered on the MediaBrowser Vu+ config page.


Setup on MediaBrowser server
Install Vu+ plugin and restart MediaBrowser server.
Go to config page for Vu+ and amend default contents as follows (at a minimum, the first 3 must be entered):

Vu+ hostname or ip address:
The host name (address) or ip address of your Vu+ receiver

Vu+ streaming port:
The Streaming port of your Vu+ receiver eg. 8001 / 8002

Vu+ Web Interface port:
The web Interface port of your receiver eg. 8000

Vu+ Web Interface username:
The web Interface username of your receiver (optional)
Vu+ Web Interface password:
The web Interface password of your receiver (optional)

Use secure HTTP (HTTPS):
Use HTTPS instead of HTTPS to connect to your receiver

Fetch Only one TV bouquet:
Limit channels to only those contained within the specified TV Bouquet below (optional)
Vu+ TVBouquet:
The TV Bouquet to load channels for (optional - only required if 'Fetch Only one TV bouquet' set)

Zap before Channel switch (single tuner)
Set if only one tuner within receiver to make tuner jump to channel

Fetch picons from webinterface:
Set if you want to retrieve Picons from the web interface of the receiver
Picons Path:
The local location of your Picons (must end with appropriate slash) eg. C:\Picons\ (optional - only required if 'Fetch picons from webinterface' is not set)

Recording Path:
The location to store your recordings on your receiver (must end with appropriate slash) eg. /hdd/movie/ (optional)

Enable VuPlus debug logging:
Plugin Debugging



Version History

1.0.0.0 - 06/03/2015
Initial Version

1.0.0.1 - 06/03/2015
Added recording directory to config.
Added text to config page.
Added additional debugging info.

1.0.0.2 - 07/03/2015

Additional logging
Locally stored picons should now be found

1.0.0.3 - 12/03/2015
Fix version number of plugin

1.0.0.4 - 20/03/2015
Update due to changes in ILiveTvService


1.0.0.5 - 01/04/2015
Since we have no way to know if Video is interlaced, just set indicator to true so that the server will deinterlace.
As per request from Luke.

1.0.0.6 - 02/04/2015
Fix EPG times

1.0.0.7 - 05/04/2015
EPG fix

1.0.0.8/1.0.0.9 - 06/04/2015
Scheduled events timezone fix

Edited by CompoUK
  • Like 7
Link to comment
Share on other sites

 

Hi,

 

I've started work on a new Vu+ / Enigma2 Live TV plugin.

 

I'm new to most of the technologies used in developing this so please be patient with me!

 

DEV version can now be installed.

 

CompUK.

 

 

Version History

-----------------------

 

1.0.0.0 - 06/03/2014

Initial Version

 

1.0.0.1 - 06/03/2014

Added recording directory to config.

Added text to config page.
Added additional debugging info.

 

Nice :) what is the setup procedure both in Vu+ and MB3 ? Like a setup guide?

Link to comment
Share on other sites

Nice :) what is the setup procedure both in Vu+ and MB3 ? Like a setup guide?

 

I've added details to the first post, hope that helps.

  • Like 1
Link to comment
Share on other sites

 

Hi,

 

I've started work on a new Vu+ / Enigma2 Live TV plugin.

 

I'm new to most of the technologies used in developing this so please be patient with me!

 

DEV version can now be installed.

 

CompUK.

 

 

 

Setup on Vu+ / Enigma2

Ensure openWebIf is installed and running - go into settings and make a note of them so they can be entered on the MediaBrowser Vu+ config page.

 
 

 

Very Nice -I'II provide feedback, thanks 4 the efforts. 

Edited by e123enitan
Link to comment
Share on other sites

Very Nice -I'II provide feedback, thanks 4 the efforts. 

 

 

Hi Vu settings looks fine, except when I launch a channel, nothing populate, attached is a log, I noticed an errors in each level of channel which I tested or try to watch,thanks for the efforts, let me know when to retest.

 

 

 

Link to comment
Share on other sites

Hi Vu settings looks fine, except when I launch a channel, nothing populate, attached is a log, I noticed an errors in each level of channel which I tested or try to watch,thanks for the efforts, let me know when to retest.

 

 

attachicon.gifserver-63561261540.txt

 

had a quick look and noticed a few things..

 

1. Your picons were not being picked up as it looks like you store them locally - this should be fixed in latest version.

2. Your epg appears to be empty according to the logs. Is this correct?

Link to comment
Share on other sites

Just posting thanks for the efforts.

Looking forward to when i'm going to be able to get rid of MCE and DVBlink in one go.

 

Please keep us posted when known limitations are implemented. I will be watching the topic. Thank you.

Link to comment
Share on other sites

See first post regarding Channel playback issue.

Details copied below:

 

Known Issues / Limitations

 

Issues with playback of Channels - Just installed on another pc with same configuration and playing of Channels is not working.

I cleared out my library.db and refreshdata.db on my development pc and playback of channels has stopped working now.

Will have to investigate why. 

 

Genres are set to 'Unknown'.

No Series related functionality.

 

 

 

Sorry about this, will investigate and get back to you.

  • Like 1
Link to comment
Share on other sites

had a quick look and noticed a few things..

 

1. Your picons were not being picked up as it looks like you store them locally - this should be fixed in latest version. This correct its stored locally, but with same setting it work on Kodi meaning picon displayed,

2. Your epg appears to be empty according to the logs. Is this correct? Correct the channels currently in my Bouquet are on 97w so doesn't have EGP.

Link to comment
Share on other sites

See first post regarding Channel playback issue.

Details copied below:

 

Known Issues / Limitations

 

Issues with playback of Channels - Just installed on another pc with same configuration and playing of Channels is not working.

I cleared out my library.db and refreshdata.db on my development pc and playback of channels has stopped working now.

Will have to investigate why. 

 

Genres are set to 'Unknown'.

No Series related functionality.

 

 

 

Sorry about this, will investigate and get back to you.

No worries, Pls take your time, no rush, let me know when to retest.

I hope you won't my with support for my Vu+ Plus setup, I just had it for few weeks and it has been a challenge getting use to, although I have openwebif and Vu+/Enigma Kodi working fine.

 

Thanks

Link to comment
Share on other sites

Hi C-UK, are good to resumed testing, waiting for you give a go ahead,

Out this thread, I watch 110, 119 on box, I missing EPG and Picon any ideal on how to active these functions,

I have search several sites in Vu+Net no help, appreciate your support.

 

Cheers!

Link to comment
Share on other sites

Hi C-UK, are good to resumed testing, waiting for you give a go ahead,

Out this thread, I watch 110, 119 on box, I missing EPG and Picon any ideal on how to active these functions,

I have search several sites in Vu+Net no help, appreciate your support.

 

Cheers!

I would suggest you make a post on http://www.vuplus-community.net/ and see what responses you get back.

 

Going back to this plugin............

 

I'm still having issues with playing Channels, you click on the 'Play' button and nothing happens.

Investigating, I have found the following:

 

Click on 'Play' button for live tv channel:
 
Error shown in Chrome Console:
Uncaught TypeError: Cannot read property 'Type' of undefined
 
request:
response:
{"Items":[],"TotalRecordCount":0}
 
Channel in DB:
 
MediaBrowser.Controller.LiveTv.LiveTvChannel
{"Number":"1","ExternalId":"1:0:1:283D:7FE:2:11A0000:0:0:0:","ChannelType":"TV","ServiceName":"VuPlus","ProviderImageUrl":"http://192.168.0.14:8000/picon/1_0_1_283D_7FE_2_11A0000_0_0_0.png","HasProviderImage":true,"ImageInfos":[{"Path":"C:\\Users\\Kevin\\AppData\\Roaming\\MediaBrowser-Server\\metadata\\livetv\\4720c71a39ec99203c9d841e7c366afc\\metadata\\folder.png","Type":"Primary","DateModified":"2015-03-09T19:35:21.6515145Z"}],"IsInMixedFolder":false,"Name":"BBC One W Mid","Id":"4720c71a39ec99203c9d841e7c366afc","DateCreated":"2015-03-11T07:44:28.2573626Z","DateModified":"0001-01-01T00:00:00.0000000Z","DateLastSaved":"2015-03-11T07:44:28.5423789Z","DontFetchMeta":false,"IsUnidentified":false,"LockedFields":[],"People":[],"Studios":[],"Genres":[],"ProviderIds":{}}
 
One of the Programs in DB:
MediaBrowser.Controller.LiveTv.LiveTvProgram
{"ExternalId":"1:0:1:283D:7FE:2:11A0000:0:0:0:~1939~2~1758817873","ExternalChannelId":"1:0:1:283D:7FE:2:11A0000:0:0:0:","ChannelType":"TV","StartDate":"2015-03-11T09:15:00.0000000Z","IsHD":false,"IsRepeat":false,"ServiceName":"VuPlus","ProviderImageUrl":"http://192.168.0.14:8000/picon/1_0_1_283D_7FE_2_11A0000_0_0_0.png","HasProviderImage":true,"IsMovie":false,"IsSports":false,"IsSeries":false,"IsLive":false,"IsNews":false,"IsKids":false,"IsPremiere":false,"ImageInfos":[{"Path":"C:\\Users\\Kevin\\AppData\\Roaming\\MediaBrowser-Server\\metadata\\livetv\\d5d3452e868424c19e46608655d1fc74\\folder.png","Type":"Primary","DateModified":"2015-03-11T07:45:02.8043385Z"}],"IsInMixedFolder":false,"Name":"Heir Hunters","Id":"d5d3452e868424c19e46608655d1fc74","DateCreated":"2015-03-11T07:44:29.4054282Z","DateModified":"2015-03-11T07:44:29.4054282Z","DateLastSaved":"2015-03-11T07:45:02.8063387Z","DontFetchMeta":false,"IsUnidentified":false,"LockedFields":[],"EndDate":"2015-03-11T10:00:00.0000000Z","Overview":"13/20. The search for the relatives of an Essex man leads the heir hunters to Wales. Also in HD. ","People":[],"Studios":[],"Genres":["Unknown"],"RunTimeTicks":27000000000,"ProviderIds":{}}
 
If a developer could take a look that would be great, as I'm really struggling to work out what is going wrong

 

Thanks.

  • Like 1
Link to comment
Share on other sites

That's fixed in dev and in source

 

Thanks Luke.

Just tested and channel are now playing using the latest DEV version of MediaBrowser

Edited by CompoUK
Link to comment
Share on other sites

Thx Luke,  We back on course  :) , let me know when to resumed testing.

I working hard to get EPG and PICON on Vu+ for testing also.

 

Cheers!

Link to comment
Share on other sites

Thx Luke,  We back on course  :) , let me know when to resumed testing.

I working hard to get EPG and PICON on Vu+ for testing also.

 

Cheers!

You should be good to start testing again as long you download the latest dev version of MediaBrowser.

  • Like 1
Link to comment
Share on other sites

You should be good to start testing again as long you download the latest dev version of MediaBrowser.

 

I will give it try when I get home-Great nice job

 

Edited by e123enitan
Link to comment
Share on other sites

While in the Dev mode, I couldn't update the latest plug 1.0.2, as many times that I restarts the server or closed the computer down for a clean restart it doesn't seems to update, I have added a log for your review.

 

Thanks

 

 

Link to comment
Share on other sites

While in the Dev mode, I couldn't update the latest plug 1.0.2, as many times that I restarts the server or closed the computer down for a clean restart it doesn't seems to update, I have added a log for your review.

 

Thanks

 

attachicon.gifserver-63561701886.txt

Tried this myself and the plugin appears to update but the version shown in the logs still thinks your on 1.0.0.0 when you restart MediaBrowser server hence it thinks you need to update again and again.

Need to find out how version checking of plugins works. Even though you got the message, did you try using the plugin to see Vu+ content?

 

2015-03-12 07:50:57.6579 Info - App: Loading MediaBrowser.Plugins.VuPlus, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null

Link to comment
Share on other sites

I updated the server to Dev version and also updated plugin (have the same problems as e123enitan regarding update / restart prompts)  I still cant get it to stream and play remotely via Chrome but interestingly it plays fine (albeit) slow via the android app on my phone.

Link to comment
Share on other sites

While in the Dev mode, I couldn't update the latest plug 1.0.2, as many times that I restarts the server or closed the computer down for a clean restart it doesn't seems to update, I have added a log for your review. resolved

Congrat "I am now able to play Live TV through VuPlus" :D excellent Job, You've nailed it I think that is the main issue the rest will be resolved in no time. 

However, I noticed that Picon did not dispalyed  on I.0.3, so I changed the location to C:\Users\Dell 9020\Desktop\Picon from \\WDMYCLOUDEX4\Public_2\Logos, this cause all tuners to disappear hence no TV channels is displayed, then I change it back and then restart server, then TV channels lisiting resumed but no Picon still.

 

On my Kodi Live TV the Picon path is set to  =>>\\WDMYCLOUDEX4\Public_2\Logos, and this work fine, not sure why MB3 did not show ;)

 

I have attached few logs, not meant to overwheelm you but hope it provide sufficient info to establish the issue

 

Cheers! Nice Big One

 

 

 

 

 

 

 

 

Edited by e123enitan
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...