Jump to content

Can't display subtitles with MP4 with srt file


jackblades
Go to solution Solved by Luke,

Recommended Posts

Version: 3.0.5490.2

 

Hi Everyone,

 

I'm a new user to MB3 and I'm having problems with subtitles. .mkv files seems to work just fine but I'm having issues watching an mp4 movie with .srt subtitles.

 

The movie works well using VLC and I can view the movie by just dropping it into my browser (no subtitles though)

 

Any thoughts?

 

I'm using the latest version of the server and app (as of 2/16/15). I have uninstalled and re-installed MB3 yet this didn't solve the issue. I haven't changed the server settings at all except for turning down the transcoder to "auto".
 
The movie looks fine, just no subtitles and no "T" button at the top left letting me choose which subtitles to use. Is there a special format needed for external subs?
 
I can post log files if needed.
 
Thanks
Edited by jackblades
Link to post
Share on other sites

What app?

 

And, as stated in our docs, I'm afraid "Latest version" doesn't mean much as there are multiple possible versions that could be "latest" at any given time.  Please provide actual version numbers.  Thanks.

Link to post
Share on other sites
  • Solution

you probably want to check your naming convention that you used on the srt files as well. if you click the help button in the library setup area it goes over the supported naming conventions for subtitles.

  • Like 1
Link to post
Share on other sites

Edit: Subtitles don't seem to work when done through the android app, Version 2.2.03, but I suppose that is a separate issue

 

Sorry, getting used to this! 

 

After setting the "Download subtitles for" settings in metadata->subtitles it has pulled down a srt file which is recognized. 

 

The original name was: Paprika (2006) 1080p [Jpn 5.1 & Eng 5.1] Blu-ray English.srt

The now recognized is: Paprika (2006) 1080p [Jpn 5.1 & Eng 5.1] Blu-ray.eng.srt

 

I'm guessing it was the naming convention. I'm having another issue now but I'll make a new topic. Thanks!

Edited by jackblades
  • Like 1
Link to post
Share on other sites
  • 1 year later...

Maybe you have failed to add the subtitle to the video. Just try it again, if the problem persists, you may consider using other programs, like video converter studio or Windows Movie Maker. I found a post that offers detailed instructions about how to merge subtitle to MP4 video. I think that will help you. Good luck.

Link to post
Share on other sites
  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...