Jump to content

Help with LAV filters and AC3


mboehler
 Share

Recommended Posts

mboehler

This started in a separate thread, but it started going off topic, so I'm starting a new one here.  The quotes contain some relevant information from the original thread.

 

I've discovered this has nothing to do with MB.

 

Basically, configuring the LAV audio decoder properties to enable SPDIF bitstreaming of AC-3 seems to cause the problem to start. Disabling AC-3 in there makes the problem go away, but then I'm just outputting stereo PCM over SPDIF.  I'll dig into the issue over on the Doom9 forum or other places and see if I can find a resolution. I'll report it back, eventually, to help anyone else who sees it.

 

Sorry for implicating MB in this. My order of operations in configuring things had the MB configurator setup and the Audio properties closely paired. My bad!

 

Marc

 

 

I am having this problem as well.  If I have AC3 checked in LAV, some files refuse to play in WMC.  They WILL play in Windows Media Player though, which is strange.  If I disable AC3, it will play, but I have to crank up the stereo in order to hear it properly.

 

I'll be heading over to http://www.thehtpc.net to see if I can find out what's up with this and how to fix it.  If you figure anything out, would you please let me know?  I will do the same for you.

Thanks!

 

 

WMP and WMC use different codecs.  Especially if you are on a x64 OS.

 

I'm not sure of all the details of Marc's problem, but here's what mine are:

 

I was having some issues with one of my HTPC's, so I reloaded Windows 7 (64bit) from scratch, did all the Windows updates, installed LAV filters using this guide, and installed MB Classic.

 

My HTPC outputs via HDMI to my Onkyo HT-S5500 stereo.  The stereo supports all of the Btistreaming formats below, so I have them all checked.

 

5277c1c63f78a_lav1.jpg

 

Almost all of my media plays correctly.  However, I do have a few files that have problems if I have the Dolby Digital (AC-3) box checked.

 

One movie in particular, The Last Exorcism, refuses to play at all through MB Classic via WMC (or WMC directly).  It WILL, however, play in Windows Media Player.  If I uncheck the Dolby Digital (AC-3) box, it plays fine.  This is not the only file that does it; there are a few others.  I am just using this one as an example.

 

Another movie, Dragonslayer, will play but the sound is delayed by 1 - 2 seconds if I have the box checked.

 

5277c1f4b9530_lav2.jpg

 

So the simple solution, it sounds like, would be just to leave this unchecked.  But if I do that, other media files, like Life After People, have really low audio levels, and I need to really crank up the stereo to hear them.

 

5277c225d625c_lastexorcism.jpg  

 

Life After People - S01E01:

5277c31b30d40_lifeafterpeople.jpg

 

Does anyone have any suggestions about where to go from here?  What can I do to help determine what is causing the issue?   Any help would be appreciated!

Link to comment
Share on other sites

Della Dog

Try un-checking AAC and/or ac3 in LAV Splitter under Input Formats.

 

(Tried uploading an image but seems broken today)

Edited by pdcinc
  • Like 1
Link to comment
Share on other sites

mboehler

Try un-checking AAC and/or ac3 in LAV Splitter under Input Formats.

 

(Tried uploading an image but seems broken today)

 

Thanks for the suggestion!

 

 I tried unchecking first ac3, then aac, then both in LAV Splitter.  As long as I still had Dolby Digital (AC-3) checked in LAV Audio Configuration, it didn't seem to make a difference.  WMC still gave me the codec error trying to play The Last Exorcism.

 

5277f07c6a624_LAVsplitter.jpg

 

I know the codecs for Windows Media Center are different from the ones for Windows Media Player.  But what I don't understand is why one will play when the other doesn't.  Or what I can do to fix it.

 

Thanks!

Link to comment
Share on other sites

mboehler

Try un-checking AAC and/or ac3 in LAV Splitter under Input Formats.

 

(Tried uploading an image but seems broken today)

 

Hmm.. I think I may have fixed it.  I think what you said was correct, but just in the wrong area (or maybe I was just looking in the wrong area!).  I found the Formats tab in the LAV Audio Configuration and unchecked ac3 there.  Everything started working!

 

Incidentally I updated to LAV 0.59 (which was released yesterday) during all this.  I don't think that had anything to do with it, however.

 

5277fa84e0762_lavaudio.jpg

Link to comment
Share on other sites

As a test try downloading MPC-HC. After configuring the LAV audio with your various formats including AC3 see if your trouble files play. If so, trouble isn't LAV. Use GraphUtil to see what else is involved. If the problem does happen in mpchc then probably it's a LAV bug in need of reporting!

Link to comment
Share on other sites

Della Dog

Hmm.. I think I may have fixed it.  I think what you said was correct, but just in the wrong area (or maybe I was just looking in the wrong area!).  I found the Formats tab in the LAV Audio Configuration and unchecked ac3 there.  Everything started working!

 

Incidentally I updated to LAV 0.59 (which was released yesterday) during all this.  I don't think that had anything to do with it, however.

 

5277fa84e0762_lavaudio.jpg

 

That's great. I remember having similar issues with Dolby Digital & couldn't figure out why it worked in one player and not the other. 

Link to comment
Share on other sites

mboehler

As a test try downloading MPC-HC. After configuring the LAV audio with your various formats including AC3 see if your trouble files play. If so, trouble isn't LAV. Use GraphUtil to see what else is involved. If the problem does happen in mpchc then probably it's a LAV bug in need of reporting!

 

I downloaded and installed MPC-HC, changed my settings back to how they were originally, and everything seems to work fine.  So, the trouble isn't LAV apparently.  I guess it's just an issue with Windows Media Center.  I kind of expected that, though, since it played fine in Windows Media Player.

 

I guess I could use MPC-HC as an external player and bypass the WMC problems, but I'd rather just stick with WMC.

 

Thanks, everyone!

Link to comment
Share on other sites

mboehler

Use graphedit to see if something else is being used when trying to play those files.

 

Okay, I downloaded graphedit.  But I don't really know how to use it.

 

If I have ac3 selected in the LAV Audio Configuration Formats, it looks like the top graph.  If I don't have ac3 selected, it looks like the bottom graph:

52780b8a1405c_graph.jpg

 

But what does that tell me about how WMC is trying to play it?

Edited by mboehler
Link to comment
Share on other sites

mboehler

Try using this tool to make sure LAV is your preferred directshow filter for WMC.

 

Thanks gthrift.  I used the Win7DSFilterTweaker 5.9 from this guide, and did exactly what it said: 

 

We’re only going to mess with Preferred decoders, so go ahead and click on that button.  We’ll get a much larger configuration box open up.  If you’re on x64 platform like me, you’ll get configuration options for both 32-bit and 64-bit systems.  Otherwise, you’ll get 32-bit only.  I only need to configure the 64-bit side since Media Center’s internal player utilizes the 64-bit version of Windows Media Player.

What we’re going to do is choose USE MERIT as the preferred decoder for all VIDEO formats, with the exception of WMV files (unless you just want to).  For all AUDIO formats, select LAV Audio.  Once complete, click the Apply & Close button, which returns us to the initial options box.  Just click Exit when there to close the tweaker application.

We’re done with the software portion!  Let’s go to Media Center and test it out!

 

Here's a couple of screenshots of how I have it setup.  I don't see any reference to WMC in it, however.

527815a4c07a3_tweak1.jpg

527815b163aeb_tweak2.jpg

527815bda5264_tweak3.jpg

527815ca7da65_tweak4.jpg

Link to comment
Share on other sites

Della Dog

I downloaded and installed MPC-HC, changed my settings back to how they were originally, and everything seems to work fine.  So, the trouble isn't LAV apparently.  I guess it's just an issue with Windows Media Center.  I kind of expected that, though, since it played fine in Windows Media Player.

 

I guess I could use MPC-HC as an external player and bypass the WMC problems, but I'd rather just stick with WMC.

 

Thanks, everyone!

Might still be a problem with LAV. Check the new update:

 

LAV Filters 0.59.1

Code:

LAV Splitter

- Fixed a regression when demuxing AAC audio from MP4/MOV file

 

(Emphasis added. pdcinc)

This version only includes a small regression fix, surprisingly the only one that showed up after more then 24 hours in the wild, i fully expected more issues after such a long time between releases and many changes in FFmpeg.

 

Anyway, take care!

__________________

LAV Filters - open source ffmpeg based media splitter and decoders - including the NVIDIA CUVID Hardware decoder

user_offline.gif  

 

Edited by pdcinc
  • Like 1
Link to comment
Share on other sites

I downloaded and installed MPC-HC, changed my settings back to how they were originally, and everything seems to work fine.  So, the trouble isn't LAV apparently.  I guess it's just an issue with Windows Media Center.  I kind of expected that, though, since it played fine in Windows Media Player.

 

I guess I could use MPC-HC as an external player and bypass the WMC problems, but I'd rather just stick with WMC.

 

Thanks, everyone!

 

First, loving the thread. IT's giving me hope for fixing my own "framestep stuttering in MPC-HC" issue.

 

Second: Turns out I actually use something called "Graphstudio" though it looks awfully much like graphedit. However, what's odd is that your source file is showing up twice in the graph... I'm more used to a single tree like this:

 

52783101c87a0_Graph.jpg

(note, this is not on my production HTPC, but a test machine, and ffdshow is currently default for WMC on this machine)

 

So my assumption is that there is a conflict going on, but again I might be ignorant of the differences of graphedit versus graphstudio.

 

I'm going to play around with Formats just as you did (in the MPC-HC embedded LAV), but even if I take LAV audio decoder out of the loop, I've got a problem because I need the audio delay feature of LAV (or of a comparable decoder) to cure a 2-3 frame audio sync issue.

 

I was originally intending to stay within WMC, but I found a problem that it seems to not show the rightmost column of pixels, and stretch things to compensate, and this throws off pixel mapping on 1080p sets. Usually not too noticeable other than lack of sharpness, but occasionally annoying moire patterns... Haven't found a solution yet. Over the past week or two, I've been complaining about it on various boards and people are saying things like "wow! never noticed that before!". So, I'm using MPC-HC as my main player now...

 

Marc

Link to comment
Share on other sites

mboehler

Might still be a problem with LAV. Check the new update:

 

LAV Filters 0.59.1

Code:

LAV Splitter

- Fixed a regression when demuxing AAC audio from MP4/MOV file

 

(Emphasis added. pdcinc)

This version only includes a small regression fix, surprisingly the only one that showed up after more then 24 hours in the wild, i fully expected more issues after such a long time between releases and many changes in FFmpeg.

 

Anyway, take care!

__________________

LAV Filters - open source ffmpeg based media splitter and decoders - including the NVIDIA CUVID Hardware decoder

user_offline.gif  

 

 

I installed the new update and unfortunately, it still does the same thing.

 

I have it working well enough though.  By unchecking ac3 in the LAV Audio Formats, it works.  :)

Link to comment
Share on other sites

mboehler

Second: Turns out I actually use something called "Graphstudio" though it looks awfully much like graphedit. However, what's odd is that your source file is showing up twice in the graph... I'm more used to a single tree like this:

 

Mine showed up twice because I ran it twice.  I ran it once with ac3 checked and once with it not checked.  I guess it just didn't clear it off the page first. :)

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...