Jump to content

DLNA profile for LG WebOS TV


Serios
 Share

Recommended Posts

Hi,

you are right with 1st and 2nd question.

@@Serios, where I can find this ? On TV or on Emby ? I can't see this option on Emby.

Maybe tweaking user playback settings on Emby will help, try to set a preferred language and remove the check on "Play default language track regardless of language

3. @@Luke, please, is there any option how to stream multiple subtitles ?

 

4. There was problem with subtitle file. At 1st position was "dot"  left before number (.1) When I deleted that dot, then subtitles was displayed. I don't know if it is purpose to put dot at first position, or it is some conversion problem.

 

Hi,

To find Playback settings

 

go to Emby Control panel  in left column click on Users, then click on your user profile. On main screen for user settings there is a link "Edit this user's profile, image and personal preferences." click on it. Then in the tabs click on "PLAYBACK"

 

OR

 

From Home Dashboard click on the "sandwich" menu and then click on your username at the top, this will open user settings too and then go to "PLAYBACK" tab

 

Here you can tweak your playback settings

 

3. Sorry for answering before Luke (apologies @@Luke ) but as far as I know - No, there is no functionality for streaming multiply external subtitles streams at the moment.

 

4. Really don't know - Maybe is true that is some conversion problem...

Edited by Serios
Link to comment
Share on other sites

This is DLNA profile for LG WebOS TV's

 

It should work on devices from the following series:

 

 

LB7xx - Series

LB731

LB730

LB700

 

LB6xx - Series

LB679

LB671

LB670

LB652

LB651

LB650

LB630

 

LB5xx - Series

LB582

LB580

LB570

LB561

LB550

 

It may work with other WebOS devices, not listed here, but at the moment can't be confirmed, so you need to test if it will work with your particular device.

 

To use this profile:

1. Download the file attached bellow.

2. Place it in your "MediaBrowser-Server\config\dlna\user" directory

3. Restart MediaBrowser

3. Go to MediaBrowser configuration - > DLNA

4. Click on "Profiles" tab.

5. You will see LG Smart+ TV under custom profiles section

6. Have fun.

 

 

If you find something is not working quite well, please post in this thread so the profile can be tweaked. Also if you find problem and modify the file by yourself, please post the code changes in this thread using {code} {/code} tag, so that I can modify and re-upload the file. That way, we will keep the thread clean of multiply files and easy for users to download an up to date file from the first post.

 

Changelog:

22.04.2015 - Renaming Media Browser to Emby and removing unsupported subtitles format.

06.02.2015 - Little tweak to support mkv containers with  Digital Theater Systems (DTS) audio - thanks to @@yudicuba for noticing that. 

 

According to LG DEV page (http://developer.lge.com/webOSTV/develop/web-app/webos-tv-platform/supported-media-formats) , WebOS TVs support AVC media codec in mp4 container.  I can confirm that on LB700 model. You can update this profile.

Link to comment
Share on other sites

The following condition is also required for each of the Video CodecProfiles for correct transcoding of anamorphic videos. Server support for this will hopefully be in the next release, I know @@Luke is in the process of integrating and testing the changes.

 

<ProfileCondition condition="NotEquals" property="IsAnamorphic" value="true" isRequired="true" />

 

I believe you will also need a CodecProfile block for avc

Link to comment
Share on other sites

  • 2 months later...

Anyone else experiencing problems with external subtitles since with Emby 3.0.5675.1 version?
This DLNA profile worked fine before, but now my LG 730v TV does not load the external subtitles.
As far I can see, the profile is loaded as it should, however I can't find any problems in the debug log (i'm not that experienced):

-07-25 00:37:52.7215 Debug - HttpServer: HTTP POST http://192.168.100.3:8096/dlna/764f4849abe8fbfae214278be2a38094/contentdirectory/control
    Ip: 192.168.100.2:54216. Headers: SOAPAction="urn:schemas-upnp-org:service:ContentDirectory:1#Search",DLNADeviceName.lge.com=%5bLG%5d%20webOS%20TV,User-Agent=Linux/3.10.19-32.afro.5 UPnP/1.0 LGE WebOS TV LGE_DLNA_SDK/1.6.0/04.45.25 DLNADOC/1.50,Host=192.168.100.3:8096,Content-Length=739,Content-Type=text/xml; charset="utf-8"
2015-07-25 00:37:52.7371 Debug - Dlna: Found matching device profile: LG Smart+ TV
2015-07-25 00:37:52.7371 Debug - UpnpContentDirectory: Received control request Search
2015-07-25 00:37:52.7371 Debug - HttpServer: HTTP Response 200 to 192.168.100.2. Response time: 15.6 ms.
Link to comment
Share on other sites

I'm also having problem with external subtitles on a custom dlna profile for my Netcast LG TV. I don't know if it worked before, embeded subtitles work just fine.

Link to comment
Share on other sites

 

Anyone else experiencing problems with external subtitles since with Emby 3.0.5675.1 version?

This DLNA profile worked fine before, but now my LG 730v TV does not load the external subtitles.

As far I can see, the profile is loaded as it should, however I can't find any problems in the debug log (i'm not that experienced):

-07-25 00:37:52.7215 Debug - HttpServer: HTTP POST http://192.168.100.3:8096/dlna/764f4849abe8fbfae214278be2a38094/contentdirectory/control
    Ip: 192.168.100.2:54216. Headers: SOAPAction="urn:schemas-upnp-org:service:ContentDirectory:1#Search",DLNADeviceName.lge.com=%5bLG%5d%20webOS%20TV,User-Agent=Linux/3.10.19-32.afro.5 UPnP/1.0 LGE WebOS TV LGE_DLNA_SDK/1.6.0/04.45.25 DLNADOC/1.50,Host=192.168.100.3:8096,Content-Length=739,Content-Type=text/xml; charset="utf-8"
2015-07-25 00:37:52.7371 Debug - Dlna: Found matching device profile: LG Smart+ TV
2015-07-25 00:37:52.7371 Debug - UpnpContentDirectory: Received control request Search
2015-07-25 00:37:52.7371 Debug - HttpServer: HTTP Response 200 to 192.168.100.2. Response time: 15.6 ms.

Yes, I have problem with ext. subtitles too. They are not streamed to TV

Edited by coudy
Link to comment
Share on other sites

I just wanted to add that it's Direct Play (with transcoding it embeds the subtitle ok).

Also tried setting the user library to the DLNA profile in hope that it gets the settings of the user.

Subtitle language preferences are set to English

And I tried changing all the options for Subtitle Mode without any luck.

Didn't have any problems with this profile with previous version of Emby Server.

 

I can't debug the code, however I see some changes were done to the Model/DLNA/StreamBuilder and StreamInfo. A condition in StreamBuilder.GetSubtitleProfile was added if the playback method is not transcode
 

if (playMethod != PlayMethod.Transcode)
            {
                // Look for supported embedded subs
                foreach (SubtitleProfile profile in subtitleProfiles)
                {
                    if (!profile.SupportsLanguage(subtitleStream.Language))
                    {
                        continue;
                    }

                    if (profile.Method == SubtitleDeliveryMethod.Embed && subtitleStream.IsTextSubtitleStream == MediaStream.IsTextFormat(profile.Format))
                    {
                        return profile;
                    }
                }
            }

Don't know if these addition to the code are the reason that the external subtitles are not loading now, as i'm not a C# programmer and my mashine is not setup for .NET enviroment. :)

Edited by rafivanatv
Link to comment
Share on other sites

Audio
Language und
Codec AAC
Profile LC
Layout stereo
Channels 2 ch
Bitrate 120 kbps
Sample rate 48000 khz
Default Yes

Video
Codec H264
Profile High
Level 31
Resolution 720x404
Aspect ratio 16:9
Anamorphic No
Interlaced No
Framerate 23.97602
Bitrate 1053 kbps
Bit depth 8 bit
Pixel format yuv420p
Ref frames 5
CABAC Yes

Subtitle
Language eng
Codec SRT
Default No
Forced No
External Yes
Container mp4

However It's not limited only to this format of video/audio. As I said previously, it worked fine before (last time it worked for me it was like 20-30 days ago) but I don't know the actual version.

On another note not related to DLNA: Now I noticed (because I don't use the web browser for watching videos) that if you change the streaming bitrate on the web player, the subtitles are defaulted to off and they don't turn on even if I select it.

Link to comment
Share on other sites

Audio
Language und
Codec AAC
Profile LC
Layout stereo
Channels 2 ch
Bitrate 120 kbps
Sample rate 48000 khz
Default Yes

Video
Codec H264
Profile High
Level 31
Resolution 720x404
Aspect ratio 16:9
Anamorphic No
Interlaced No
Framerate 23.97602
Bitrate 1053 kbps
Bit depth 8 bit
Pixel format yuv420p
Ref frames 5
CABAC Yes

Subtitle
Language eng
Codec SRT
Default No
Forced No
External Yes
Container mp4

However It's not limited only to this format of video/audio. As I said previously, it worked fine before (last time it worked for me it was like 20-30 days ago) but I don't know the actual version.

On another note not related to DLNA: Now I noticed (because I don't use the web browser for watching videos) that if you change the streaming bitrate on the web player, the subtitles are defaulted to off and they don't turn on even if I select it.

 

 

I am able to reproduce that web client problem, but it's just an issue in the web client itself and not the profile engine. i was able to get subs both with direct stream and transcoding.

 

i think some good information would be to find out if the server is adding the subtitles to the upnp response proflie. it's always a possibility that it's there but the tv just isn't using it for whatever reason.

Link to comment
Share on other sites

Does the server send the subtitle as VideoName.language.srt? Because I believe LG TVs expect the subtitle to be exactly the same name as the video, no language codes included.

Link to comment
Share on other sites

no it's just the raw url from the server's api. i never knew that. do you know of any documentation on that or examples from other servers? 

Link to comment
Share on other sites

It probably has nothing to do with this issue, I was thinking of playing from usb instead of dlna.

Plex is working just fine, although it's not exactly dlna that is working, smart share seems to acts as a plex client of some sort, dlna profiles for plex were completely ignored, until I changed the server name in the profile in which case I got both the plex server and the renamed plex dlna (this was the only way to get transcoding in plex to work for me).

Link to comment
Share on other sites

well i think the first question is whether it's being sent back in the response xml. if you enable dlna debug logging it will dump the entire response body into the log.

Link to comment
Share on other sites

Plex's actual DLNA doesn't seem to play subtitles for me either when not transcoding (not sure if it's dlna not working, or I'm missing some kind of option), LG's SmartShare is working fine though for subtitles. I'll try to sniff the response.

Link to comment
Share on other sites

yup, if you search for srt, it's in there. the player is just not using it for whatever reason. it's possible lg has some proprietary expectation that we just aren't aware of right now

Link to comment
Share on other sites

This is the conversation with SmartShare:

TV:

POST /web/cds_control HTTP/1.1

SOAPAction: "urn:schemas-upnp-org:service:ContentDirectory:1#Browse"

DLNADeviceName.lge.com: %5bTV%5d%5bLG%5d32LB5800-ZM

User-Agent: Linux/3.0.13 UPnP/1.0 LGE_DLNA_SDK/1.6.0 [TV][LG]32LB5800-ZM/04.04.06 DLNADOC/1.50

Connection: close

Host: 192.168.1.2:49152

Content-Length: 675

Content-Type: text/xml; charset="utf-8"



<?xml version="1.0" encoding="UTF-8"?>

<s:Envelope s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><u:Browse xmlns:u="urn:schemas-upnp-org:service:ContentDirectory:1"><ObjectID>8</ObjectID><BrowseFlag>BrowseDirectChildren</BrowseFlag><Filter>res@resolution,res@nrAudioChannels,res@sampleFrequency,res@bitrate,dc:creator,res@dlna:cleartextSize,dc:date,upnp:genre,res,res@duration,res@size,upnp:albumArtURI,upnp:originalTrackNumber,upnp:album,upnp:artist,upnp:author</Filter><StartingIndex>0</StartingIndex><RequestedCount>99</RequestedCount><SortCriteria></SortCriteria></u:Browse></s:Body></s:Envelope>



SmartShare server:
HTTP/1.1 200 OK

CONTENT-LENGTH: 2347

CONTENT-TYPE: text/xml; charset="utf-8"

DATE: Fri, 31 Jul 2015 01:04:03 GMT

EXT:

SERVER: UPnP/1.0 DLNADOC/1.00 LG_Smart_Share_SDK/1.0.3

X-User-Agent: LGE_DLNA



<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><s:Body>
<u:BrowseResponse xmlns:u="urn:schemas-upnp-org:service:ContentDirectory:1">

<Result><DIDL-Lite xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/" xmlns:dlna="urn:schemas-dlna-org:device-1-0"><item id="3db1e52ff1463fc31ff4048d8da68a492" parentID="8" restricted="1"><upnp:class>object.item.videoItem.movie</upnp:class><dc:title>The Pirates! In an Adventure with Scientists! (2012)</dc:title><upnp:genre>..............</upnp:genre><dc:date>2015-06-07</dc:date><upnp:actor>Unknown</upnp:actor><SharePath>C:\Users\Alex\Downloads\Videos\Movies\The Pirates! In an Adventure with Scientists! (2012)</SharePath><FolderPath>C:\Users\Alex\Downloads\Videos\Movies\The Pirates! In an Adventure with Scientists! (2012)</FolderPath><upnp:albumArtURI>http://192.168.1.2:49152/virtual/thumb/3db1e52ff1463fc31ff4048d8da68a492/3db1e52ff1463fc31ff4048d8da68a492.jpg</upnp:albumArtURI><res protocolInfo="http-get:*:video/mp4:DLNA.ORG_PN=AVC_MP4_BL_CIF15_AAC_520;DLNA.ORG_OP=01;DLNA.ORG_FLAGS=01500000000000000000000000000000" bitrate="1993728" duration="1:28:05.000" resolution="1920x816" size="1289507013">http://192.168.1.2:49152/virtual/3db1e52ff1463fc31ff4048d8da68a492/The%20Pirates%21%20In....mp4</res><res protocolInfo="http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_TN;DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=00900000000000000000000000000000" resolution="176x136" colorDepth="24">http://192.168.1.2:49152/virtual/thumb/3db1e52ff1463fc31ff4048d8da68a492/3db1e52ff1463fc31ff4048d8da68a492.jpg</res><res protocolInfo="http-get:*:text/srt:*">http://192.168.1.2:49152/virtual/subtitle/4fc9ebec0fd414af371742a3586ddf8c6/The%20Pirates%21%20In....srt</res></item></DIDL-Lite></Result>

<NumberReturned>1</NumberReturned>

<TotalMatches>1</TotalMatches>

<UpdateID>5</UpdateID>

</u:BrowseResponse>

</s:Body> </s:Envelope>

And this is the conversation with Emby:

TV:


POST /dlna/b67df29b5c379445fde78c3774ab518d/contentdirectory/control HTTP/1.1
SOAPAction: "urn:schemas-upnp-org:service:ContentDirectory:1#Browse"
DLNADeviceName.lge.com: %5bTV%5d%5bLG%5d32LB5800-ZM
User-Agent: Linux/3.0.13 UPnP/1.0 LGE_DLNA_SDK/1.6.0 [TV][LG]32LB5800-ZM/04.04.06 DLNADOC/1.50
Connection: close
Host: 192.168.1.2:8096
Content-Length: 706
Content-Type: text/xml; charset="utf-8"


<?xml version="1.0" encoding="UTF-8"?>
<s:Envelope s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><u:Browse xmlns:u="urn:schemas-upnp-org:service:ContentDirectory:1"><ObjectID>d728d30ed7bf642a48db2b18552530f5</ObjectID><BrowseFlag>BrowseDirectChildren</BrowseFlag><Filter>res@resolution,res@nrAudioChannels,res@sampleFrequency,res@bitrate,dc:creator,res@dlna:cleartextSize,dc:date,upnp:genre,res,res@duration,res@size,upnp:albumArtURI,upnp:originalTrackNumber,upnp:album,upnp:artist,upnp:author</Filter><StartingIndex>0</StartingIndex><RequestedCount>99</RequestedCount><SortCriteria></SortCriteria></u:Browse></s:Body></s:Envelope>





Emby server:

HTTP/1.1 200 OK
X-UA-Compatible: IE=Edge
X-Frame-Options: SAMEORIGIN
Vary: Accept-Encoding
X-Powered-By: ServiceStack/4,00 Win32NT/.NET
Access-Control-Allow-Origin: *
Access-Control-Allow-Methods: GET, POST, PUT, DELETE, OPTIONS
Access-Control-Allow-Headers: Content-Type, Authorization, Range, X-MediaBrowser-Token, X-Emby-Authorization
Server: Mono-HTTPAPI/1.1
Content-Type: text/xml; charset=UTF-8
Date: Fri, 31 Jul 2015 01:21:40 GMT
Content-Length: 1762
Connection: close


<?xml version="1.0" encoding="utf-8"?><SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body><u:BrowseResponse xmlns:u="urn:schemas-upnp-org:service:ContentDirectory:1"><Result><DIDL-Lite xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/" xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/"><item restricted="1" id="d85cc3c6121bdb424ccb692137cdad12" parentID="d728d30ed7bf642a48db2b18552530f5"><dc:title>The Pirates! In an Adventure with Scientists! (2012)</dc:title><upnp:class>object.item.videoItem.movie</upnp:class><res duration="01:28:05.3330000" nrAudioChannels="2" resolution="1920x816" sampleFrequency="48000" bitrate="1947785" protocolInfo="http-get:*:video/mp4:DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01D00000000000000000000000000000">http://192.168.1.2:8096/videos/d85cc3c6121bdb424ccb692137cdad12/stream.mp4?Params=5cd28c870d4ce6ed690db933b96b1509;test;d85cc3c6121bdb424ccb692137cdad12;true;;;;2;;;;;;;0;;;;;;;;;;d85cc3c6121bdb424ccb692137cdad12</res><upnp:albumArtURI dlna:profileID="JPEG_SM">http://192.168.1.2:8096/Items/d85cc3c6121bdb424ccb692137cdad12/Images/Primary/0/68c04edd11f658147d7f2b8c127ac788/jpg/480/480/0/0</upnp:albumArtURI><upnp:icon>http://192.168.1.2:8096/Items/d85cc3c6121bdb424ccb692137cdad12/Images/Primary/0/68c04edd11f658147d7f2b8c127ac788/jpg/48/48/0/0</upnp:icon></item></DIDL-Lite></Result><NumberReturned>1</NumberReturned><TotalMatches>1</TotalMatches><UpdateID>2228</UpdateID></u:BrowseResponse></SOAP-ENV:Body></SOAP-ENV:Envelope>

I don't see any srt in the Emby response.

 

PS Nothing to do with this thread, but could you make "Select Path" when adding a media location to a media folder remember last folder? It's annoying having to navigate from root each time.

 

Link to comment
Share on other sites

I'm attaching another log. Notice that even though you can find multiple "srt"s in the file, line 7079 which is the actual response to the TV contains no mention of srt.

server-63573913822.txt

Link to comment
Share on other sites

Also please try the dev server build as I've just made one adjustment might have an impact. thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...