Jump to content

Crystal - MBC crashing on new episodes


psmc
 Share

Go to solution Solved by leedavies,

Recommended Posts

what does the web client look like?

 

it looks to me like we aren't able to get the episode numbers out of the file, and then the ui is crashing because it's assuming an episode number will be there.

Link to comment
Share on other sites

I'm not sure why I still cant..also I have just noticed this about the newly added tv files that wont play in Crystal/ROC, in neo's ehs i went into Channels (Bottom Right) and the same files all have something in common, they're missing the episode numbers. (see highlighted episodes in pic) Could this be it or a factor @@ebr @leedaives ? my files are set exactly like this...

 

Server/// TV>MASH>Season 1> 1 episode name 

                                                   2 next episode name

                                                   3 and so on

528a85506f52f_answer.jpg

Link to comment
Share on other sites

  • Solution

I'm not sure why I still cant..also I have just noticed this about the newly added tv files that wont play in Crystal/ROC, in neo's ehs i went into Channels (Bottom Right) and the same files all have something in common, they're missing the episode numbers. (see highlighted episodes in pic) Could this be it or a factor @@ebr @leedaives ? my files are set exactly like this...

 

Server/// TV>MASH>Season 1> 1 episode name 

                                                   2 next episode name

                                                   3 and so on

528a85506f52f_answer.jpg

 

Yes, I posted a few days ago that having a missing episode number will cause a crash in Crystal as the episode number is assumed to be there for all tv show episodes - it's whilst stupidly trying to format a null/blank episode number for display on-screen that Crystal crashes.

 

It's fixed in 1.0.8.4 which is being tested along with ROC 1.0.8.4 right now.  I'll PM you a link to this new Crystal build and it would be great if you could confirm that the problem is fixed for you in this new build.

 

Ta!

  • Like 2
Link to comment
Share on other sites

I'll take some screen shots tomorrow....I do use "the renamer" to move and rename files to my library.  I don't believe this is an issue as the movies (two directories, Kids and My movies) work fine....

 

I haven't had a close look at the screen when it crashes other than the error itself, so I'm not sure about the the numbering of the episodes.  As I said I'll have a closer look and send some screen shots tomorrow....

 

Football right now (go Pats go [fingers crossed])

Link to comment
Share on other sites

Movies would be completely un-related.  The issue appears to be with episode numbers due to an unsupported naming convention.

 

And my Panthers are kicking your butt... ;)

  • Like 1
Link to comment
Share on other sites

hmmm. My name convention is:

 

episode number - Episode name....so:

 

01 - Episode Name

 

lol - I can't argue that - but it's not over til it's over....lol ;)

Link to comment
Share on other sites

See above.  That convention is not supported in MB3 at this point.  If it worked previously it was an accident.

 

The problem is, that convention is too easily fooled (with a number in the actual episode name, for instance).  We will look into if we can support it but we don't right now.

Link to comment
Share on other sites

the ui shouldn't crash though. it should be able to handle that there's no episode number.

 

Absolutely true and, I assume, lee is already on that.

  • Like 1
Link to comment
Share on other sites

i don't use the "01 the episode name" structure i used it like this "1 the episode name" as i found the 01, 02 naming used to miss all the metadata in 2.62 but once you hit eps 11,12,13 meta would work for the structure type "01 episode name".

 

if there is another way it's to be done can some one enlighten me before i pull the last of my hair out lads?

 

if i put 3x01 file name

           3x02 other name

            3x03 third episode

will the meta all download as episode 3 ??

 

Ps here all day more or less

Link to comment
Share on other sites

Also just to make you double aware the error pops up in TV mainly as i used it most as pics i posted show ..but the movies i have modified just play dead in crystal when you click at the movie the mouse bounces off the cover in coverflow like it's a dud or not there again this only affects crystal & new or modified folders.  

Link to comment
Share on other sites

i don't use the "01 the episode name" structure i used it like this "1 the episode name" as i found the 01, 02 naming used to miss all the metadata in 2.62 but once you hit eps 11,12,13 meta would work for the structure type "01 episode name".

 

if there is another way it's to be done can some one enlighten me before i pull the last of my hair out lads?

 

if i put 3x01 file name

           3x02 other name

            3x03 third episode

will the meta all download as episode 3 ??

 

Ps here all day more or less

 

@ebr 

 

UPDATE: I removed all Crystal & ROC files

reinstalled crystal and retested ...the same issue appeared ...Unsolved

 

THEN on ebr's instructions mainly

One of the new series i've added is on series 1, so i removed all metadata & images in the season folder renamed the files 1x01,1x02,1x03 refreshed the tv folder from the browser and i noticed this change (see pic) and the file does indeed play as it should i am now about to try another small series renaming and will post results again. 528b5d24dff04_WORKING.jpg

Link to comment
Share on other sites

@@ebr @@leedavies & all

 

I have renamed some of the previously affected folders from earlier "Season 1> 1 episode name 

                                                                                                                              2 second episode"..  to the new format of

Season 1> 1x01

                  2x02 & removed all previous metadata and all is working so far.the affected TV files from earlier pics now Play in                                                                                                                                                                                Crystal.v1 0.8.0 & 1.0.8.5B1

                                                                                                                                                                   Roc      v1.0.8.2  

Link to comment
Share on other sites

ok so i renamed a load of files & folders and now cannot enter into MBC using ROC the error pops up on the MB splash screen ...after deleting everything works again crystal is working ok

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...