Jump to content

Crystal - MBC crashing on new episodes


psmc
 Share

Go to solution Solved by leedavies,

Recommended Posts

What is that?

 

@@ebr - what's your current thinking on this one...?  We'll see what test results come from trying this out in ROC and whether it's just a Crystal issue, but right now are you thinking it is a theme specific issue or a core problem maybe?

Link to comment
Share on other sites

I think it almost has to be in the mcml - which would mean theme.  Looks like something is blowing trying to determine the size of an image, maybe...

Link to comment
Share on other sites

Ok So ROC got on slightly better, I got one step further (MASH pic) The Error appears now as i press the thumb (tv) image527586c30e97f_mb1.jpg (inside the series to view episode thumbs before i could only get to the season cover) ,but still not wanting to play any of the series or eps & as before all others working fine.(blackadder pic)527586245fca8_mb2.jpg

Edited by psmc
Link to comment
Share on other sites

With Chocolate the results were worse the entire folder had an issue (pictured dark) The series appear but the program seems locked with moving left/right having no effect and only pressing back or Close X  notice too the folder contents in the bottom corner now also shows 0. where as in the other pic from the subdued(pictured white) theme shoes the series playing fine as with other tests5275886a6a540_mbsub.jpg527587af99fad_mbchoc1.jpg

Link to comment
Share on other sites

The '0|27' thing in Chocolate is a totally separate issue.  

I was asked by Lee to give it a look too, and post a result maybe he's had an idea?

 

PS the choc screen shot is from a clean install this evening just after roc test.

Edited by psmc
Link to comment
Share on other sites

 

 

 

Exception System.InvalidOperationException: Unable to convert "" to an object of type 'System.Int32'. at Microsoft.MediaCenter.UI.ObjectPath.Operations.TypeConversion(Object instance) at Microsoft.MediaCenter.UI.ObjectPath.PropertyOperations.Get(Object instance, String stPath, Boolean fThrowOnError) at Microsoft.MediaCenter.UI.ObjectPath.Get(Object instance, Int32 idxStart, Int32 nCount, Boolean fErrorOnNullReturn, Boolean fThrowOnError) at Microsoft.MediaCenter.UI.Set.ApplyWorker(Object args) at Microsoft.MediaCenter.UI.Set.Apply(IRulesHost rulesHost) at Microsoft.MediaCenter.UI.Template.RuleCollection.Update(IRulesHost rulesHost) at Microsoft.MediaCenter.UI.View.UpdateBindings() at Microsoft.MediaCenter.UI.View.UpdateBindings() at Microsoft.MediaCenter.UI.View.UpdateBindings() at Microsoft.MediaCenter.UI.View.UpdateBindings() at Microsoft.MediaCenter.UI.View.UpdateBindings() at Microsoft.MediaCenter.UI.View.UpdateBindings() at Microsoft.MediaCenter.UI.View.UpdateBindings() at Microsoft.MediaCenter.UI.View.UpdateBindings() at Microsoft.MediaCenter.UI.NewUiZone.ImplementUiTask(UiTask task, Object param) at Microsoft.MediaCenter.UI.UiZone.ProcessUiTask(UiTask task, Object param) at Microsoft.MediaCenter.UI.UiSession.ProcessDataBinding() at Microsoft.MediaCenter.Queues.Dispatcher.MainLoop(Queue queue) at Microsoft.MediaCenter.UI.UIDispatcher.MainLoop(Queue queue, LoopCondition condition) at MediaCenter.Extensibility.Host.Main(String[] args) 

 

Link to comment
Share on other sites

Just tried the updated v1.70 of crystal and it now reacts just as ROC (pic1) did last week which is a sight improvement (pic2), getting one step further into the folder.(last week would give error on entering individual season folders. The Error appears now as i press the thumb (episode) image and is still restricted to tv series folders only i have manually added to tv series folder in MB3...Short of removing the entire program to start again i'm unsure if there are any other options ? any ideas? 527d4d2c03bc9_cryer.jpg527d4d3a8e191_crystalerror.jpg

Link to comment
Share on other sites

Hey Lee - This seems to be the same (or very similar) to my issues!  Both ROC and Crystal....All other themes are fine.  I can browse to a show then a season but once I'm in the season directory I get the invalid application error and MB crashes.

Edited by hotshot79
  • Like 1
Link to comment
Share on other sites

Hey Lee - This seems to be the same (or very similar) to my issues!  Both ROC and Crystal....All other themes are fine.  I can browse to a show then a season but once I'm in the season directory I get the invalid application error and MB crashes.

Sweet ...i can stop pulling my hair out :) i'm not alone

  • Like 1
Link to comment
Share on other sites

I seem to have now replicated the error (sort of) ...i added a higher quality version of a few movies to their folders and removed the old file so now (after refresh) when i click on them they are dead ...no error visual or sound though as with tv shows, but the mouse click now in the affected movies just bounces off the case cover of the newly modified movies. This only affects Crystal and not ROC oddly in this scenario ! 

Link to comment
Share on other sites

@ psmc - I've tried that too, to no avail :(

 

I'm curious what your directory structure is for your TV....

 

I have all my media stored on a D-Link NAS and the directory is: \\HOME-SHARE\Volume_1\Videos\TV Shows and Specials\Homeland although I don't think this is the issue because all the movies work, plus I can access and watch both movies and TV with any other theme (other than Crystal and ROC) my movies are on the same volume and the directory is: \\HOME-SHARE\Volume_1\Videos\My Movies\Batman - The Dark Knight [boxset]...

  • Like 1
Link to comment
Share on other sites

So, I today reinstalled everything from scratch and it's still happening same series same eps ..officially out of ideas. the crystal ehs library info is mis-alligned too on the right .

Link to comment
Share on other sites

Hi guys, I'm in this too, with ROC. I don't have Crystal to test.

 

Only for TV series (for content which used to work fine before); movies work fine. This started IMMEDIATELY once I came home from a trip and let the system update the Server, MB Classic, and ROC. All are now latest versions as of now. I do have coverart trial installed, if it matters.

Server Version 3.0.5061.25570

MBC 3.0.90.0 B11-3.1

ROC 1.0.7.2

 

My path is like this:

 

\\ServerUNCpath\TV Series\Big Bang Theory\Season 2\BBT S02E15.mkv

 

Should I start a separate thread for the ROC error, or leave discussion here? And what can I do to help? I suppose I should figure out how to turn on debug logging...  EDIT. That was easy. Debug logging is on. Now I just have to find where the logs are :-)

 

Marc

Edited by Marc_G
  • Like 1
Link to comment
Share on other sites

It's not up to me but it looks like the exact same thing is happening to both - might be a good idea to keep together to gather more information as others have the issue...This may help Lee troubleshoot the problem - Can't wait till its fixed!!

Link to comment
Share on other sites

@ psmc - I've tried that too, to no avail :(

 

I'm curious what your directory structure is for your TV....

 

I have all my media stored on a D-Link NAS and the directory is: \\HOME-SHARE\Volume_1\Videos\TV Shows and Specials\Homeland although I don't think this is the issue because all the movies work, plus I can access and watch both movies and TV with any other theme (other than Crystal and ROC) my movies are on the same volume and the directory is: \\HOME-SHARE\Volume_1\Videos\My Movies\Batman - The Dark Knight [boxset]...

Same as yourself,i set up mine as directed by unc paths, but as with yours the error only affects the ROC & Crystal Themes 

Link to comment
Share on other sites

Hi guys, I'm in this too, with ROC. I don't have Crystal to test.

 

Only for TV series (for content which used to work fine before); movies work fine. This started IMMEDIATELY once I came home from a trip and let the system update the Server, MB Classic, and ROC. All are now latest versions as of now. I do have coverart trial installed, if it matters.

Server Version 3.0.5061.25570

MBC 3.0.90.0 B11-3.1

ROC 1.0.7.2

 

My path is like this:

 

\\ServerUNCpath\TV Series\Big Bang Theory\Season 2\BBT S02E15.mkv

 

Should I start a separate thread for the ROC error, or leave discussion here? And what can I do to help? I suppose I should figure out how to turn on debug logging...  EDIT. That was easy. Debug logging is on. Now I just have to find where the logs are :-)

 

Marc

I'm not too sure there is anything more any of us can do apart from provide logs if needed ...the error is on a few machines now so maybe Lee has it tracked down ...you can leave your post here and then if it's solved they can close the thread i suppose.

Link to comment
Share on other sites

Well, both of my systems are working now.  Not sure if it was a Crystal update or the last MB update - but I can now browse and play my TV shows - new or old!!

 

So glad it's working again!!!

  • Like 1
Link to comment
Share on other sites

Well - Looks like I spoke to soon.....MB crashes whenever I try to view a new episode.  Any existing episode will play but no joy for a new episode :( 

 

Lee - I'd still like to connect through skype for you to have a look if possible.

Link to comment
Share on other sites

That episode naming convention is not supported in MB3.  You will need to change it to one that is.

Whats the new one ? Do i have to rename every single episode ? and if it's the naming thats an issue why does this affect movies that have been modified ( eg updated this "film name.avi" with a new Higher quality "film name.mp4" file) too? also I have tested a new version of crystal which before & after a server update the results were different ...before the server update i got the error at the episode level and after the update the error was given at the season level ... @@leedavies suggested this after the update:

 

"So the same build of Crystal is now showing the error at a higher level now you've updated the server version?

 

I think you just found the cause.  You might want to share that with Luke, 

Link to comment
Share on other sites

Whats the new one ? Do i have to rename every single episode ? and if it's the naming thats an issue why does this affect movies that have been modified ( eg updated this "film name.avi" with a new Higher quality "film name.mp4" file) too? also I have tested a new version of crystal which before & after a server update the results were different ...before the server update i got the error at the episode level and after the update the error was given at the season level ... @@leedavies suggested this after the update:

 

"So the same build of Crystal is now showing the error at a higher level now you've updated the server version?

 

I think you just found the cause.  You might want to share that with Luke, 

 

Based on those findings that a server update caused season level to break in the same way episodes were breaking before that server update, and given that the Crystal DLL didn't change, so was running the same code, it does suggest perhaps there's something causing this at the back end?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...