Jump to content
Luke

FreeNAS plugin

Recommended Posts

jjstecchino

Thank you Luke for looking at it.

I have installed mb3 Version 3.0.5445.6 on freenas. Auto update set to "Dev" and it say I am up to date if I check for updates.

Mb3 on windows server is  3.0.5464.1902 again updates set to "Dev" and server up to date.

Is there a way to get the release you just fixed?

Will network share enumeration on setting up media folder eventually work on Freenas? Still believe setting the path directly to the share is the easiest route as you don't even need to remap nas physical directories to the mb3 jail.

Thank you for your hard work on this. Mediabrowser3 must have been a monumental project for you. I hope It will give the satisfaction you deserve.

 

Thanks

 

Johnny

Share this post


Link to post
Share on other sites
embeathome

Guys, pls i would need your help. I have FreeNas server and i want to install MBS on it. Actually i did that already, however i would need help with setting it up; i mean i have difficulties to set it up so it works. Any idea where i could find some step by step guide how to make it working? I have installed it and when i tried to turn it on, it took some time and then i got message "Some error occured". I am pretty sure it requires some settings in jail and so on but i have no clue how to proceed....:(

 

Thanks<
Martin

  • Like 1

Share this post


Link to post
Share on other sites
josh4trunks

@@embeathome

it should work and startup when you press start in plugins > installed.

 

do other plugins install and start successfully?

Share this post


Link to post
Share on other sites
Hisma

try this again with the latest. i think it should be after reviewing path substitution. But instead of testing with the external player, just go to the edit page of an item in the web interface and it will display the new path after substitution

 

Got around to testing this today, and lo and behold, it works!

 

Here is a ss of the correct path substitution -

 

dg8nrm7.png

 

You can see that the full network path is listed, and it is not based on the local path inside of the jail.  

I then tested functionality of using mpc-hc as an external player, and it worked beautifully.  

 

This also means that I can now go back to using xbmb3c.  

 

I have to say that you guys are awesome.  You really do listen to the community, and I did not expect this issue to get fixed so expediently.  Bravo :)

Edited by Hisma

Share this post


Link to post
Share on other sites
Hisma

So, anyone who is using the freenas mb3 plugin should go ahead and set up path substitution.  It's easy, here is a ss of what mine looks like -

 

MddmTLL.png

 

simply map the equivalent full network path to the directory you have your local storage folders.  Mine is obviously in /usr/local, where I have a movie, tv, and mp3 directory mounted inside my jail.  

Share this post


Link to post
Share on other sites
woodsb02

Glad to hear it works for you :)

Share this post


Link to post
Share on other sites
Hisma

thanks, at this point the plugin is good enough to act as my new main media database, and replace xbmc's outdated sql backend.

 

the only remaining items on my dream sheet are -

  • a working unix/bsd tv plugin.  Ideally mythtv, since I already have it running on my freenas server.  But I'll take whatever I can get.  I have a feeling this will happen eventually since there are enough non-windows users now.
  • real-time updates for zfs file system.  This will likely never happen, unless an extremely motivated user decides it is worth the trouble of implementing themselves. 

I can totally live with where it is at now though.  Was also breeze to update the other day.  The server detected an update was available, so I just pushed the "update" button from the freenas admin dashboard and all was good.

Share this post


Link to post
Share on other sites
josh4trunks

thanks, at this point the plugin is good enough to act as my new main media database, and replace xbmc's outdated sql backend.

 

the only remaining items on my dream sheet are -

  • a working unix/bsd tv plugin.  Ideally mythtv, since I already have it running on my freenas server.  But I'll take whatever I can get.  I have a feeling this will happen eventually since there are enough non-windows users now.
  • real-time updates for zfs file system.  This will likely never happen, unless an extremely motivated user decides it is worth the trouble of implementing themselves. 

I can totally live with where it is at now though.  Was also breeze to update the other day.  The server detected an update was available, so I just pushed the "update" button from the freenas admin dashboard and all was good.

So in-app updates work using the FreeNAS plugin? Maybe I don't need to update the PBI in the repo then?

 

EDIT

I doubt this would work, cause the mediabrowser user couldn't overwrite the exe file because of it's permissions/ownership.

Edited by josh4trunks

Share this post


Link to post
Share on other sites
Luke

So in-app updates work using the FreeNAS plugin? Maybe I don't need to update the PBI in the repo then?

 

In-server updates definitely do not.

Share this post


Link to post
Share on other sites
embeathome

@@embeathome

it should work and startup when you press start in plugins > installed.

do other plugins install and start successfully?

Unfortunately it wont start. It takes minute or two and then it says some error occured. I have few plugins installed but none of them works. It stopped working once i upgraded from FreeNas 8.x to 9.1. Now i am running 9.3 and i cannot even uninstal those plugins. I am just able to uninstall MBS and thats it. When i want to uninstall others it says no jail found. Honestly my english is not so good so i missed the point of all those jails etc....

Share this post


Link to post
Share on other sites
woodsb02

Unfortunately it wont start. It takes minute or two and then it says some error occured. I have few plugins installed but none of them works. It stopped working once i upgraded from FreeNas 8.x to 9.1. Now i am running 9.3 and i cannot even uninstal those plugins. I am just able to uninstall MBS and thats it. When i want to uninstall others it says no jail found. Honestly my english is not so good so i missed the point of all those jails etc....

I would recommend going into the #freenas channel on freenode irc and asking for assistance on fixing your FreeNAS install in there. It sounds like something isn't behaving properly.

 

Alternatively you could try posting on forums.freenas.org. Just make sure you include a good description of your symptoms, a screenshot and any logs you can get.

Share this post


Link to post
Share on other sites
Hisma

So in-app updates work using the FreeNAS plugin? Maybe I don't need to update the PBI in the repo then?

 

EDIT

I doubt this would work, cause the mediabrowser user couldn't overwrite the exe file because of it's permissions/ownership.

 

No, I mentioned that I updated through the freenas admin dashboard, from the plugins page.  Just mentioning that it went smoothly.  I am guessing you were the one that updated the repo then.

Share this post


Link to post
Share on other sites
josh4trunks

@@embeathome

that's what I suspected. it had nothing to so with mediabrowser then. itd be better to look for help on the freenas forums.

 

I know some people had issues with upgrading because they were missing their loopback IP. that's somewhere to start.

Share this post


Link to post
Share on other sites
jjstecchino

Hello Hisma, so what mb3 version are you running on freenas?  MIne is 3.0.5445.6 and I do not have the option to upgrade. The plugin list in the freenas repo shows the same version as latest. 

Also help me out here with path substitution.

My nas is named nas and has smb shares on \\NAS\My Movies, \\NAS\My TV etc. The physical files reside on zfs datasets named movies, tv etc.

These datasets are mapped to the mediabrowser_1 jail as /mnt/movies, /mnt/tv etc.

Now my freenas mb3 server is set to read movies from /mnt/movies. what path do I substitute as a share?

  Would the correct setup be to substitute /mnt/movies with \\NAS\My Movies or do I have to create a share and supply the entire path to the jail i.e. \\NAS\jails\mediabrowser_1\mnt\movies?

 

Thanks

 

P.S. I like your avatar but I hope it is not your picture  :)

Edited by jjstecchino

Share this post


Link to post
Share on other sites
Hisma

Hello Hisma, so what mb3 version are you running on freenas?  MIne is 3.0.5445.6 and I do not have the option to upgrade. The plugin list in the freenas repo shows the same version as latest. 

Also help me out here with path substitution.

My nas is named nas and has smb shares on \\NAS\My Movies, \\NAS\My TV etc. The physical files reside on zfs datasets named movies, tv etc.

These datasets are mapped to the mediabrowser_1 jail as /mnt/movies, /mnt/tv etc.

Now my freenas mb3 server is set to read movies from /mnt/movies. what path do I substitute as a share?

  Would the correct setup be to substitute /mnt/movies with \\NAS\My Movies or do I have to create a share and supply the entire path to the jail i.e. \\NAS\jails\mediabrowser_1\mnt\movies?

 

Thanks

 

P.S. I like your avatar but I hope it is not your picture  :)

 

You are running the newest version, path sub should work for you.

 

Good question that you posed.  The thing is that I do not use datasets, I have more simplistic setup and just have regular media folders stored on my NAS.  I then mount those folders as storage inside of my jail.

 

So the way I have my mb3 path substituted is how you described in the latter part, supplying the entire path to the jail.  But, because you mapped the datasets in your jail, \\NAS\My Movies should also be a valid path, since /mnt/movies/<moviename> would resolve to \\NAS\My Movies\<moviename>, which is also a valid path from what you described.  

 

Good thing is this would not take much time at all to test both ways.  Start with the dataset path, and if that doesn't work, use the full path.  Make sure that typing the substituted path into a video player can actually open a video file... easiest way to make sure you got the substitution path entered correctly.

Share this post


Link to post
Share on other sites
jjstecchino

The first option, using \\NAS\My Movies worked well. Thanks

Share this post


Link to post
Share on other sites
embeathome

@@embeathome

that's what I suspected. it had nothing to so with mediabrowser then. itd be better to look for help on the freenas forums.

I know some people had issues with upgrading because they were missing their loopback IP. that's somewhere to start.

So after a few days i was able to make everything up and running. I had to reinstall FreeNas (FN) completely because plugins from FN 8.x doesn't work in FN 9.3 - I didn't know that. Old plugins caused a mess in jails and i was not able to unistall them anymore. There were strange jail templates which blocked new plugins (MBS) to work. So the only possibility was the reinstall. Now i was able to set everything including WOL/partially through dashboard of Asus router also WOW, and also acces to MBS from home LAN and Internet.

 

I found here now that i will have to use path substitution too; i didn't expect that. I am also using MPC-HC as external player. I didn't come to the stage of adding Media folders to the library of MBS - so based on above it seems that i have to create Storage in Media Browser jail and point it to ZFS Volume called in my case Storage_1? I am not able to check it now and test because I am on holiday with my family in Austria. But I don't use datasets at all and i just copied my Media,Photos,Software,Documents,Games etc etc folders to Storage_1 through Windows explorer. But if i point MBS to scan my whole Storage_1, it will take much more time....but maybe jail will recognize copied folders so i will be able to point only to these...

Edited by embeathome

Share this post


Link to post
Share on other sites
woodsb02

By default your MediaBrowser jail will not have access to any files or folders saved on your FreeNAS file share. Think of the MediaBrowser jail as a virtual machine of sorts.

You need to use the FreeNAS web interface to configure the MediaBrowser jail to have access to your media files. This is explained in the FreeNAS manual http://doc.freenas.org/9.3/freenas_jails.html#add-storage.

Regardless of where my media is stored within the file share, I normally mount the media folders to the /media folder in the jail (eg. Movies are /media/movies, whilst music is /media/music). Then you go back to the MediaBrowser web page and add those folders to your library.

Edited by woodsb02

Share this post


Link to post
Share on other sites
embeathome

So it seems i couldn't set path substitution correctly, or maybe something else is wrong. MPC-HC as external player says "File not found". Internal player of MBT starts to play movie when i disable external player however it loops playing just 1 second of the movie. I tried more movies with the same result. Here is what i set:

 

- I have latest MBS plugin for freenas (3.0.5464.40000)

- Path to Movies on Freenas server ZFS RaidZ2 is: \\Freenas\Media\Filmy 2D

- Storage in Jail is set as per below SS:

post-10423-0-33576800-1420411914_thumb.jpg

 

- Path substitution set as on below picture:

post-10423-0-46131700-1420412190_thumb.jpg

 

Could someone help me out to set it correctly? The rest is OK, MBS scans movies added in the way i want etc...

 

 

Share this post


Link to post
Share on other sites
woodsb02

The path substitution should be FROM the jail path, TO the file sharing from the host FreeNAS.

 

From your second screenshot, it looks like you have the FROM correct as /usr/local/Filmy 2D (a path in the jail), but the TO should look more like \\Freenas\Media\Filmy 2D

Share this post


Link to post
Share on other sites
embeathome

The path substitution should be FROM the jail path, TO the file sharing from the host FreeNAS.

 

From your second screenshot, it looks like you have the FROM correct as /usr/local/Filmy 2D (a path in the jail), but the TO should look more like \\Freenas\Media\Filmy 2D

 

Well, i tried several options but still, "file couldn't be find" Honestly, i followed Hisma's setup from page 3 of this thread, which is not in line with your suggestion:

 

post-10423-0-32386200-1420486374_thumb.png

 

Any other ideas?

 

EDIT: Stupid error :( I forgot to add "Server" to path substitution, so the TO now looks like \\Freenas\Server\Media\Filmy 2D

 

Now all works perfectly. MPC-HC opens and plays the file.

 

Thanks for help guys!

 

EDIT 2: it is OK to make path substitution only from usr/local to \\Freenas\Server\Media . Filmy 2D is not necessary to add to neither from nor to

Edited by embeathome
  • Like 1

Share this post


Link to post
Share on other sites
Hisma

Well, i tried several options but still, "file couldn't be find" Honestly, i followed Hisma's setup from page 3 of this thread, which is not in line with your suggestion:

 

attachicon.gifMddmTLL.png

 

Any other ideas?

 

EDIT: Stupid error :( I forgot to add "Server" to path substitution, so the TO now looks like \\Freenas\Server\Media\Filmy 2D

 

Now all works perfectly. MPC-HC opens and plays the file.

 

Thanks for help guys!

 

EDIT 2: it is OK to make path substitution only from usr/local to \\Freenas\Server\Media . Filmy 2D is not necessary to add to neither from nor to

Yes, you can sub the path down to local. Once you have the direct path to inside of the jail, you've accomplished your goal.

 

Congrats on getting it working. As I mentioned you should test your direct path by trying to open a movie from that path in mpc. It's easy to forget a folder, I did the same thing at first.

Share this post


Link to post
Share on other sites
whitestrat13

I would like to say thanks to everyone who worked so hard to bring this plugin to the community.

 

I built a test machine with an old desktop and things are working well.  I did have to add a user with User ID 989 and give it rights to the volume with my media on it to allow MBS to write metadata and images.  I hope this can help anyone with a similar issue.

 

I did notice that chapter image extraction doesn't work.  This maybe a result of my media being in MKV containers.  Any thoughts guys?

  • Like 1

Share this post


Link to post
Share on other sites
whitestrat13

Sorry, @@Luke.

 

When I click the "Chapter Image Extraction" button in the scheduled tasks, it "finishes" instantly, but no images are extracted.  I am running Server Version 3.0.5464.40000.  If you want me to upload any logs, I'd be happy to.

 

Thanks again

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...