Jump to content

Ubuntu


Luke

Recommended Posts

Ive made the transition from a Windows server to a ubuntu 14.04.1 Server in a VM and have installed this, its all working correctly, its just that the server crashes randomly.

 

Please advise what this means?

The task has already completed
System.InvalidOperationException
  at System.Runtime.CompilerServices.AsyncTaskMethodBuilder.SetException (System.Exception exception) [0x00000] in <filename unknown>:0
  at System.IO.Stream+<CopyToAsync>c__async0.MoveNext () [0x00000] in <filename unknown>:0
  at (wrapper unbox) System.IO.Stream/<CopyToAsync>c__async0:MoveNext ()
  at System.Threading.Tasks.AwaiterActionContinuation.Execute () [0x00000] in <filename unknown>:0
  at System.Threading.Tasks.Task.ProcessCompleteDelegates () [0x00000] in <filename unknown>:0
  at System.Threading.Tasks.Task.HandleGenericException (System.AggregateException e) [0x00000] in <filename unknown>:0
  at System.Threading.Tasks.Task.TrySetException (System.AggregateException aggregate, Boolean cancellation, Boolean observed) [0x00000] in <filename unknown>:0
  at System.Threading.Tasks.TaskCompletionSource`1[System.Int32].TrySetException (IEnumerable`1 exceptions) [0x00000] in <filename unknown>:0
  at System.Threading.Tasks.TaskCompletionSource`1[System.Int32].SetException (IEnumerable`1 exceptions) [0x00000] in <filename unknown>:0
  at System.Threading.Tasks.TaskCompletionSource`1[System.Int32].SetException (System.Exception exception) [0x00000] in <filename unknown>:0
  at System.Threading.Tasks.TaskFactory`1[System.Int32].InnerInvoke (System.Threading.Tasks.TaskCompletionSource`1 tcs, System.Func`2 endMethod, IAsyncResult l) [0x00000] in <filename unknown>:0
  at System.Threading.Tasks.TaskFactory`1+<FromAsyncBeginEnd>c__AnonStorey5`3[System.Int32,System.Byte[],System.Int32,System.Int32].<>m__0 (IAsyncResult l) [0x00000] in <filename unknown>:0
  at System.Net.WebAsyncResult.CB (System.Object unused) [0x00000] in <filename unknown>:0
Link to post
Share on other sites

Is this what you mean?

2015-02-10 03:57:00.3353 Info - App: HttpClientManager GET: http://api.themoviedb.org/3/person/7471?api_key=f6bd687ffa63cd282b6ff2c6877f2669&append_to_response=credits,images,external_ids
2015-02-10 03:57:00.6149 Info - App: HttpClientManager GET: http://image.tmdb.org/t/p/original/kYijshMQiGA3RP8bXFZ93GR4j8W.jpg
2015-02-10 03:57:00.6741 Error - Main: UnhandledException
        *** Error Report ***
        Version: 3.0.5490.2
        Command line: /opt/mediabrowser/MediaBrowser.Server.Mono.exe -programdata /var/lib/mediabrowser
        Operating system: Unix 3.13.0.32
        Processor count: 2
        64-Bit OS: True
        64-Bit Process: True
        Program data path: /var/lib/mediabrowser
        Mono: 3.2.8 (Debian 3.2.8+dfsg-4ubuntu1)
        Application Path: /opt/mediabrowser/MediaBrowser.Server.Mono.exe
        The task has already completed
        System.InvalidOperationException
          at System.Runtime.CompilerServices.AsyncTaskMethodBuilder.SetException (System.Exception exception) [0x00000] in <filename unknown>:0
          at System.IO.Stream+<CopyToAsync>c__async0.MoveNext () [0x00000] in <filename unknown>:0
          at (wrapper unbox) System.IO.Stream/<CopyToAsync>c__async0:MoveNext ()
          at System.Threading.Tasks.AwaiterActionContinuation.Execute () [0x00000] in <filename unknown>:0
          at System.Threading.Tasks.Task.ProcessCompleteDelegates () [0x00000] in <filename unknown>:0
          at System.Threading.Tasks.Task.HandleGenericException (System.AggregateException e) [0x00000] in <filename unknown>:0
          at System.Threading.Tasks.Task.TrySetException (System.AggregateException aggregate, Boolean cancellation, Boolean observed) [0x00000] in <filename unknown>:0
          at System.Threading.Tasks.TaskCompletionSource`1[System.Int32].TrySetException (IEnumerable`1 exceptions) [0x00000] in <filename unknown>:0
          at System.Threading.Tasks.TaskCompletionSource`1[System.Int32].SetException (IEnumerable`1 exceptions) [0x00000] in <filename unknown>:0
          at System.Threading.Tasks.TaskCompletionSource`1[System.Int32].SetException (System.Exception exception) [0x00000] in <filename unknown>:0
          at System.Threading.Tasks.TaskFactory`1[System.Int32].InnerInvoke (System.Threading.Tasks.TaskCompletionSource`1 tcs, System.Func`2 endMethod, IAsyncResult l) [0x00000] in <filename unknown>:0
          at System.Threading.Tasks.TaskFactory`1+<FromAsyncBeginEnd>c__AnonStorey5`3[System.Int32,System.Byte[],System.Int32,System.Int32].<>m__0 (IAsyncResult l) [0x00000] in <filename unknown>:0
          at System.Net.WebAsyncResult.CB (System.Object unused) [0x00000] in <filename unknown>:0

Link to post
Share on other sites

Hi,

Just FYI

I have make a fresh install of MB3 on ubuntu 14.4bits, with ppa..

I have make a upgrade in beta version after install

And I have searched 2 day why movies doesn't playing..

I have find it !!

ffmpeg is not download in /var/lib/mediabrowser/ffmpeg/20150124/ .. folder is empty !

I have copy/past an old ffmpeg and now it's work.. so don't forget to put ffmpeg in ppa, please..

 

So.

 

Thanx for your job mediabrowser team.

Edited by youl94
Link to post
Share on other sites

this is resolved in 3.0.5518.4

 

Thank you a lot, Luke :)

 

Another trick, for ubuntu server 14.04.1 LTS, if you want ...

# Add officiel ffmpeg repo and install it

sudo add-apt-repository ppa:mc3man/trusty-media
sudo apt-get update
sudo apt-get install ffmpeg

# Delete ffmpeg and ffprobe, if exist, and link new one

sudo rm /var/lib/mediabrowser/ffmpeg/20150124/ff*
ln -s /opt/ffmpeg/bin/ffmpeg /var/lib/mediabrowser/ffmpeg/20150124/ffmpeg
ln -s /opt/ffmpeg/bin/ffprobe /var/lib/mediabrowser/ffmpeg/20150124/ffprobe

# Change right
chown -R mediabrowser: /var/lib/mediabrowser/ffmpeg/20150124/

If you want compil your one, check this link : https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu

Link to post
Share on other sites
  • 1 month later...
wolfbuddy

Is it normal to have to start the mediabrowser service manually when the system boots?

 

I'm guessing not, and that it's related to the system error message I get about mono at startup?

Link to post
Share on other sites
hurricanehrndz

Is it normal to have to start the mediabrowser service manually when the system boots?

 

I'm guessing not, and that it's related to the system error message I get about mono at startup?

It should start automatically. Please follow the new install instructions and report back.

 

PPA has been updated and ensured working. Hope everyone enjoys.

Link to post
Share on other sites

I'm running MB3 server beta 3.0.5518.7 on an Ubuntu Server 14.04 machine. I'm runnnig an

sudo apt-get update

and a

sudo apt-get upgrade

to try to install the latest Emby server beta 3.0.5556. I keep getting a message that mediabrowser is kept back. Do I need to point to a new PPA, or should it upgrade to the new serve through my package manager without me changing anything as per usual?

Edited by biddy
Link to post
Share on other sites
hurricanehrndz

I'm running MB3 server beta 3.0.5518.7 on an Ubuntu Server 14.04 machine. I'm runnnig an

sudo apt-get update

and a

sudo apt-get upgrade

to try to install the latest Emby server beta 3.0.5556. I keep getting a message that mediabrowser is kept back. Do I need to point to a new PPA, or should it upgrade to the new serve through my package manager without me changing anything as per usual?

You are probably missing dependencies. Please look at the instructions on the front page. Upgrade to mono 3.10 (front page) and install the imagemagick binaries. 

 

 

Run apt-get dist-upgrade - dependencies for the project has changed.

Edited by hurricanehernandez
  • Like 1
Link to post
Share on other sites
wolfbuddy

I think I have a newer version of mono than 3.10, that was installed as a dependency by the instructions I followed a couple of weeks ago.

 

Should I uninstall MBS and all it's dependencies before following the new instructions?

Link to post
Share on other sites
hurricanehrndz

Anything newer then 3.10 is considered unstable. You don't have to uninstall. I would not follow all the instructions, pick the ones you need.  If you followed other instructions to install mono 3.12 then you can try and see how well mediabrowser works with that version, some users have reported some issues though.

Link to post
Share on other sites

You are probably missing dependencies. Please look at the instructions on the front page. Upgrade to mono 3.10 (front page) and install the imagemagick binaries. 

 

 

Run apt-get dist-upgrade - dependencies for the project has changed.

Thank you, running dist-upgrade pushed the latest update.

 

I'm not sure what you mean when you say check the front page. I check the front page of mediabrowser.tv, the first page of this thread, the Ubuntu page under Downloads, I couldn't find anything anywhere about dependencies for the project changing. I looked on the blog, I re-read the introducing Emby post. Maybe I am just blind.

Link to post
Share on other sites
hurricanehrndz

Thank you, running dist-upgrade pushed the latest update.

 

I'm not sure what you mean when you say check the front page. I check the front page of mediabrowser.tv, the first page of this thread, the Ubuntu page under Downloads, I couldn't find anything anywhere about dependencies for the project changing. I looked on the blog, I re-read the introducing Emby post. Maybe I am just blind.

Installation instructions under linux at mediabrowser.tv

Link to post
Share on other sites
aveeshkumar

Hello,

 

am running into installation problems while installing server for ubuntu 14.04.02  at this line:

 

-apt-get install -qy --force-yes libmono-cil-dev mediainfo wget libsqlite3-dev libc6-dev imagemagick-6.q8 libmagickwand-6.q8-2 libmagickcore-6.q8-2 

 

am getting:

E: Unable to locate package imagemagick-6.q8
E: Couldn't find any package by regex 'imagemagick-6.q8'
E: Unable to locate package apt-get
E: Unable to locate package install
E: Unable to locate package mediabrowser
E: Unable to locate package libmagickwand-6.q8-2
E: Couldn't find any package by regex 'libmagickwand-6.q8-2'
E: Unable to locate package libmagickcore-6.q8-2
E: Couldn't find any package by regex 'libmagickcore-6.q8-2
 

 

I first changed to sudo su - 

 

Any pointers?

 

Thanks

 

Aveesh

Link to post
Share on other sites
thefirstofthe300

Hello,

 

am running into installation problems while installing server for ubuntu 14.04.02 at this line:

 

-apt-get install -qy --force-yes libmono-cil-dev mediainfo wget libsqlite3-dev libc6-dev imagemagick-6.q8 libmagickwand-6.q8-2 libmagickcore-6.q8-2

 

am getting:

E: Unable to locate package imagemagick-6.q8

E: Couldn't find any package by regex 'imagemagick-6.q8'

E: Unable to locate package apt-get

E: Unable to locate package install

E: Unable to locate package mediabrowser

E: Unable to locate package libmagickwand-6.q8-2

E: Couldn't find any package by regex 'libmagickwand-6.q8-2'

E: Unable to locate package libmagickcore-6.q8-2

E: Couldn't find any package by regex 'libmagickcore-6.q8-2

 

 

I first changed to sudo su -

 

Any pointers?

 

Thanks

 

Aveesh

I would say that you haven't added the ppa to your system.

 

The ppa is ppa:app-z/mediabrowser if I remember right. It should be in the download instructions on the website.

Link to post
Share on other sites

Since installing Version 3.0.5557.20000 I'm unable to select external client for remote playback. Neither from web or windows phone app. The clients (kodi) are detected/connected when I view settings (server dashboard)

Edited by KRA
Link to post
Share on other sites
h1machiii

Installation Instructions

 

See http://mediabrowser.tv/download/

 

Let's all thank @

 

54620be0631e3_logoubuntu_st_noblack_oran

 

 

The leading platform for scale-out computing, Ubuntu Server helps you make the most of your infrastructure. Whether you want to deploy an OpenStack cloud, a Hadoop cluster or a 50,000-node render farm, Ubuntu Server delivers the best value scale-out performance available.

Instructions do not work for my install of Linux Mint 17. Dependencies will not install. Follwed directions to the letter but instructions are bad. Why is installing Mediabrowser so difficult for Linux?

 

computer max # apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.3srERseypa --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF

gpg: requesting key D3D831EF from hkp server keyserver.ubuntu.com

gpg: key D3D831EF: public key "Xamarin Public Jenkins (auto-signing) <releng@xamarin.com>" imported

gpg: Total number processed: 1

gpg:               imported: 1  (RSA: 1)

computer max # echo 'deb http://ppa.launchpad.net/apps-z/mediabrowser/ubuntu trusty main' > /etc/apt/sources.list.d/mediabrowser.list

computer max # echo "deb http://download.mono-project.com/repo/debian wheezy/snapshots/3.10.0 main" > /etc/apt/sources.list.d/mono.list

computer max # echo 'deb http://download.mono-project.com/repo/debian wheezy-apache24-compat main' >> /etc/apt/sources.list.d/mono.list

computer max # install dependencies

install: missing destination file operand after ‘dependencies’

Try 'install --help' for more information.

computer max # apt-get install -qy --force-yes libmono-cil-dev mediainfo wget libsqlite3-dev libc6-dev imagemagick-6.q8 libmagickwand-6.q8-2 libmagickcore-6.q8-2

Reading package lists...

Building dependency tree...

Reading state information...

E: Unable to locate package imagemagick-6.q8

E: Couldn't find any package by regex 'imagemagick-6.q8'

E: Unable to locate package libmagickwand-6.q8-2

E: Couldn't find any package by regex 'libmagickwand-6.q8-2'

E: Unable to locate package libmagickcore-6.q8-2

E: Couldn't find any package by regex 'libmagickcore-6.q8-2'

computer max # install mediabrowser

install: missing destination file operand after ‘mediabrowser’

Try 'install --help' for more information.

computer max # install mediabrowser

install: missing destination file operand after ‘mediabrowser’

Try 'install --help' for more information.

computer max # apt-get install -qy --force-yes mediabrowser

Reading package lists...

Building dependency tree...

Reading state information...

E: Unable to locate package mediabrowser

 

Link to post
Share on other sites
thefirstofthe300

Don't forget apt-get update. Until you run

apt-get update

apt-get won't know where to find the packages because it has to find the sources for it.

Link to post
Share on other sites

Since installing Version 3.0.5557.20000 I'm unable to select external client for remote playback. Neither from web or windows phone app. The clients (kodi) are detected/connected when I view settings (server dashboard)

I'm also getting this bug. Running Ubuntu Server 14.04, unable to access the web client. Doesn't matter if I restart the mediabrowser service or reboot the machine, unable to access the server through the web client at all anymore.

Link to post
Share on other sites
hurricanehrndz

I'm also getting this bug. Running Ubuntu Server 14.04, unable to access the web client. Doesn't matter if I restart the mediabrowser service or reboot the machine, unable to access the server through the web client at all anymore.

I don't believe this is something isolated to Ubuntu, so please post in the server section. Let's keep the thread concentrated on issues related to Ubuntu and the actual release.

Link to post
Share on other sites

I don't believe this is something isolated to Ubuntu, so please post in the server section. Let's keep the thread concentrated on issues related to Ubuntu and the actual release.

Sorry, that it was not a strictly Ubuntu problem was not apparent. I suppose it was a mistake that I just submitted a bug report about it. Opps.

Link to post
Share on other sites

Any tips on how I can install Emby server on Ubuntu 12.04? The following commands are okay:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 637D1286
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF 

But I get an error message on the next line:

myname@myserver:~$ sudo echo 'deb http://ppa.launchpad.net/apps-z/mediabrowser/ubuntu trusty main' > /etc/apt/sources.list.d/mediabrowser.list 
-bash: /etc/apt/sources.list.d/mediabrowser.list: Permission denied
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...