Jump to content

[DEV]New Argus Provider


pünktchen
 Share

Recommended Posts

Just a small feedback with MBS and Argus Scheduler Server on one pc and MediaPortal TVServer/Recorder on an other:

Couldn't test the guide, because i haven't mapped guide channels yet...

 

Connection works without problems, streaming starts immediately :D but only "SD" channels are watchable.

Everything above 720p stutters or stops depending on the streaming profile. (No problem with vlc from the Argus Scheduler Console, so no network related problem)

 

But for a "DEV" version - Great work!!!

Link to comment
Share on other sites

Hi!

 

My first attempt didnt go that well  :(

Argus stream seems to start but cant be watched. Part of the log uploaded, hope it helps.

 

Server version:3.0.5413.14205

 

Other stuff connecting the server seems to be working fine so far  :)

 

Let me know if anything else is needed!

/tompa

 

edit: using web client

 

Could you post the full log? And also the transcode log....

Link to comment
Share on other sites

Just a small feedback with MBS and Argus Scheduler Server on one pc and MediaPortal TVServer/Recorder on an other:

Couldn't test the guide, because i haven't mapped guide channels yet...

 

Connection works without problems, streaming starts immediately :D but only "SD" channels are watchable.

Everything above 720p stutters or stops depending on the streaming profile. (No problem with vlc from the Argus Scheduler Console, so no network related problem)

 

But for a "DEV" version - Great work!!!

 

Can you maybe post your log and transcode logs?

Link to comment
Share on other sites

Hi!

 

My first attempt didnt go that well  :(

Argus stream seems to start but cant be watched. Part of the log uploaded, hope it helps.

 

Server version:3.0.5413.14205

 

Other stuff connecting the server seems to be working fine so far  :)

 

Let me know if anything else is needed!

/tompa

 

edit: using web client

sever_log.zip

Edited by tompa
Link to comment
Share on other sites

I'm using Media Browser Server Version 3.0.5413.14205 with the Argus-TV Plugin 1.0.5413.35689 and Argus-TV 2.3 RC Server.

All on the same Win 8.1 machine. For me it can't even establish a connection between the Argus-TV MB Plugin and the Argus-TV Server.

 

You can find my log here: https://onedrive.live.com/redir?resid=FCA9F896D4BC3DB2%215320

 

When I open up the Argus TV links directly or when I watch and record TV with my XBMC clients it works fine. 

 

argus.png

Edited by CM000n
Link to comment
Share on other sites

I'm using Media Browser Server Version 3.0.5413.14205 with the Argus-TV Plugin 1.0.5413.35689 and Argus-TV 2.3 RC Server.

All on the same Win 8.1 machine. For me it can't even establish a connection between the Argus-TV MB Plugin and the Argus-TV Server.

 

You can find my log here: https://onedrive.live.com/redir?resid=FCA9F896D4BC3DB2%215320

 

When I open up the Argus TV links directly or when I watch and record TV with my XBMC clients it works fine. 

 

argus.png

 

I see in the log that we receive some error from argus

2014-10-28 08:31:51.0171 Error - App: [ArgusTV] It's not possible to initialize a connection to the ArgusTV Server on server localhost with port 49943
	Mindestens ein Fehler ist aufgetreten.
	System.AggregateException
	   bei System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
	   bei System.Threading.Tasks.Task`1.GetResultCore(Boolean waitCompletionNotification)
	   bei System.Threading.Tasks.Task`1.get_Result()
	   bei MediaBrowser.Plugins.ArgusTV.LiveTvService.InitializeServiceChannelFactories()
	InnerException: ArgusTV.DataContracts.ArgusTVException
	ARGUS TV Recorder on server is too old, upgrade server
	   bei ArgusTV.ServiceProxy.Proxies.<PingAndCheckServer>d__e.MoveNext()
	--- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
	   bei System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
	   bei System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
	   bei ArgusTV.ServiceProxy.Proxies.<InternalInitialize>d__5.MoveNext()

Argus is telling us that the recorder is to old....

Link to comment
Share on other sites

I see in the log that we receive some error from argus

Argus is telling us that the recorder is to old....

 

Strange. Like I said, I'm using the latest 2.3 RC of Argus-TV Server.

But maybe something went wrong with the update? I will try a complete reinstall of Argus-TV Server, when I'm back Home.

Link to comment
Share on other sites

Another small update:

Also NO connection problems with the Argus Scheduler Server on a pc different than MBS.

Recordings and TV-Guide is also working, but the guide has many gaps. Will look into it later this evening...

 

For those with connection problems: I had to disable my firewall temporary.

Link to comment
Share on other sites

Another small update:

Also NO connection problems with the Argus Scheduler Server on a pc different than MBS.

Recordings and TV-Guide is also working, but the guide has many gaps. Will look into it later this evening...

 

For those with connection problems: I had to disable my firewall temporary.

 

The gaps are some javascript problems. But I am not a javascript expert. :(

Link to comment
Share on other sites

So, after I made a complete reinstall of the Argus-TV Server, the connection works.

It seems that something went wrong during the Argus update.

 

I can see now my Channels in the Media Browser Server.

But sadly it won't play anything.

I just see a black screen, although Argus-TV itself says that it streams to my Media Browser:

 

4vwlzdmw.png

 

 

Here is another server logfile: https://onedrive.live.com/redir?resid=FCA9F896D4BC3DB2%215322

When I look at the transcoding logfile it is empty? :-/

Edited by CM000n
Link to comment
Share on other sites

So, after I made a complete reinstall of the Argus-TV Server, the connection works.

It seems that something went wrong during the Argus update.

 

I can see now my EPG and my Channels in the Media Browser Server.

But sadly it won't play anything.

I just see a black screen, although Argus-TV itself says that it streams to my Media Browser:

 

4vwlzdmw.png

 

 

Here is another server logfile: https://onedrive.live.com/redir?resid=FCA9F896D4BC3DB2%215322

When I look at the transcoding logfile it is empty? :-/

 

Same error as pünktchen and tompa.....

Something weird is happening, because I don't have it on my machine.

Link to comment
Share on other sites

But you have a analog signal. CM00n and i have digital signal. Maybe also tompa?!

So there must something with the stream that the MBS ffmpeg profiles cannot handle :(

Link to comment
Share on other sites

No idea.

 

Maybe it's possible that somebody expose his api for a moment so i can test it?

For the moment i can't test the digital side (because i only have analog signal)

Do you mean the Argus Scheduler ports or MBS? I would do that, but my upload speed is not enough for live streams :angry:

Link to comment
Share on other sites

The argus scheduler port and the rtsp stream port...

It would be great to have them. I don't need to stream it on a good way.

 

I only want to check if the stream starts....

Link to comment
Share on other sites

No idea.

 

Maybe it's possible that somebody expose his api for a moment so i can test it?

For the moment i can't test the digital side (because i only have analog signal)

Link to comment
Share on other sites

Sorry Sven, for me nothing has changed :unsure:

HD channels are still stuttering like hell: https://www.dropbox.com/s/mxdu48b7gux7w9k/5749cbe497fd037e93ea62380357b068.webm?dl=0

I would guess we need a little bit more buffering before ffmpeg begins to transcode.

 

Oh but it plays now, before it even didn't play right?

 

Sven,

 

On ChannelMediaInfo, try setting ReadInputAtNativeFramerate to true

 

Ok i try to add that property. Or this evening when i get home or at noon at work if i have some time. :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...