Jump to content

Old Kodi shutdown delay seems to be back


jasonmcroy
 Share

Recommended Posts

Well, not really, but since my last post it is doing strange things now. When I posted that log I had only opened it once and closed it. It took 2-3 seconds to close. 

 

After I posted that log I opened Kodi again and then closed it. It took 15 seconds to close! I restarted my computer and then opened it and closed it again. This time it took somewhere between 4-5 seconds to close. 

 

Here is my last log: kodi.log

 

Maybe it is a Kodi issue at this point. I am going to check over on their forums to see if anyone else is having problems. I may start my own post but my experience has been that when someone brings up an issue of this nature it is always blamed on some addon, not Kodi itself...

 

Not sure what I am going to do if I am not willing to have this slow closing of Kodi problem since it is the only stable video player front end option for me right now...

 

-Jason

Link to comment
Share on other sites

The issues I had when I was using Gotham 13.2 was only when using the XBMB3C plugin and then the closing time stayed anywhere from 4-6 seconds. I could sort of live with that even though it was annoying.

 

I never had shutdown issues in Gotham without any plugins installed though. It always shut down very fast. I think I will go back to the Beta3 download of Helix and see what happens with that out of curiosity because it hasn't been this bad up to this point.

 

-Jason

Link to comment
Share on other sites

The XBMB3C add-on has changed a lot in the past 2 months. Would you mind giving Gotham 13.2 a try to see if you can get everything working without a hitch? I just want to exclude the Kodi aspect from the equation with a stable version and try using the Confluence MB3 skin (really basic).

 

I am personally using Gotham, with Beta XBMB3C and Aeon MQ5 skin and I'm not experiencing any delays.

Edited by Angelblue05
Link to comment
Share on other sites

Yes, I am doing that right now. There seems to be a connection issue right now with the Download page on XBMC so it's taking forever! lol

 

Anyway, I will report the results here. I should probably just stick to Gotham until the final version of Kodi comes out.

 

-Jason

  • Like 1
Link to comment
Share on other sites

Wow, this is getting a bit crazy now. I downloaded and installed Gotham 13.2. Now, it's closing at randomly slow rates. Sometimes it closes in 5-6 seconds and sometimes it is as much at 10 seconds. 

 

I looked at the logs and I don't see anything myself other than those last lines:

21:51:35 T:4848 WARNING: Attempted to remove window 10013 from the window manager when it didn't exist

21:51:35 T:4848 WARNING: Attempted to remove window 10014 from the window manager when it didn't exist
21:51:35 T:4848 WARNING: Attempted to remove window 10015 from the window manager when it didn't exist
21:51:35 T:4848 WARNING: Attempted to remove window 10016 from the window manager when it didn't exist
21:51:35 T:4848 WARNING: Attempted to remove window 10017 from the window manager when it didn't exist
21:51:35 T:4848 WARNING: Attempted to remove window 10018 from the window manager when it didn't exist
21:51:35 T:4848 WARNING: Attempted to remove window 10019 from the window manager when it didn't exist
21:51:35 T:4848 WARNING: Attempted to remove window 10021 from the window manager when it didn't exist
21:51:35 T:4848 WARNING: Attempted to remove window 10107 from the window manager when it didn't exist
21:51:35 T:4848 WARNING: Attempted to remove window 10115 from the window manager when it didn't exist
21:51:35 T:4848 WARNING: Attempted to remove window 10104 from the window manager when it didn't exist
 
But those lines have been there all the time from what I can recall from before. 
 
Maybe there is a general issue between XBMC and my system? I don't have anything different installed than when I was last using the program. 
 
Here is my last log in case you see something that I don't: xbmc.log
 
-Jason
Link to comment
Share on other sites

Ok so the module error is gone now. I have a quick question, it seems there's something trying to connect to your XBMC (or the other way around) but it failed to do so. 

21:51:02 T:4848  NOTICE: stop all
21:51:34 T:6040   ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28)
21:51:34 T:6040   ERROR: CCurlFile::CReadState::Connect, didn't get any data from stream.
21:51:34 T:6040   ERROR: XFILE::CFileCache::Open - failed to open source <http://mirrors.xbmc.org/addons/gotham/addons.xml.md5>

Maybe it's a network issue? It could also be because the XBMC domain is super slow right now. I am still looking. Will let you know if I find something.

Edited by Angelblue05
Link to comment
Share on other sites

Do you mean that it's trying to connect to the XBMC website? That's the way I read that in my completely noob way. :-)

 

Would that mean that it's perhaps an error on their end? If it matters, when I mentioned above I tried to download from the links (both for the Gotham version and for the Helix Beta3 version or any of the nightly links) it takes a good 3-5 minutes for anything to happen. I have no issues connecting to the forum or any other websites through my browser. 

 

-Jason

 

Edit: Could it be as simple as a problem with their repo? I just opened the program and tried to go into the xbmc repo and it just keeps trying to connect but never does.

Edited by jasonmcroy
Link to comment
Share on other sites

That is what I'm reading on the XBMC/Kodi forums, jasonmcroy. :huh:

 

http://forum.kodi.tv/showthread.php?tid=187277

 

Yes, I have been reading similar threads. I Google the error and there are many different discussions about it but I haven't found a definite solution yet...

 

Sometimes XBMC closes instantly and sometimes it takes 3 seconds and sometimes 10. It's very inconsistent. 

 

My XBMC repo takes about 30 seconds to open and then it's empty when it does open even if I try to "force refresh".

 

Thanks for your help, I will keep checking on the forums to see if I find a solution that may help. If you have any other ideas feel free to let me know. :-)

 

-Jason

Link to comment
Share on other sites

I have the same error as you in my logs, but mine goes thru the error in 1-2 seconds.....Yours took a solid 30 seconds according to your last posted log....Odd....

 

Edit: I can't connect to the xbmc repo either. I got a major add-on update a few minutes ago. Something really odd is going on.

Edited by Angelblue05
Link to comment
Share on other sites

Wow. I guess that is why yours is closing faster so you haven't noticed it. 

 

I found out that if I try to open the XBMC repo (it takes about a minute to open) and then it shows it is empty. If I exit XBMC after that, it closes immediately. I guess it has already timed out by then so closing is not hampered by that.

 

Maybe it's an issue on their mirror servers because if I try to open the link in my browser it also times out and won't connect. Strange.

Link to comment
Share on other sites

I don't know about you, but mine just fixed itself a few minutes ago. I'm now able to instantly load the XBMC.org add-ons repo. I no longer see the timeouts in my log either.

Link to comment
Share on other sites

For the reference: the kodi/xbmc repo's were having some issues this weekend...

Think it's fixed now.

Link to comment
Share on other sites

As for the closing speed of services in the background:

 

I recently optimized the Titan helper service so it will always shutdown within 2 seconds.

This is change that can also be applied to the xbmb3c services over time but a little delay is to be expected as all those addons run tasks in the background which have to be finished.

 

As soon as the main XBMC servers are up to speed again please try again with xbmb3c and titan and report how it's going.

On all of my machines I have a shutdown/exit time of about 2 till 6 seconds which is really normal for xbmc...

Link to comment
Share on other sites

I am glad you're not having trouble now, but I just reinstalled everything and I am still having the issue. It's still taking forever to even go to the download page on their mirrors in my browser. I know that is the issue because if I open the repo in the program and wait for it to timeout then close the program it closes instantly. Also, if I leave the program open for a minute or two and then close it, it closes instantly as well.

 

I guess I will have to deal with it until it's fixed on their end. I may just leave it open in the background minimized when I am not using it. Lame, but it's the only frontend that I have to play with my Media Browser files.

 

-Jason

Link to comment
Share on other sites

Well, if you want to attach another log to see what's happening, feel free to do so. Is the delay still happening, if you wait longer (let's say the length of an episode) to close the program? Maybe, if you are closing XBMC/Kodi too quickly, not everything has the chance to load/unload and that could also cause a delay.

Edited by Angelblue05
Link to comment
Share on other sites

I could upload another log in case you see anything else, but I really think it's the issue we have been talking about. Yes, if I wait for a bit and then close Kodi, it closes instantly but I looked in the log and that timeout where it's trying to connect to the mirror site is still there. You are correct about me closing it too fast to let all the processes run completely, but the error is still happening. Is there anyway to manipulate the xml file to override it trying to connect to their mirror site? I don't use anything in their repo anyway.

 

I am going to watch a show right now and then close it to see if it closes faster (with just the xbmb3c plugin and no skin).

 

Here is my last log if you want to look at it again: kodi.log

 

-Jason

Link to comment
Share on other sites

Ok, I just opened Kodi, installed the xbmb3c repo and enabled the plugin. Just for fun, I opened the Kodi default repo and it opened right away with all the data there now. I exited the program and it closed instantly. I looked in the log and that error we were seeing before is not there now!

 

Here is the latest log: kodi.log

 

Look like we're back in business for now. Still getting that dll missing error at the end. I don't know what that's all about.

 

-Jason

Link to comment
Share on other sites

That's great news! :) All I know about the error is that it's PVR related. If it's not causing you any delay, I would not worry about it or post about it on the official Kodi forums. 

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

Ok. Thanks for helping me out with this one, it was driving me nuts.

 

I am not sure if I should post a separate thread or not, but in the last log I checked out after watching a video and closing Kodi I see this line several times:

 

20:37:22 T:948 WARNING: CPythonInvoker(6, C:\Users\Jason\AppData\Roaming\Kodi\addons\plugin.video.xbmb3c/default.py): the python script "C:\Users\Jason\AppData\Roaming\Kodi\addons\plugin.video.xbmb3c/default.py" has left several classes in memory that we couldn't clean up. The classes include: class XBMCAddon::xbmcaddon::Addon

 

I am not sure what it means or if it's a potential problem with anything. Any idea?

 

-Jason

Link to comment
Share on other sites

This is nothing to worry about. It's normal. To be honest, your log looks fine.  :) The only time you need to worry, is if you are trying to access MediaBrowser content and you get something like Script Failed! XBMB3C. Hope this helps!

Link to comment
Share on other sites

This is nothing to worry about. It's normal. To be honest, your log looks fine.  :) The only time you need to worry, is if you are trying to access MediaBrowser content and you get something like Script Failed! XBMB3C. Hope this helps!

 

Thanks! It definitely helps. I never know what is important and what isn't. :)

 

Thanks again for all of your attention and help. I think we can end off on this one now.

 

-Jason

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...