Jump to content

Old Kodi shutdown delay seems to be back


jasonmcroy
 Share

Recommended Posts

Hello.

 

I know there was an issue months ago where XBMC/Kodi was taking a while to shut down when using the XBMB3C plugin. You guys looked into it and fixed it.

 

The issue came back for me about a month ago and to be honest, I thought it was a different plugin that I use that was causing the issue and I had forgotten about the old XBMB3C issue until just recently. It came back to my attention because to be honest, I started using the Plex Media Server out of curiosity as I was having some streaming issues with Media Browser so I wanted to see what I would get out of the other services available. 

 

Their Plex Home Theater works great for me and is fast and nice looking and plays all of my videos very well. However, the streaming issues are just as prevalent with Plex and I have decided I need to upgrade my cpu. I have ordered a Quad Core cpu to use in my motherboard so that should handle that issue.

 

Anyway, I reinstalled my entire OS and installed only Plex and I have also been using Plexbmc in the Amber skin with Kodi Helix 4 along with the other plugin that I normally use but without the XBMB3C plugin. I noticed that with this set up it only takes about 2-3 seconds for Kodi to close when I exit. I have been using this set up for the past 3 weeks with no issues at all.

 

Now, my monthly Plex Pass is almost ended (I signed up just to try it out) and would rather move back to Media Browser since I have a lifetime membership and I overall like it more than Plex.

 

I just installed the XBMB3C plugin again to try everything out. Now, it is taking about 10-15 seconds for Kodi to close up when I go to exit. It's currently the last bug that I need to handle before moving fully back over to Media Browser.

 

I am running Windows 8.1 and I just downloaded the repo about an hour ago so I guess I have the latest version. It says it is version 0.9.6.

 

Here is my Kodi log: xbmc.log

 

Let me know if there is any other log you need.

 

-Jason

Link to comment
Share on other sites

boywhosetsfire

I also installed Helix yesterday and it's shutting down with XBMB3C within 2-3 seconds, so it's not a general problem. But even if it worked for you before installing XBMB3C I would try to uninstall PleXBMC if you don't need it anymore. No idea if it can cause problems when both plugins are running, but at least it's worth a try to remove unused ones.

Link to comment
Share on other sites

I also installed Helix yesterday and it's shutting down with XBMB3C within 2-3 seconds, so it's not a general problem. But even if it worked for you before installing XBMB3C I would try to uninstall PleXBMC if you don't need it anymore. No idea if it can cause problems when both plugins are running, but at least it's worth a try to remove unused ones.

 

Thanks for your response. I am glad to know that it's not a general problem. I will try uninstalling that other plugin and see if it makes a difference. If not I will uninstall Kodi completely and reinstall with just the XBMB3C plugin and see what happens. 

 

It's even a little funny to me to bring this up as a problem in the first place because 10 seconds isn't really a long time, but it seems that way when I want to exit a program and do something else.  :)

 

-Jason

Link to comment
Share on other sites

I just wanted to update this thread and let you guys know that I reinstalled everything, have completely removed Plex from my system and now am only running Kodi Helix with XBMB3C and Titan Helix skin.

 

Shut down time now varies between 5-9 seconds. I can work with that for now. Hopefully as time goes on and there are further updates with both Kodi and the plugin that time will decrease.

 

Either way, I love this service and everything you guys do with it to provide us with it. 

 

Thanks!

 

-Jason

Link to comment
Share on other sites

are there requests being sent to MBS on closing? you could try monitoring with fiddler or wireshark to see if something is taking a long time which would cause the shutdown process to get hung up

Link to comment
Share on other sites

Thanks for the suggestion Luke. I will try that out. I have never used any of the two programs you mention but I am sure I can figure it out with Google. 

 

I will let you guys know if I find anything. 

 

-Jason

Link to comment
Share on other sites

Hi Luke - I downloaded Wireshark and ran the program, then opened Kodi and then closed it again. 

 

Keep in mind, I am no programmer or too tech savvy, but I see 4 instances of a communication with Media Browser listed out in four lines of some code with some text but I have no idea what any of it means or if any of the notifications show any particular lag of any kind. 

 

When I went to close the program it asked me to save the packet data which I did. If it is useful to someone to look at I could PM it since I have no clue what I am looking at or if you want to tell me what may be significant to look for I could try it!  :)

 

-Jason

Link to comment
Share on other sites

  • 1 month later...

Have you tried to use a skin other than titan?  I know there were a few issues with the titan helper service associated with the skin (i think the issues have been fixed, but not sure).  I would try to remove the titan skin, and the helper service from your addons directory, try with a different skin after restarting kodi and see if the issues persist.  that will help narrow it down to addon vs skin vs something else being the issue.

 

Thanks, but I have used the other skin as well with the same issue. This has been long term for me, it's just that now it seems to be worse than it was before.

 

 

@@jasonmcroy

 

The log is not showing what's going on. You will need to enable XBMB3C log (level 1) , recapture the exit delay and post the log again. Here's how to enable debug log: Enabled Add-ons > Video Add-ons > XBMB3C. Once you are in the configuration panel, go to the Advanced Tab (it is the last one) and enable the XBMB3C log to level 1 - info.

 

Thanks!

 

Thanks for your quick reply. Ok, I upped the log level and exited Kodi, then re-entered. I briefly played a file, then exited again.

 

The log is now too big to upload directly. I deleted the original log and then went back into Kodi and briefly played a file then exited.

 

I used pastebin: http://pastebin.com/WF3zJFwF

 

Thanks.

 

-Jason

Link to comment
Share on other sites

Thank you for posting your log. I do not see anything out of the ordinary, but I'm sure one of the dev will have a look. Meanwhile, were you using Helix Beta 3 previously, when you were experiencing the delay? Can you try the latest nightly build of Kodi to see if you have a better experience?

Link to comment
Share on other sites

Thank you for posting your log. I do not see anything out of the ordinary, but I'm sure one of the dev will have a look. Meanwhile, were you using Helix Beta 3 previously, when you were experiencing the delay? Can you try the latest nightly build of Kodi to see if you have a better experience?

 

Thanks for taking a look at it for me. The last time I posted about this I was told something similar, nothing in my log shows there to be an issue. I was not using the Beta3 previously. I had the issue with Gotham 13.2, and every Helix version since it was released. It comes and goes as to how long it takes to shut down. Sometimes it's 7 seconds, sometimes it's 12 seconds - very random.

 

I have tried uninstalling Kodi and installing with the XBMB3C plugin only to also rule out any other plugins (of which I only install one) and I would have the same problem. I have tried without installing any plugins and then I tried with just the one other plugin I use and no XBMB3C, etc. In the past two weeks I have been using only Plex server with the Plexbmc plugin and no problems in that whole time. 2-3 seconds to close.

 

I am discouraged to say the least since Kodi is the only front end I can stably play video files with Media Browser server on my living room HTPC.

 

It looks like I am the only one having this issue too which I know makes it harder to figure out.

 

Anyway, thanks for looking.

 

-Jason

Link to comment
Share on other sites

This line bugs me, however: 

17:04:07 T:6112   ERROR: dllFreeLibrary - Invalid hModule specified

When googling it, it does bring up "recent" posts about causing a hang when exiting Kodi. Do you, by any chance, use a PVR addon? Other than XBMB3C, is there any default addons running? Hopefully, someone might have an idea as to what is causing the shut down delay. Keep hope! :)

 

What is StorageServer add-on? Is it a cache plugin?

Edited by Angelblue05
Link to comment
Share on other sites

I also cannot see anything that stands out. Possibly the skin.widgets service is taking time shutting down, looking at the below it seems to take 4 seconds after the warning for things to kick in...but this is purely guess work. It may be worth disabling that service to see if anything improves.

 

17:03:58 T:3560 WARNING: CPythonInvoker(1, C:\Users\Jason\AppData\Roaming\Kodi\addons\service.skin.widgets\default.py): the python script "C:\Users\Jason\AppData\Roaming\Kodi\addons\service.skin.widgets\default.py" has left several classes in memory that we couldn't clean up. The classes include: class XBMCAddon::xbmcgui::Window,class PythonBindings::XBMCAddon_xbmc_Monitor_Director,class PythonBindings::XBMCAddon_xbmc_Player_Director

17:03:58 T:3776 NOTICE: StorageServer-2.5.4 Closed down

17:04:02 T:3904 NOTICE: breaking..........................

Link to comment
Share on other sites

This line bugs me, however: 

 

17:04:07 T:6112   ERROR: dllFreeLibrary - Invalid hModule specified
When googling it, it does bring up "recent" posts about causing a hang when exiting Kodi. Do you, by any chance, use a PVR addon? Other than XBMB3C, is there any default addons running? Hopefully, someone might have an idea as to what is causing the shut down delay. Keep hope! :)

That looks to be it! Great spot!! http://forum.kodi.tv/showthread.php?tid=203554&pid=1798794

There's some pvr stuff going on in the log so I think you hit it on the nail.

Link to comment
Share on other sites

Ok, I am bringing this issue back up again because now the shutdown issue has gotten worse for me and I received no reply regarding what I tried in my last post, which is moot at this point because since that time I have reinstalled my OS and all my programs.

 

So, starting new. I recently stopped using MB because of some playback issues I was having with Kodi and the plugin (I saw the thread with this issue being addressed) and since the only other HTPC option (for me since I don't have WMC on my Windows 8 machine) is MBT which doesn't play all my files back very well (it has come a long way since I first started using it but it's still not perfect) I didn't have any player that I could use on my living room machine which is where 90% of video watching occurs. I have a Roku for the bedroom which plays everything really well.

 

I started using Plex again because Plex Home Theater plays everything I throw at it with no problems and plays them all very well (even better than Kodi). I installed Kodi with Plexbmc and one other plugin that I always use. With this set up Kodi closes every time for the past 2 weeks in about 2-3 seconds.

 

Today, because now the playback issue in Kodi using the Kodi/MB plugin is solved I want to go back to using MB because outside of the playback issues, I love everything else about the software.

 

So, I reinstalled Kodi so I could start fresh. I am using Helix Beta3. I downloaded the stable repo for XBMB3C and installed the plugin, version 1.9.713 and Titan Helix version 3.1.25. I checked everything regarding playback and all is good there. I had to exit Kodi a couple of times and noticed right away the exit delay was there. At first it was only about 6-7 seconds. However, it seems to be random now as to how long it takes to exit. The last time I tried to exit it took 17 seconds.

 

Here is my Kodi log: kodi.log

 

Thanks.

 

-Jason

Link to comment
Share on other sites

@@jasonmcroy

 

The log is not showing what's going on. You will need to enable XBMB3C log (level 1) , recapture the exit delay and post the log again. Here's how to enable debug log: Enabled Add-ons > Video Add-ons > XBMB3C. Once you are in the configuration panel, go to the Advanced Tab (it is the last one) and enable the XBMB3C log to level 1 - info.

 

Thanks!

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

Have you tried to use a skin other than titan?  I know there were a few issues with the titan helper service associated with the skin (i think the issues have been fixed, but not sure).  I would try to remove the titan skin, and the helper service from your addons directory, try with a different skin after restarting kodi and see if the issues persist.  that will help narrow it down to addon vs skin vs something else being the issue.

Link to comment
Share on other sites

Ok. After much testing, opening and closing Kodi and disabling addons one by one, I don't think it is just one addon that is causing the overall issue but several.

 

The three that I think are the biggest culprits are Axel Downloader (downloads with Icefilms plugin), Grab Fanart, Titan Skin Helper Service and the XBMB3C plugin itself.

 

Here is why I think this: Disabling Axel took me down to 15 seconds to shut Kodi down (it was up to 17-20 seconds when I got home and tried this all again). Disabling Grab Fanart didn't seem to change the shutdown time, but I will explain later why I think it's a problem plugin. Disabling Titan Skin Helper Service got me down to 6-8 seconds shutdown time. Disabling XBMB3C got me down to 1-2 seconds shutdown time.

 

Now, each one of the above plugins have something additional that I noticed that I don't notice with the other plugins I disabled. First, every time I hit the disable button for the plugin, Kodi froze up and I had to exit it via Task Manager. One for one this happened. On the other plugins not mentioned here I did not have that issue.

 

Second, when I go into the "Disabled Addons" screen to look at the plugins I just disabled, there are 4 instances showing of the Axel Downloader plugin, 2 instances of the Grab Fanart plugin, 2 instances of Titan Skin Helper Service plugin and 3 instances of XBMB3C plugin showing on that page.

 

What does that mean if anything? I am not a programmer, I am just going on a hunch here. Maybe this may be a clue for you guys, maybe not. Any ideas?

 

I do know that the fastest I ever had Kodi closing was back when I only had XBMB3C installed with the 1080XF skin only. It still took 5-6 seconds to close Kodi down, but that was faster than what I have right now at least.

 

I am going to reinstall the XBMB3C plugin and 1080XF for now since at least it won't take 15 seconds to close. I don't like the views offered in 1080XF, otherwise I would just keep that skin from now on.

 

If you have anything I should try, please let me know.

 

Thanks.

 

-Jason

Link to comment
Share on other sites

Yes. I even went so far as to uninstall Kodi completely, downloaded the latest nightly and ran that. The error is there even without enabling any pvr addons or any others at all.

Link to comment
Share on other sites

There was a change/workaround that was made when playback stopped in helix. This was originally putting 2 instances of the xbmb3c addon in programs. I changed that a week or so ago, but from Helix beta 3 I understand we can go back to howit was originally..so I will put that change back in and hopefully it solves the problem..or at least prevents 3 instances from showing up,

 

As for the views in 1080XF, I agree some of them could be better. I'll be looking to port some across from different skins so let me know which ones are your favourite.

Link to comment
Share on other sites

Thanks for your explanation! :-)

 

As to the views, the main one I like is a Bannerplex type view for series like is in the Titan skin. The poster views in Movies sections look good but move too slow when I scroll through them.

Link to comment
Share on other sites

Is the error that I posted earlier still appearing in your logs after disabling the add-ons you mentioned?

 

Just to illustrate, I re-installed my OS last night. I have re-installed MB Server and my PVR program (NextPVR) and the latest Kodi nightly build (from 11-22-14). 

 

I just ran it and looked at the logs and still see that error you noted earlier. 

 

Here is the log: kodi.log

 

This is a new install with no addons added by me. I haven't even set it up for Live TV yet. I am now going to slowly add my addons and check each one to see what happens with the shutdown issue. 

 

Like I said before, I think it is a combination of several different addons, but we'll see what happens.

 

-Jason

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...