Jump to content

"Conversion" not working on TrueNAS


JonnieBlaze
 Share

Recommended Posts

JonnieBlaze

Hi all,

I just recently purchased the Emby Premier subscription to see how the "Conversion" functionality works.  Upon getting everything setup, it seems the converted file gets created, but errors when attempting to copy that file to the destination folder.  I assume it is permissions related but have done everything I know of and still can't figure it out.  Hoping someone here can help.

  • TrueNAS CORE version TrueNAS-12.0-U8
  • Emby version 4.6.7.0 installed using these instructions:
  • Dataset named "Media" within "Tank" pool with permissions setup using these instructions:
  • Mount point in the jail setup as follows:
    • Source "/mnt/Tank/Media"  
    • Destination "/mnt/Tank/iocage/jails/emby-server/root/media"
  • Attempting to convert with these settings: 
    • \Media\Documentaries\Dolby Surround Sound Tests\Dolby Atmos\Dolby Atmos.mkv
      • Convert To "Original media folder, next to original files"
      • Profile "Mobile"
      • Quality "1.5 Mbps"
  • MP4 file (3.53MB) gets created here:
    • \IOCage\jails\emby-server\root\var\db\emby-server\sync\5\5  
      • 68d5a293-3243-48f3-a3d4-5148d2655a0b.mp4
  • Two files (both 0KB) get created here:
    • \Media\Documentaries\Dolby Surround Sound Tests\Dolby Atmos
      • Dolby Atmos - mobile.mp4
      • Dolby Atmos - mobile (1).mp4

Some logs are attached.

Emby seems to be able to create other files, namely .nfo files, in this directory, as well as the 0KB .mp4 files, so its unclear to me why it's not able copy/move the entire 3.53MB file to this location.

Any ideas on what else I need to do to get this working? 

embyserver.txt ffmpeg-transcode-68d5a293-3243-48f3-a3d4-5148d2655a0b_1.txt

Link to comment
Share on other sites

The errors in the logs and 0 size files are a sign of a permissions problem or a combination of permissions and ownership of the directory "Dolby Atmos".

I don't know enough about TrueNAS or the quirks of Emby+mono to give specific advice. Though from the linked thread it looks like ACLs are an option from the Admin UI which could take care permissions problems stemming from media library files and directories with mixed ownership.

 

Link to comment
Share on other sites

JonnieBlaze

It seems to be something related to the ACLs.

  • Test 1
    • If I setup the ACLs on the "Media" dataset as recommended in the forum post I listed above in my original post, the conversion fails.  It is unable to copy the new file to the destination.  It can create that 0KB file, but not copy the actual converted media over.  That part really throws me off, why can it create the 0KB but not the actual file? 
      • image.png.1207b4bfcbaa5f37e7d7f4b444bbcc7c.png
  • Test 2
    • 989 is the id for both the default user and default group in the emby jail.  If I set the ACLs on my "Media" dataset so that user and group 989 are both the owners of the dataset, the conversion fails in the same way. 
      • image.png.34e6f6caef7e617cea46975b78a78a73.png
  • Test 3
    • If I go into the TrueNAS web gui and "Strip ACLs", the conversion works. 
      • image.png.e86efb0faacdddcdbca8fbeb10fecfa8.png

 

So, must be ACL related?  I would think so,  since the only difference between Test 2 and Test 3 are the little plus(+) signs next to the list of permissions meaning ACLs were found.

So, going back to Test 2 and looking at the ACL's I see this:

  • fanart.jpg (a file created by Emby):
    • image.png.d350527d4ac03ed089a884e1233fdbb7.png
  • Dolby Atmos - mobile.mp4 (a file created by Emby):
    • image.png.7e1c5a22d3bbd82ea2c41327af3f2b46.png

Are there any permission (ACL) differences between that fanart.jpg file that was successfully created and the Dolby Atmos - mobile.mp4 file that was created but couldn't be replaced with the converted file?  I don't see any in the two screenshots above, so it's still unclear to me why one would work and one wouldn't.

I saw in the error message that the "System.IO.FileSystem.CopyFile" function was being used for moving the converted file?  Is that the same function used when choosing "Refresh Metadata > Replace existing images"?  I was just curious if maybe a different function was used and that's why its working in one place but not the other.

 

 

 

Sorry about these two screenshots, I can't get them to go away lol

image.png

image.png

Edited by JonnieBlaze
formatting
Link to comment
Share on other sites

JonnieBlaze
Posted (edited)

I did some more testing. 

I created a new dataset in TrueNAS with identical permissions to the dataset I'm having issues with.  Once setup, I copied my test file over to the new dataset and mounted the dataset to the jail so Emby could see it. I started the "Convert" process for both files in both datasets.  The "Convert" process worked for the new dataset, but not the original.  I doubled checked permissions one more time.  The permissions looked the same on the directories, but the new files (the 0KB and the one that worked) were different.  The one that worked had additional ACLs set directly on the file.

Trying to figure out why one new file had additional ACLs and the other didn't, I looked at the properties of the datasets in TrueNAS.  After clicking the "Advanced Options" button, near the bottom of the screen I found an "ACL Mode" option.  It was set for "Restricted" on my original dataset and "Passthrough" on the new dataset.

I changed the original dataset to "Passthrough", retried the "Convert" process, and it worked.

I don't completely understand how they explain this "ACL Mode" field, but their explanation is below.  I might try posting in their forum to get more information, because this says something about "Restricted" being preferred for SMB sharing, and this dataset is shared.  So I just need to make sure I understand it and select the correct option. 

image.png.5d5cc92707f611beb0ba2a724821cf12.png

 

Edited by JonnieBlaze
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...