Jump to content

App Crashing on playing 4k video more details in post


DarKni8
 Share

Recommended Posts

Happy2Play
6 hours ago, DarKni8 said:

Also i feel if someone has disabled the transcoding , why not just serve the media as it is?

Emby already does and if the player supports if it will play.

So are you saying with transcoding disable the file plays?

I have no idea what the other guys are doing so don't know if they are faking the client or what but to me that could just make things worse.

6 hours ago, DarKni8 said:

Hardware is capable enough in today to play anything.

Well that is not true as a Roku is very picky on its media, Browsers will very across the board as not two browsers have the same capabilities and have their own limitation.  So in the end every client would have  a custom player instead of using native support that has documented limitations.

Link to comment
Share on other sites

DarKni8
6 minutes ago, Happy2Play said:

Emby already does and if the player supports if it will play.

So are you saying with transcoding disable the file plays?

I have no idea what the other guys are doing so don't know if they are faking the client or what but to me that could just make things worse.

There are two different behavior i am seeing on same file

Case 1 - Emby server 4.6.7.0 Linux

 - Transcoding disabled, same file plays directly same client that's my android phone

- Transcoding enabled, same file doesn't play at all

Case 2 - Emby server 4.7.3.0 windows

 - Transcoding disabled, file doesn't play, same client that's my android phone.

- Transcoding enabled, file plays.

Such a strange behavior , my fingers are crossed for next release.

In this emby server 4.6.7.0 is correct, transcoding is disabled and it does it job to keep quiet and serve the media directly. Whereas 4.7.3.0 is not able to do this hence video playback fails.

 

Quote

Well that is not true as a Roku is very picky on its media, Browsers will very across the board as not two browsers have the same capabilities and have their own limitation.  So in the end every client would have  a custom player instead of using native support that has documented limitations.

See, I agree with everything you are saying but after I disable transcoding, there should be no validations like video level support and other because i want my media to be played as it is. If its choppy I transcode it or convert it it's up to end user. But to take that liberty away from user where i can't play original print just because emby says video level not supported? No sir you can't say this to people who are using octa core chipsets with more power than average desktop CPU 5 - 7 years ago. 

Link to comment
Share on other sites

Happy2Play
4 minutes ago, DarKni8 said:

Case 2 - Emby server 4.7.3.0 windows

I assume you mean 4.7.0.30 and if so it is a beta and does have current defects.

But client playback capabilities come from the client not the server.

But a log from both stable and beta server may help here.

Link to comment
Share on other sites

DarKni8
Posted (edited)
20 minutes ago, Happy2Play said:

I assume you mean 4.7.0.30 and if so it is a beta and does have current defects.

But client playback capabilities come from the client not the server.

But a log from both stable and beta server may help here.

My bad yes  4.7.0.30  , i will  update more logs here , meanwhile can you look into logs which i have uploaded here till now. 

Edited by DarKni8
Link to comment
Share on other sites

Happy2Play
Just now, DarKni8 said:

My bad , i will  update more logs here , meanwhile can you look into logs which i have uploaded here till now. 

2 of the transcode logs don't really show anything like they just die and the 3rd can not decode the audio track.

Error while decoding stream #0:1: Invalid data found when processing input

 

Link to comment
Share on other sites

DarKni8
7 hours ago, Happy2Play said:

2 of the transcode logs don't really show anything like they just die and the 3rd can not decode the audio track.

Error while decoding stream #0:1: Invalid data found when processing input

 

Hi Mate get ready many logs incoming :)

 

embyserver 4.6 playing without transcoding.txt ffmpeg-directstream-740d62f7-8d09-4c7e-901b-6e196b9d5790_1 4.6 playing without transcoding.txt

Link to comment
Share on other sites

DarKni8

@Luke @Happy2Playpros, were you able to catch anything in logs?

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Link to comment
Share on other sites

  • 2 weeks later...
DarKni8
Posted (edited)

 

 

Edit - @Luke Nope its not fixed , still facing the same issue.

Edited by DarKni8
Link to comment
Share on other sites

  • 4 weeks later...
  • 3 weeks later...
DarKni8
6 hours ago, cayars said:

@DarKni8, what other clients have you tried?

Works on emby theatre windows,  and emby ios.

Link to comment
Share on other sites

  • 3 weeks later...
DarKni8

bumping again, it has been almost 6 months now. My gf has already rejected emby for messed up download functionality, i am hanging on paying monthly to support luke and team in some ways but i feel the condition is exactly same as plex forums now. Despite identifying the problem being improper video level luke not looking into it is just sad, same file works in jellyfin and plex flawlessly

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...