Jump to content

Unable to install 4.6.7 to DSM 7.0


stuartgib
 Share

Recommended Posts

I've been following the instructions in the DSM 6 to DSM 7 Emby Migration Instructions post to upgrade my DS414j to DSM 7.

I updated my install to the lastest version (emby-server-synology_4.6.7.0_armv7.spk), checked its operation, shut down then uninstalled and updated to DSM 7.0.1-42218.

I'm now stuck at installing the dsm7 version (emby-server-synology7_4.6.7.0_armv7.spk), as I get the error "Invalid file format. Please contact the package developer" whenever I try to manually install. I have restarted the server and get the same error on Firefox, Edge and Opera (which was suggested under post "4.4.3.0 Update to DSM 7" back in July). I have also tried re-downloading the spk from the github (both the armv7 and comcerto2k variants).

I've even tried the version listed (4.6.3) in the instructions and the Syncology package center verison (4.6.4.0-3001 currently) from which I get the error "Unable to install "Emby Server". Please try again later or contact the package developer."

 

Edited by stuartgib
edit
Link to comment
Share on other sites

That is strange. It sounds like the migration is likely blown at this point and would need to be copied over again so don't to anything with the /volume1/Emby you have from the DSM 6 version.  Keep that safe.

Now we need to figure out what type of issue is causing this wrong version message.

Please try downloading and installing the beta version from the page https://emby.media/synology-server.html on the bottom half of the page. This is build 4.7.0.19..
If you like I can remote in and have a look with you to see if I see anything. Send me a PM if you would like to do this.

  • Agree 1
Link to comment
Share on other sites

emby-server-synology7_4.6.7.0_armv7

emby-server-synology7_4.6.7.0_armv7_standalone.spk

emby-server-synology7_4.6.7.0_comcerto2k

emby-server-synology7_4.6.6.0_armv7

emby-server-synology7_4.6.3.0_armv7

emby-server-synology7_4.7.0.19_armv7

emby-server-synology7-mono_4.6.7.0_armv7_legacy

Link to comment
Share on other sites

I don't use it for any other apps, but Jellyfin (setup on a different port) installed (with ffmpeg) fine after I couldn't get Emby running.

The package center app downloads,

image.png.5a5e00e8fcbae98fc06d6671caebc322.png

Then changes to installing,

image.png.7fb127ebc03b8cf7ff9563bb2ecfd628.png

Then I get a error in the notifications

image.png.918f38307a8a28227433db8bac417159.png

It only leaves me this in the logs

image.png.eeb85920a3bfdbe457f8e4c847bd7d5c.png

 

Link to comment
Share on other sites

Out of curiosity is JF running when you try to install this?  Any chance you could uninstall JF and try Emby install again?
I can't help to wonder if that could interfere with the installation as many libs and services use the Emby name.

Edited by cayars
Link to comment
Share on other sites

Has anything changed since I originally couldn't install the package? Emby wouldn't install when it was the only non Synology package.

I'm not loving jellyfin so far, but it works. I really don't want to have keep setting up libraries as the 414j is slow.

Link to comment
Share on other sites

Nothing has changed that I know of Emby wise.  However the package installer could be getting confused if JF is using Emby's name space.
I'd try uninstalling JF and seeing if Emby will install.  If not you can reinstall JF and be right back where you were.

Link to comment
Share on other sites

Thank you for trying that for us, appreciated.
I do not think there is anything I can do to assist you.
I think this is going to require dev support to try and figure out what the issue is.

@Luke

Link to comment
Share on other sites

  • 2 weeks later...

You picked the correct package for your device, the armv7 flavor should definitely be compatible with the 414j and its comcerto2k CPU.

Are you able to install packages from synocommunity like this one https://packages.synocommunity.com/ffmpeg/39/ffmpeg.v39.f41890[comcerto2k].spk ?

What worries me is that  it doesn't work via the software center (where it most definitely should).

Link to comment
Share on other sites

  • 1 month later...
stuartgib

@LukeStill the same error. I have setup a seperate server in the meantime so it's less of a critical issue for me, but happy to try and assist in solving it incase there is a larger issue at hand.

Link to comment
Share on other sites

5 minutes ago, stuartgib said:

@LukeStill the same error. I have setup a seperate server in the meantime so it's less of a critical issue for me, but happy to try and assist in solving it incase there is a larger issue at hand.

Even from package center without using our manual spk?

Link to comment
Share on other sites

stuartgib

actually strike that the package center had been behind. Does not install from the apk or the package center. Same non specific failure error from Synology.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...