Jump to content


Photo

iPad to Chromecast Bugs

iOS iPad Chromecast

  • Please log in to reply
7 replies to this topic

#1 thaBadfish OFFLINE  

thaBadfish

    Newbie

  • Members
  • 4 posts
  • Local time: 11:13 AM

Posted 10 September 2014 - 05:43 PM

I have been using the media browser app (1.1.3) for awhile now both by itself and streaming to my TV via Chromecast. I haven't had any problems with playback on my iPad air itself, but recently I have been having many issues with streaming to Chromecast.

 

Typically, I would have Chromecast started and waiting, open the app, connect to Chromecast, hit the refresh button on the app which changes the TV to media browser, and select content to play. This has, in the past few weeks, worked flawlessly. In the past week or so, the content will play for a few minutes and stop, or not play at all. I then proceed to disconnect, restart Chromecast, restart my iPad, restart the app, restart the server, and even restart my wifi in my attempt to fix the problem. It then might work for one episode of a show, but then not work for the next episode.

 

Last night a stream to Chromecast froze as I described above, but instead of trying to troubleshoot it I just tried playing back on the app itself without even restarting anything. It worked flawlessly, leading me to believe the issue is not with the server, or my network, but with the app streaming to Chromecast.

 

Please let me know how I can help resolve what I believe is a bug. If you tell me how, I can send whatever logs the server generates, or I can post a video of the issue so you can see exactly what my workflow is.



#2 tmb4016 OFFLINE  

tmb4016

    Advanced Member

  • Members
  • 201 posts
  • Local time: 10:13 AM

Posted 18 September 2014 - 05:34 PM

hi -  this will not provide any help with you issue but in my experience with the ipad app is not good and I have seen same issue as you are seeing. Other issues the worst of which is items do not refresh. Newly added items show in the recent list but no matter what I try short of a complete reinstall they do not show up 'normally'. Performance is slow, playback awful - It looks good but performs terribly. With or without chromecast. I have resorted to the web client on the ipad and works fine for what I need. App is not worth the money or wait.



#3 darwindeeds OFFLINE  

darwindeeds

    Advanced Member

  • Alpha Testers
  • 993 posts
  • Local time: 05:13 AM

Posted 22 September 2014 - 04:14 PM

theBadfish, we haven't tested chromecast in a while. Sorry to hear that you are having issues. First step will be to reproduce the issue and PM me the server logs (Please send me the complete log).

 

Also another thing to note here is that, iPad does not stream to chromecast but rather hands off the video URL to chromecast and chromecast plays from the server. 



#4 darwindeeds OFFLINE  

darwindeeds

    Advanced Member

  • Alpha Testers
  • 993 posts
  • Local time: 05:13 AM

Posted 22 September 2014 - 04:27 PM

@tmb4016, I'm sorry you feel that way about the app. The content refresh, am aware, is annoying and I would ideally love to provide notifications when new contents get added. Unfortunately, we are not there yet. The app caches your media list for faster performance and without the caching the media list loading will be annoyingly long if you have a > 500 items. Now to automatically refresh we can do one of two things, request the server for the list and compare the cache header (the server has not implemented the cache header yet) or periodically request the server for the list in the background and refresh the list. IOS does not true backgrounding but rather suspends the app in the background state, if I try to keep the app alive it will drain your device's battery. Cache header is typically the way to go and until the server implements the feature we would not be able to implement it. In the meantime, we are definitely researching any alternatives that might be possible.

 

As far as how to get the refreshed list, you can pull down to refresh from the server on any list and you will get the updated items. if this does not work for you please let us know.

 

If you have any particular issues with native playback, please let me know and I will be happy to look into.



#5 henr0 OFFLINE  

henr0

    Newbie

  • Members
  • 7 posts
  • Local time: 10:13 AM

Posted 04 November 2014 - 11:54 PM

I have a friend that uses my mediabrowser server over the internet and has tried to do that with her iphone which then tries to stream to her chromecast. It stutters constantly. But if she uses Chrome on her laptop it generally works very well. I notice that when she uses Chrome my server says her chromecast is accepting a transcoded stream and it says "2.0.000" at the top. When using her iphone I do not see the red progress bar i just see a green progress bar and the number is a 1.x.x number (I forget what it is).

Does that mean that her iphone is trying to get a full quality version of the video and not a transcoded one at a bitrate that she can take with her limited bandwidth?

 

Today I found the option to limit her web client bitrate but not sure if that applies to her iphone.

 

Any suggestions, or is this a known issue?

 

PS: MediaCenter rocks! No complaints!



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140284 posts
  • Local time: 05:13 AM

Posted 04 November 2014 - 11:57 PM

The iOS apps are using our v1 chromecast receiver. Android and the web client are using v2 which introduced a long list of improvements, see:

 

http://mediabrowser....-media-browser/

 

we are working on getting ios updated to use the v2 receiver and then the experience will be consistent.


  • henr0 likes this

#7 tgurath OFFLINE  

tgurath

    Newbie

  • Members
  • 4 posts
  • Local time: 03:13 AM

Posted 18 November 2014 - 09:26 PM

I bought a Chromecast in Sept and the Media Browser app for iPad to go with it. In fact, casting to Chromecast is the only reason I bought the app. Casting from the iPad has never worked for me. I get Media Browser's ready to cast screen. Then any content I select to play just gives me the spinning blue circle. I can cast the same content from the Media Browser web client in Chrome on Windows just fine. I can cast from Netflix on the iPad just fine. I can play content in the app on the iPad just fine. I'd love to see this fixed so I can get rid of the laptop connected to that TV.



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140284 posts
  • Local time: 05:13 AM

Posted 18 November 2014 - 09:27 PM

I bought a Chromecast in Sept and the Media Browser app for iPad to go with it. In fact, casting to Chromecast is the only reason I bought the app. Casting from the iPad has never worked for me. I get Media Browser's ready to cast screen. Then any content I select to play just gives me the spinning blue circle. I can cast the same content from the Media Browser web client in Chrome on Windows just fine. I can cast from Netflix on the iPad just fine. I can play content in the app on the iPad just fine. I'd love to see this fixed so I can get rid of the laptop connected to that TV.

 

It should work. Please see:

 

http://mediabrowser....port-a-problem/







Also tagged with one or more of these keywords: iOS, iPad, Chromecast

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users