Jump to content

Unable to passthrough audio


wrick17
 Share

Recommended Posts

wrick17

My setup:

LG C9 with Chromecast with Google TV + Phillips Soundbar with Dolby Atmos.

Both Chromecast and TV are set up to passthrough audio and it works perfectly with all other apps like Netflix, VLC and Apple TV.

 But Emby plays only PCM audio. I have tried this with a lot of movies that play Dolby audio on VLC. But the same movies play PCM audio in Emby. Any idea how to fix this?

Attaching details of one such file.

8FC77590-2612-40D1-B0AC-187E962842B1.jpeg

Link to comment
Share on other sites

Hi.  That item doesn't have Dolby audio.  It is AAC, which will show as PCM on the speaker.

Link to comment
Share on other sites

wrick17

Fair enough, I've tried with other files as well, like the one attached. Same result.

 

if i play this using VLC, it shows Dolby.

8ADE69CB-11FF-48A2-9D27-9E5BCF344A92.png

Edited by wrick17
Link to comment
Share on other sites

Does your soundbar support TrueHD?  Many don't.

Can we please look at logs from a specific example?

 

Link to comment
Share on other sites

wrick17

 

6 minutes ago, ebr said:

Does your soundbar support TrueHD?  Many don't.

Can we please look at logs from a specific example?

 

I just sent logs from my Android TV Emby app. How do I get it here? 
 

and yes it does support TrueHD. I'm sure. Works just fine with VLC and MxPlayer Pro.

Edited by wrick17
Link to comment
Share on other sites

wrick17

I tried the same file with the 5.1 dolby audio track. Emby even shows the it as Dolby codex in the stats panel. But outputs PCM audio.

Link to comment
Share on other sites

Exactly how is everything setup and what audio option is selected in the Android settings?

The device chain is not reporting support for anything.

Link to comment
Share on other sites

wrick17
16 minutes ago, ebr said:

Exactly how is everything setup and what audio option is selected in the Android settings?

The device chain is not reporting support for anything.

Both Chromecast and TV is set to passthrough audio to soundbar. It's working on VLC. Attached a screenshot.

1CC081A0-8C2F-4554-A7BC-F36155B6C3E8.png

BD211A96-5F59-4094-B7F1-07CA2B136F0F.png

5239BF08-08BF-4E8F-BD3E-453E405084D2.png

Edited by wrick17
Link to comment
Share on other sites

Exactly how is everything connected together?  In order to get the best sound, you probably will need to connect the Chromecast to the sound bar and then the sound bar to the ARC input on the TV but, you may be able to get the TV to pass the audio properly if you can get the Android settings correct.

Exactly what settings are available in the Android menu and have you tried other options there?

Link to comment
Share on other sites

wrick17
Just now, ebr said:

Exactly how is everything connected together?  In order to get the best sound, you probably will need to connect the Chromecast to the sound bar and then the sound bar to the ARC input on the TV but, you may be able to get the TV to pass the audio properly if you can get the Android settings correct.

Exactly what settings are available in the Android menu and have you tried other options there?

My Chromecast is connected directly to the TV via HDMI. And the soundbar is on the eARC port. I have other sources going to the TV so, the ARC feature is kinda important to me.

Link to comment
Share on other sites

wrick17

There are no other options on the android side. My TV gives me the option to run either passthrough or pcm audio. So i selected passthrough.

Link to comment
Share on other sites

5 hours ago, wrick17 said:

There are no other options on the android side

Are you sure?  The Android menus usually have several options.

Link to comment
Share on other sites

wrick17
9 minutes ago, ebr said:

Are you sure?  The Android menus usually have several options.

Not Chromecast I'm afraid, I've dug as deep as possible. There's just that.

Link to comment
Share on other sites

wrick17
16 hours ago, ebr said:

And your sound bar only has a single HDMI input?

No it has 2 inputs, but i've had some display issues with HDMI passthrough before. I'll try it again and let you know.

Link to comment
Share on other sites

wrick17

@ebr So good news. Got it to work. My LG TV had a hidden setting which was converting it to PCM instead of keeping it Bitstream. Now videos plays in Dolby properly.

Now how do I get "Convert Unsupported to Dolby Digital" working? I've turned that on, and turned off TrueHD passthrough (my soundbar doesn't support it via ARC). But still my AAC, AC3 and TrueHD tracks play PCM Audio. They don't get converted to DD.

Is there something else I need to turn on?

Edited by wrick17
Link to comment
Share on other sites

5 hours ago, wrick17 said:

Now how do I get "Convert Unsupported to Dolby Digital" working? I've turned that on, and turned off TrueHD passthrough (my soundbar doesn't support it via ARC). But still my AAC, AC3 and TrueHD tracks play PCM Audio. They don't get converted to DD.

Hi.  We need to look at specifics of that situation.  Start by sending an app log after playing one of these for just a few seconds.

Link to comment
Share on other sites

wrick17
3 minutes ago, ebr said:

Hi.  We need to look at specifics of that situation.  Start by sending an app log after playing one of these for just a few seconds.

Done. The file name should be Free.Guy.2021.1080p.BluRay.x264.AAC5.1-[YTS.MX]. It has a AAC 5.1 audio, and it's playing in PCM stereo.

Link to comment
Share on other sites

1 minute ago, wrick17 said:

It has a AAC 5.1 audio

Haven't looked at your log yet but the answer is in your image above.  It indicates that you turned on support for AAC on the device.  Therefore, AAC is not "unsupported" audio and will not be converted.

If you switch that off in the device menus, does it do what you want?

Link to comment
Share on other sites

wrick17
Just now, ebr said:

Haven't looked at your log yet but the answer is in your image above.  It indicates that you turned on support for AAC on the device.  Therefore, AAC is not "unsupported" audio and will not be converted.

If you switch that off in the device menus, does it do what you want?

No no I have already turned AAC off. Now it's the following. AAC is disabled, but still playing in PCM.

image.jpg

Link to comment
Share on other sites

Yeah, but unfortunately, AAC is so universal that it is still supported and it also supports an input of 5.1 AAC even though it will only output stereo.  We are not mixing it down, the TV is.

EventLogger:       [X] Track:0, id=2, mimeType=audio/mp4a-latm, codecs=mp4a.40.2, channels=6, sample_rate=48000, language=und, supported=YES

 

Link to comment
Share on other sites

wrick17
6 minutes ago, ebr said:

Yeah, but unfortunately, AAC is so universal that it is still supported and it also supports an input of 5.1 AAC even though it will only output stereo.  We are not mixing it down, the TV is.


EventLogger:       [X] Track:0, id=2, mimeType=audio/mp4a-latm, codecs=mp4a.40.2, channels=6, sample_rate=48000, language=und, supported=YES

 

Okay, I tried the same for another File which has TrueHD 7.1 audio. It's not on my supported audio list. And I've also disabled TrueHD passthrough in the Emby app. That's playing in PCM too. I've sent logs. The filename should be Iron.Man.2008.INTERNAL.REMASTERED.2160p.UHD.BluRay.X265-IAMABLE

Link to comment
Share on other sites

wrick17

I've sent logs again for the same file. AC3 5.1 is playing Dolby audio, but TrueHD is playing in PCM.

Link to comment
Share on other sites

Your device is reporting support for both TrueHD and DTSHD so we are letting them pass.  The TV must be accepting them and mixing them down.

Link to comment
Share on other sites

wrick17
18 minutes ago, ebr said:

Your device is reporting support for both TrueHD and DTSHD so we are letting them pass.  The TV must be accepting them and mixing them down.

I've tried everything. Can't seem to get around it. Any suggestions? Any chance we can get on a call and discuss this? I have a few settings that work and some end up the video not playing and coming back to the info screen. It'll be easier to explain on a call.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...