Jump to content

Synology DS918+ DSM7 installation impossible


BaiytaOne

Recommended Posts

BaiytaOne

Bonjour, 

J'avais déjà écris dans un autre post mais je le reprends ici car j'ai peur que mon message ne ce soit perdu dans le post qui traitait déjà d'autres problèmes due à la migration.

Pour refaire le point : 

J'avais Emby (serveur) sur DSM 6.2 qui fonctionnait parfaitement. Je n'ai pas vu les différents post sur le sujet avant de migrer mon DSM ; pour être honnête, j'ai beaucoup de choses qui tournent sur mon Nas et Emby n'était pas ma préoccupation principale à ce moment.

J'ai donc fait la migration vers DSM7 avant de constater qu'Emby ne fonctionnait plus. 

J'ai alors désinstallé l'app et tenté d'installer manuellement la version pour DSM7.

J'ai tenté l'installation manuelle la version 4.6.4.0 mais également toute les versions beta jusqu'à la 4.7.0.12. ce matin et rien à faire le message est toujours le même :
image.png.78fffbc98c880dfb82eb73b57a0967dc.png

 

J'étais heureux de voir hier qu'Emby était enfin dispo dans les sources tiers du centre de paquet officiel de Syno (félicitation d'ailleurs pour ça !) et pensais que cela allait enfin fonctionner, sauf que là non plus ça ne marche pas :
image.png.d74fddd7f7897375f5635f133e447113.png

image.png.fb73a5afcf963b52010f707be394e7dd.png

 

Comme je l'ai dit, j'ai vraiment pas mal de choses qui tournent sur le Nas, j'aimerais vraiment éviter de le réinitialiser "juste" pour Emby.
Surtout que je n'ai aucun autre problème (même avec d'autres app "non officielle").

Pouvez-vous m'aider svp ?

 

Link to post
Share on other sites
cayars

Hi, If you still have the DSM 6 folders for Emby which by default are located at /volume1/Emby then you should try the migration instructions located here:

You would just start with the steps after the upgrade to DSM 7.

Regardless if you do the migration or not you will want to pay attention to the instructions for permissions using the system internal emby user which is different than under DSM 6.

Link to post
Share on other sites
BaiytaOne

Salut, 

J'ai abandonné l'idée de la migration d'Emby il y a quelques temps ; après avoir désinstallé l'app via l'interface du Synology, j'ai fait des recherches via SSH sur le mot "emby" et j'ai supprimé tout ce qu'il a trouvé, je n'ai plus rien de Emby sur le Nas actuellement.

C'est pour cela que je ne comprends pas pourquoi je ne peux pas l'installer.

Je veux juste faire une nouvelle installation.

Pour les permissions, l'utilisateur Emby n'existe pas (ou pas encore), je suppose qu'il va être créé à l'installation de l'app mais ça ne marche pas.

image.png.77c9ec0080b87c708cf26b04d6ac2d3e.png

 

 

Edited by BaiytaOne
Link to post
Share on other sites
cayars

The migration does go smooth if you follow the directions step by step.  But this isn't an option for you at this point.

You might have corrupted things up removing anything with "emby" in it via SSH.

I would try logging in SSH and going root with sudo -i

Then see if /volume1/@appdata/Emby Server exists and if so remove it.
Then try reinstalling Emby again from the package center.

If that doesn't work I would contact Synology support for help as you may need to make changes to modify the system volume where apps are installed due to the removal of anything "emby" related.

Link to post
Share on other sites
BaiytaOne

ça ne fonctionne pas, j'ai donc ouvert un ticket d'assistance chez Synology, je vous ferais un retour dès que j'en sais plus.

Link to post
Share on other sites
cayars

Let us know how this goes.  If they are not able to help, maybe we can do a remote support session and can try and see if we can assist you.

But for now, it's best to give Synology a chance to fix you up or give you ideas to try.

I'm more than willing to help in any way I can. In a case like this we'd discuss any potential changes in chat and then let you make the changes.  This way nothing is done without your knowledge and blessing as you would make the changes.

If you don't mind me asking what other primary server apps are you running on your Synology?

Link to post
Share on other sites
BaiytaOne

apps serveur : synology drive server, webdav server et apache http server

d'autres apps qui peuvent peut-être interférer : Audio station, Video station, Synology photos, Surveillance station, Antivirus Essential, mariaDB 10, Home assistant Core.

J'utilise Docker mais je n'y ai pas de serveur.

J'ai aussi un service de Backup à distance qui tourne via Hyper Backup

Link to post
Share on other sites
cayars

I'm pretty sure as you already mentioned the issue is the Docker install.

Have you heard anything back from Synology yet?

Link to post
Share on other sites
BaiytaOne

Pas encore de retour de Synology.

Je vais faire des backup de mes container et le désinstaller pour tester, si le problème vient de là, je trouverais des alternatives à Docker.

Je vous fais un retour dès que j'ai fait le test.

Link to post
Share on other sites
BaiytaOne

J'ai supprimé tous les container et désinstallé docker et évidemment reboot le nas.

Malheureusement, l'installation d'emby ne fonctionne toujours pas, ni en installation "automatique", ni la version Beta manuellement.

Toujours pas de retour de Synology.

Link to post
Share on other sites
BaiytaOne

les même erreurs : 

via centre de paquets : 

image.png.04cdfc200453b93e0b28ddee27f00dc5.png

installation manuelle (4.7.0.12) : 

image.png.03f1bcb5c86fb4aae9c5eb346e253682.png

en fouillant un peu plus dans les log, j'ai trouvé ceci :

dans le /var/log/synoscgi.log :

Quote

2021-09-21T17:19:40+02:00 Nas synoscgi_SYNO.Core.Package.Server_2_list[7125]: pkgcurltool.cpp:283 Failed to curl perform, code=7, err=Error
2021-09-21T17:19:40+02:00 Nas synoscgi_SYNO.Core.Package.Server_2_list[7125]: pkgcurltool.cpp:473 Failed to download https://synology.emby.media/, code=7, err=Error
2021-09-21T17:19:40+02:00 Nas synoscgi_SYNO.Core.Package.Server_2_list[7125]: pkgcurltool.cpp:283 Failed to curl perform, code=7, err=Error
2021-09-21T17:19:40+02:00 Nas synoscgi_SYNO.Core.Package.Server_2_list[7125]: pkgcurltool.cpp:473 Failed to download https://synology.emby.media/, code=7, err=Error
2021-09-21T17:21:04+02:00 Nas synoscgi_SYNO.Core.Package.Installation_1_upload[13915]: pkgverify.cpp:297 Failed to verify package, spk=[/volume1/@tmp/upload_tmp.139150] result=[{"action":"prepare","beta":true,"betaIncoming":true,"error":{"code":289,"description":"spk is not from synology"},"installReboot":false,"package":"EmbyServer","packageName":"Emby Server","stage":"prepare","success":false}]
2021-09-21T17:21:04+02:00 Nas synoscgi_SYNO.Core.Package.Installation_1_upload[13915]: privilege_api.cpp:544 User emby is reservered for system
2021-09-21T17:21:04+02:00 Nas synoscgi_SYNO.Core.Package.Installation_1_upload[13915]: pkgtool.cpp:1370 Failed to revise files before running wizard, pkg=[EmbyServer]
2021-09-21T17:21:04+02:00 Nas synoscgi_SYNO.Core.Package.Installation_1_upload[13915]: pkgtool.cpp:1384 Failed to load wizard, pkg=[EmbyServer]

il y a apparemment un problème avec le nom du user system "privilege_api.cpp:544 User emby is reservered for system".

On dirait qu'il veut créer cet utilisateur mais que le nom est dééjà réservé par le syno ; pourtant il n'existe pas

image.png.2356c06061a05d4cc71c32ce62c894bc.png

Par contre, je ne sais pas où je peux trouver cette liste d'user réservé au système pour l'en supprimer.

 

 

image.png

Link to post
Share on other sites
BaiytaOne

voici la réponse de Synology : 

Quote

Bonjour,

Merci d'avoir contacté le support Synology

Cette application n'étant pas développée par Synology, nous n'assurons malheureusement pas son support..

Je vous invite donc à directement contacter les développeurs de l'application.

Cordialement,

Christophe

Technical Support

 

Je vais tenter de faire le forcing pour qu'il regarde au moins à ce problème d'utilisateur système, on verra...

Link to post
Share on other sites
BaiytaOne

Pour l'installation manuelle, je l'ai déjà fait

image.png.dfa6353155d60225ea31ec25abf3f965.png

 

voici le message :

image.png.82eff0da56d9f2e91f1ddd5f90311dab.png 

dans le /var/log/synoscgi.log :

Quote

2021-09-22T20:56:44+02:00 Nas synoscgi_SYNO.Core.Package.Installation_1_upload[23603]: pkgverify.cpp:297 Failed to verify package, spk=[/volume1/@tmp/upload_tmp.236030] result=[{"action":"prepare","beta":false,"betaIncoming":false,"error":{"code":289,"description":"spk is not from synology"},"installReboot":false,"package":"EmbyServer","packageName":"Emby Server","stage":"prepare","success":false}]
2021-09-22T20:56:45+02:00 Nas synoscgi_SYNO.Core.Package.Installation_1_upload[23603]: privilege_api.cpp:544 User emby is reservered for system
2021-09-22T20:56:45+02:00 Nas synoscgi_SYNO.Core.Package.Installation_1_upload[23603]: pkgtool.cpp:1370 Failed to revise files before running wizard, pkg=[EmbyServer]
2021-09-22T20:56:45+02:00 Nas synoscgi_SYNO.Core.Package.Installation_1_upload[23603]: pkgtool.cpp:1384 Failed to load wizard, pkg=[EmbyServer]
2021-09-22T20:56:55+02:00 Nas synoscgi_SYNO.Core.Package.Installation_1_upload[23753]: pkgverify.cpp:297 Failed to verify package, spk=[/volume1/@tmp/upload_tmp.237530] result=[{"action":"prepare","beta":false,"betaIncoming":false,"error":{"code":289,"description":"spk is not from synology"},"installReboot":false,"package":"EmbyServer","packageName":"Emby Server","stage":"prepare","success":false}]
 

 

Link to post
Share on other sites
BaiytaOne

 

et avec l'installation automatique : 

image.png

 

image.png.a25531762d84f4c02beca66947f874e9.png

Quote

2021-09-22T21:05:15+02:00 Nas synoscgi_SYNO.Core.Package.Installation_1_install[1199]: privilege_api.cpp:544 User emby is reservered for system
2021-09-22T21:05:15+02:00 Nas synoscgi_SYNO.Core.Package.Installation_1_install[1199]: pkginstall.cpp:1069 Failed to extract and verify package, spk=[/volume1/@tmp/@synopkg/@download/EmbyServer/@SYNOPKG_DOWNLOAD_EmbyServer] result=[{"action":"install","beta":false,"betaIncoming":false,"error":{"code":313,"description":"failed to revise file attributes"},"installReboot":false,"installing":true,"language":"fre","last_stage":"prepare_install","package":"EmbyServer","packageName":"Emby Server","spk":"/volume1/@tmp/@synopkg/@download/EmbyServer/@SYNOPKG_DOWNLOAD_EmbyServer","stage":"install_failed","success":false,"username":"Lionel"}]

 

 

 

 

 

 

Edited by BaiytaOne
Link to post
Share on other sites
cayars

If you like we can do a remote session with you and help you try to resolve this.
Send me a PM if you want to setup a remote session.

Link to post
Share on other sites
BaiytaOne

Synology ne fera rien  😕 

Quote

je comprends votre déception, mais comme indiqué dans notre précédent message nous n'apportons aucun support sur les paquets tiers.

 

Link to post
Share on other sites
BaiytaOne

Thanks but Cayars is already helping me.

We watched together with remote session yesterday.

We don't find out where the problem is coming from.

He will do more research but we think I'll have to do a fresh install of DSM7.

I don't have time to do this now, maybe in 2-3 weeks. I'll let you know.

If anyone has any idea by then ...

the log error (/var/log/synoscgi.log ) is always the same:

Quote

2021-09-22T21:05:15+02:00 Nas synoscgi_SYNO.Core.Package.Installation_1_install[1199]: privilege_api.cpp:544 User emby is reservered for system
2021-09-22T21:05:15+02:00 Nas synoscgi_SYNO.Core.Package.Installation_1_install[1199]: pkginstall.cpp:1069 Failed to extract and verify package, spk=[/volume1/@tmp/@synopkg/@download/EmbyServer/@SYNOPKG_DOWNLOAD_EmbyServer] result=[{"action":"install","beta":false,"betaIncoming":false,"error":{"code":313,"description":"failed to revise file attributes"},"installReboot":false,"installing":true,"language":"fre","last_stage":"prepare_install","package":"EmbyServer","packageName":"Emby Server","spk":"/volume1/@tmp/@synopkg/@download/EmbyServer/@SYNOPKG_DOWNLOAD_EmbyServer","stage":"install_failed","success":false,"username":"Luser"}]

 

Link to post
Share on other sites
Luke

That says error code 313 failed to revise file attributes. I can't find anything when googling that but you'd think Synology support would be willing to describe that error message.

Maybe tell them you're trying to install one of they're own apps and then they'll help you.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...