Jump to content

Recommended Posts

nickysilver

Ok, i've posted a lot over the last few days as I set up emby for the first time. (migrating from Plex)

Today's question:

I'm running the server on Nvidia Shield. I'm managing the server on my mac laptop. The media, about 2500 movies is located on a hard drive plugged into the shield. Now, as i set up this main library, I am editing ALL the metadata. I manually enter a "critic rating" then sort by critic rating, thus i get the 2500 movies in order from what I think are masterpieces to what I think are, well, odd junk that i sorta like. As I do this on the mac, shouldn't what I see on the shield match it exactly? It doesn't.

Foe instance, the very first three movies on the mac are , in this order,  The Apartment, All About Eve, 2001: A Space Odessy. On the shield they appear in this order: The Apartment, 2001:A Space Odessy, All about Eve. (I realize this is sort of labor intensive and, well, a little nuts, but there you are.) Shouldn't they match? I'm only managing the server on the mac, after all. (All three of those movies are rated "10" btw.)

Also, in both locations, if I have 30 movies all with the critic rating 7.5, they appear together, as one would expect, but in REVERSE alphabetical order (from Z to A), This seems very odd to me. Not as problematic as the first issue, but very strange.

 

Thoughts? Help?

ten thousand thank yous!!

Link to post
Share on other sites
cayars

Do you have two ratings for some movies?

You may have rotten tomato ratings as well.

Link to post
Share on other sites
nickysilver

There was a "community rating," which i've now deleted (who is this community?), but it didn't resolve the discrepancy. (baffling, huh?)

Link to post
Share on other sites
nickysilver

The alternative, which i used to in plex, is change every movies "sort name," adding a number to the front-- but I wish I'd realized the problem before I'd excited about 700 movies. (Of course, I don't know yet if they will match exactly using that method either.) Just baffled as to why they wouldn't match.

Link to post
Share on other sites
nickysilver

I don't understand... The emby server on the shield, which I manage on the mac. The emby player on the shield. (Editing the "sort title appears to work. They match. Back to square one. 20 of 2500 done.... sigh.)

Link to post
Share on other sites
GrimReaper
1 hour ago, nickysilver said:

Also, in both locations, if I have 30 movies all with the critic rating 7.5, they appear together, as one would expect, but in REVERSE alphabetical order (from Z to A), This seems very odd to me. Not as problematic as the first issue, but very strange.

Actually, IMHO that makes perfect sense, if you sorted by ratings ascending, they would be sorted alphabetically, but since you reversed order - they are shown descending, as well. Can't have them alphabetical in both orders. 

Edit: It doesn't change the fact that you should have them presented in same order if same sort method used, regardless of client. 

Edit2: Just to confirm that same can be observed on Win server, different presentation on sort by Critic rating between Web app and AndroidTV app. Android app seem to generally follow Web app sorting, which looks like reverse alphabetical on same rating. AndroidTV app is a bit mish-mash, no discernible pattern between same-rated items: sometimes it's reverse alphabetical, sometimes it ain't, but random. 

Edited by GrimReaper
Append
Link to post
Share on other sites
8 hours ago, GrimReaper said:

AndroidTV app is a bit mish-mash, no discernible pattern between same-rated items: sometimes it's reverse alphabetical, sometimes it ain't, but random. 

It probably just needs a secondary sort which isn't there.  Thanks.

  • Like 1
Link to post
Share on other sites
nickysilver

Well, I've started over.... using the system I used to use in plex, which is to edit the sort title. (To be fair, this method gives me the most flexibility/specificity as I can do things like 9a and 9a1.) I was hoping to avoid this method as it's more labor intensive. (As it happens I'm a covid isolation till Monday, so what the hell.) 

 

Thank you all for your help/advice!

Link to post
Share on other sites
Luke
6 hours ago, nickysilver said:

Well, I've started over.... using the system I used to use in plex, which is to edit the sort title. (To be fair, this method gives me the most flexibility/specificity as I can do things like 9a and 9a1.) I was hoping to avoid this method as it's more labor intensive. (As it happens I'm a covid isolation till Monday, so what the hell.) 

 

Thank you all for your help/advice!

Won't that have adverse effects when sorting by title?

Link to post
Share on other sites
nickysilver

It does. But  that's the trade off. It doesn't bother me. With 2500 movies, I'd rather have the in order of preference. 

What I DO want to figure out, when I'm done (I've done about half so far) is how to back up the metadata, so I don't ever have to do it again. I read that emby makes this relatively easy,

Edited by nickysilver
Link to post
Share on other sites
GrimReaper
4 minutes ago, nickysilver said:

What I DO want to figure out, when I'm done (I've done about half so far) is how to back up the metadata, so I don't ever have to do it again.

You should've done that to begin with, enable NFO saver in your library settings, as it is saved/updated upon any metadata change (either manual Edit/Save or Refresh Metadata). 

Link to post
Share on other sites
cayars
Just now, nickysilver said:

done.... thanks!

If you just turned on NFO writing this won't help with your existing files until the meta-data changes triggering a write of the NFO. That's why it's a good thing to turn this on before you start scanning files into the library.

Link to post
Share on other sites
nickysilver

Scanning them now won't save the meta data?

(I must seem like an idiot)

 

Edited by nickysilver
Link to post
Share on other sites
cayars

New media or a refresh or edit of the meta-data will create the NFO but existing media without a change won't get the NFO written.

Link to post
Share on other sites
Luke
3 hours ago, cayars said:

New media or a refresh or edit of the meta-data will create the NFO but existing media without a change won't get the NFO written.

Correct. This is explained the help text at the top of the library options dialog box.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...