Jump to content

 M1


MyTheater

Recommended Posts

MyTheater

@voodoomurphy i don't know but my macstudio fully dedicated to Migrate my emby on it. So I'm really waiting @Lukeand staff News about full native apple silicon version. I hope so in few days / week but sooooooon. Really frustrating to wait for my new server 🥹🥹🥹

Link to comment
Share on other sites

  • 2 weeks later...
AdamMobile

@Luke any update? I had a major hardware fail and am currently using a non m1 Mac mini and really love the stability of Mac so I’m holding off but am about to purchase a m1 mini and would really love native support

  • Like 1
Link to comment
Share on other sites

BBQThunder
On 8/19/2022 at 2:56 PM, Felipe Baez said:

I already moved 100% to Plex and it’s now a breeze.

But now you have to deal with spyware and DRM plugins, add that to recent Plex hack...I'll stay on Emby.  I had Plex before and switched to Emby...overall a much better platform.

Link to comment
Share on other sites

  • 3 weeks later...
neptunepic

I basically gave up on waiting for a native M1 server. If it ever happens, great. But the current server works fine on M1 and I’d rather be pleasantly surprised when it arrives rather than frustrated every month that passes without it. 
 

PS, a Mac Studio is total overkill for running a home media server. Save your money!

Link to comment
Share on other sites

MyTheater
On 9/30/2022 at 7:44 PM, neptunepic said:

I basically gave up on waiting for a native M1 server. If it ever happens, great. But the current server works fine on M1 and I’d rather be pleasantly surprised when it arrives rather than frustrated every month that passes without it. 
 

PS, a Mac Studio is total overkill for running a home media server. Save your money!

Already buy and dedicated 😅 

Link to comment
Share on other sites

  • 3 weeks later...

I did not read this entire topic yet, but I just installed Emby to my M1 Mini running Monterey 12.6 and it went fine.  I added my Premier account as I am trying to switch everything from a Windows 10 computer to my M1 Mini now.

I am not sure the easiest way or if my external that works with the windows Emby will easily work with the Mac Emby.  I guess I will find out soon,, might not have time today though.

Link to comment
Share on other sites

A quick update.  I moved a 2Tb SSD from my Windows computer to my M1 Mini to start with.  Everything went fine, I only made 2 sections, photos and videos and just lumped everything into them for now.  I need to tweak some settings and move some folders, but so far it is going faster and better than I thought as sometimes moving from Win to Mac is not simple.

This is my M1 Mini 16gB Memory activity when playing a video thru Emby.

image.png.6bdce3e81acf54add24cefda09a8224d.png

 

This is the CPU:

image.png.74f1b96c521b5b06293840b405085695.png

  • Thanks 1
Link to comment
Share on other sites

For those anxious to try this out, here is a native M1 build of latest beta server (4.8.0.13):

https://github.com/MediaBrowser/Emby.Releases/releases/download/4.8.0.13/embyserver-osx-arm64-4.8.0.13.zip

Please note that unlike the x64 build, there's no tray icon yet. I still need to build that for the M1 architecture, but everything else is there and it's enough for you to try it out.

We'll be issuing a 4.7.9 maintenance stable release and we'll have that for M1 assuming this goes well.

  • Like 2
  • Haha 1
  • Thanks 2
Link to comment
Share on other sites

Installed last night and so far it’s working great! Thanks for doing the latest beta as well!  Today I’m going to put through end to end tests along with the new ATV app. 🙂

  • Thanks 1
Link to comment
Share on other sites

Install went smooth and it went over the old Emby and everything seems much faster.  I did not do a lot of streaming to my AppleTV 4k devices or other devices of course as its has only been overnight.

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

So far everything is working great! Performance seems to be stellar and smooth. I do have one issue with hardware transcoding that might just be a settings thing… seems as though I can’t use hw transcoding at all. I have it enabled and still get ffmpeg consuming the entire 8 cores. Any ideas on what might be set incorrectly?

A57B908A-C2CA-4810-AF3B-14AABE7820E7.png

4933DDFD-3EDC-4F55-8666-44DA2F0AB63D.png

C5F68403-8FF3-4580-859B-E68BF57AC1C7.png

DEF1EA01-1189-4C6B-BE77-FC535DDF43AD.png

Edited by ellisd4
Chang he transcoding to hw
Link to comment
Share on other sites

I removed my comment as trying to see what is going on with the version numbers.

Edited by rkkeller
Link to comment
Share on other sites

chirenguaiguai
On 10/24/2022 at 5:43 PM, Luke said:

For those anxious to try this out, here is a native M1 build of latest beta server (4.8.0.13):

https://github.com/MediaBrowser/Emby.Releases/releases/download/4.8.0.13/embyserver-osx-arm64-4.8.0.13.zip

Please note that unlike the x64 build, there's no tray icon yet. I still need to build that for the M1 architecture, but everything else is there and it's enough for you to try it out.

We'll be issuing a 4.7.9 maintenance stable release and we'll have that for M1 assuming this goes well.

Thank you! This is what we need! It runs like a breeeeeze

Link to comment
Share on other sites

UPDATE to below:  It was user error.  I guess not seeing an icon at the top right corner, made me think it closed when safari closed.  It does

work fine after closing safari, I guess I needed to reboot.



I upgraded to Ventura 13 and now I can't get Emby to stay on without leaving Safari open.  When I close Safari and click Emby, it always says "not responding".

I don't know if it is something "I" messed up as I am not a huge techie, but going to restart a few times and see if it fixes it.

Edited by rkkeller
Link to comment
Share on other sites

16 hours ago, ellisd4 said:

So far everything is working great! Performance seems to be stellar and smooth. I do have one issue with hardware transcoding that might just be a settings thing… seems as though I can’t use hw transcoding at all. I have it enabled and still get ffmpeg consuming the entire 8 cores. Any ideas on what might be set incorrectly?

A57B908A-C2CA-4810-AF3B-14AABE7820E7.png

4933DDFD-3EDC-4F55-8666-44DA2F0AB63D.png

C5F68403-8FF3-4580-859B-E68BF57AC1C7.png

DEF1EA01-1189-4C6B-BE77-FC535DDF43AD.png


I found it and looking, but mine was set on the default not advanced.  What did "you" add on the M1 as I dont have anything under those sections.

Screenshot 2022-10-26 at 9.43.02 AM.png

Edited by rkkeller
Link to comment
Share on other sites

36 minutes ago, rkkeller said:


I found it and looking, but mine was set on the default not advanced.  What did "you" add on the M1 as I dont have anything under those sections.

Screenshot 2022-10-26 at 9.43.02 AM.png

I have the Emby Diagnostics plugin installed.  I see VideoToolbox H.264 is available, so that should mean it's supported on Mac, but maybe not.  HW transcoding never worked on my intel machine either, so it could be that Mac just isn't supported for HW transcoding.  @LukeIs that the case?  I would say the significant improvement with the M1 architecture update is that before with the Roseta version, high bitrate transcoding would stutter... with the M1 release I do not get stuttering, but do see all 8 cores maxed out on my m1 mini.  Thanks!

  • Like 1
Link to comment
Share on other sites

1 hour ago, rkkeller said:

I also found this, not supported I think.  This is a little old though:

https://support.emby.media/support/solutions/articles/44001160148-hardware-acceleration-overview

It could be that Emby on Mac just doesn't support HW transcoding.  That honestly doesn't surprise me since Apple has closed their architecture down even further.  I would say that the Video toolbox encoders/decoders are available, so they should be able to be used... maybe just not efficiently.

Edited by ellisd4
Added clarification: Emby on Mac.
Link to comment
Share on other sites

Felipe Baez

Just to be clear here with information that's a fact and not speculation. Apple does NOT limit the usage of hardware encoder and decoder on Macs and is up to developers to use them or not. There's no limitation on the Apple framework for hardware encoding and decoding.

Furthermore, with the latest update of Ventura, applications like FCP are now seeing a 3x to 4x increase in encoding speed.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...