Jump to content

XBMB3C transcoding some files encoded by Handbrake


arztonyou
 Share

Go to solution Solved by arztonyou,

Recommended Posts

arztonyou

First off, thank you to everyone who has worked on the XBMB3C plug-in and the assorted skins.  I've been following the project since the beginning and am currently using the plug-in on two Windows 7 machines and an Android phone with the Confluence MB skin.  I've been very happy with this setup and impressed with how quickly the project has progressed.

 

I know that you just recently added support for transcoding.  I was wondering exactly what is checked to determine if transcoding is necessary.  I've edited some recorded TV episodes using VideoRedo to cut out commercials and then used Handbrake to convert from mpeg2 to h.264 in an mkv container to save space and for better playback using a Chromecast (with the Android MB app or Plex app) on bedroom TVs.  

 

But I've noticed that the XBMB3C clients on my Windows 7 machines use transcoding to play some of the episodes.  Episodes that were recorded as 720p mpeg2 video with AC-3 audio and converted to 720p h.264 video with AAC audio play just fine.  However, episodes that were recorded at 1080i mpeg2 video with AC-3 audio and converted to 720p h.264 video with AC-3 and AAC audio tracks are forced to use transcoding.  These same files play just fine on the same machines using WMC MBC with MPC-HC as an external player.

 

I'm no Handbrake expert, so I might be causing the transcoding with my choice of settings.  But really the only difference between the settings for the different types of episodes is that I reduce the 1080i files to 1280 x 720 and use Bob for deinterlacing.  

 

 

I also noticed that you've added "Transcoding" or "Direct Play" to the episode name, but sometimes an episode plays without either of these being added to the name.  What does that mean?

 

 

Thanks.

Link to comment
Share on other sites

xnappo

It definitely should not be transcoding if you are expecting it to play directly for a Windows/SMB share.  

 

Previously to this version were you using the 'Play from stream' option?  If not - then somehow the detection that you are trying to play from a share is trigger it to fall through to the transcoding checks.

 

Can you please go to advanced setting and change the log level to '2' and play one of the files that is transcoding?

 

xnappo

Link to comment
Share on other sites

  • Solution
arztonyou

sigh....nevermind about the transcoding...user error   

 

I had a local path instead of a share for one media folder.  Can't believe I did that after all the times I've seen new users come to this site with that problem.  At least those files are no longer transcoded.

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...