Jump to content

502 Gateway Error-Embycon


sm07
 Share

Recommended Posts

sm07

Hi, I'm having a very strange problem where exactly at a certain time I start getting an error when I want to stream on embycon. This happens every night at 12AM and almost always goes away and fixes itself automatically around 1-1:30AM. I'm getting the 502 Bad Gateway error first and after that the error changes to service unavailable.

The weird part is that I can access the server and watch my content on the official Emby app (Android TV) without any error or issue so this is only happening if I want to use embycon. I hope you can figure out what the root cause could be from the log file I've attached. Thank you.

kodi.log

Link to comment
Share on other sites

TeamB

This error message is coming from the nginx reverse proxy server, I dont think it was anything to do with EmbyCon.

Is this your Emby server? Is Emby being shutdown or restarted at the times you are having issues?

Link to comment
Share on other sites

sm07
34 minutes ago, TeamB said:

This error message is coming from the nginx reverse proxy server, I dont think it was anything to do with EmbyCon.

Is this your Emby server? Is Emby being shutdown or restarted at the times you are having issues?

Thanks for your reply.

It's not my emby server I'm sharing with a friend of mine but if it's an error on server end why would it only crash on embycon while still working fine on the Emby app? 

Link to comment
Share on other sites

TeamB

no idea, nginx is responding with those errors, perhaps get you friend to check the nginx logs at the times in question and see if there is anything weird about the requests.

Are you using the exact same URL to access the server with EmbyCon and also the Emby App? Are you using Emby Connect (forum credentials) on the Emby App? Parhaps that is bypassing the nginx reverse proxy in some way and that is way you dont get the nginx error with the Emby App. Or it could be somethign to do with the EmbyCon addon but I dont see any difference in the times it was working vs the times it failed apart from the nginx reverse proxy returning the errors.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...