Jump to content

Recently added vs actual library content


CharleyVarrick
 Share

Go to solution Solved by quickmic,

Recommended Posts

CharleyVarrick

I have noticed an Emby for Kodi (or just Kodi) less than ideal behavior.

When I add either an occasional new movie or daily new tv episodes to Emby, it displays it a minute later on embyweb under "Latest Movie" or Latest TV Show"

When looking at Kodi, it seems to take forever to be displayed on its Recently Added respective areas.

 

This leads me to believe somethings wrong between emby and kodi.

But 99% of the time, If I browse the related library, those recently added movie or episodes are there alright.

For some reason, its not working out so great for Recently Added.

 

If anyone knows about it and maybe experienced it, what's the story (what causes the issue), and more importantly can I do something about it ?

Ignoring it is not viable option for me, as in the past, I sometime found out after a week+ that Kodi stopped updating new content from Emby altogether.

 

When I see Emby and Kodi agreeing on the same Latest / Recently Added, I know in a quick glance that everything is running smoothly under the hood.

 

Edited by CharleyVarrick
Link to comment
Share on other sites

quickmic
2 hours ago, CharleyVarrick said:

When looking at Kodi, it seems to take forever to be displayed on its Recently Added respective areas.

 

 

 

In the plugin option menu? Dynamic or synced content?

Link to comment
Share on other sites

CharleyVarrick
22 minutes ago, quickmic said:

In the plugin option menu? Dynamic or synced content?

Sorry, I can't find such options, can you tell me where to look?

Link to comment
Share on other sites

quickmic
9 minutes ago, CharleyVarrick said:

Sorry, I can't find such options, can you tell me where to look?

Dynamic content has "(dynamic)" as an extension in the library label, or was your question how to select recently added via plugin options menu.

Edited by quickmic
Link to comment
Share on other sites

CharleyVarrick

What do you know !

This morning, Kodi's Recently added matches Emby's Latest ... within minutes (instead of 8-10 hours like before)

I'm a happy camper again 😊

Edited by CharleyVarrick
Link to comment
Share on other sites

CharleyVarrick
On 3/15/2021 at 2:46 PM, quickmic said:

In the plugin option menu? Dynamic or synced content?

When I reinstall kodi in my home office, I thought I had seen this "Dynamic" mention (after all library names) when in emby next gen.

But when you asked about it and I had a peak, Dynamic was not displayed. OK I said, too many Heineken or something...

This morning I did a full reinstall of living room htpc kod and before adding libraries it showed Dynamic, but once all library added, Dynamic suffix again disappear.

Thats not a problem, but a little odd and I dont have a clue why it shows up at first and then vanishes.

 

Does it have to do with native path vs add on mode, as I am on add on mode.

Edited by CharleyVarrick
Link to comment
Share on other sites

CharleyVarrick
On 3/17/2021 at 5:48 AM, CharleyVarrick said:

What do you know !

This morning, Kodi's Recently added matches Emby's Latest ... within minutes (instead of 8-10 hours like before)

I'm a happy camper again 😊

Spoke too quickly, original issue is back, here's a grab of Emby latest Show followed by  Kodi Recently added Show.

9 hours and counting between Emby and Kodi

image.thumb.png.d9adc480dea5fda2d78b9edf40682851.png

image.thumb.png.8926d1688264731e80472fbefd6c9480.png

image.thumb.png.8f2c0ecc4788465866e92c12a2aa9732.png

Edited by CharleyVarrick
Link to comment
Share on other sites

CharleyVarrick

Login issue already fixed.

Weird, 2 minutes ago, I look at kodi and it stills how yesterdays latest tv shows. I exit kodi and reopen it and its up to date in a flash.

???

As if it updated them allright, but did not bother displaying them. I am really confused.

 

Link to comment
Share on other sites

CharleyVarrick
25 minutes ago, quickmic said:

Please try the with 5.2.02. I'm also curious, if it fixes your login issue.

Login issue, I have a nagging feeling I might have tried to install emby next gen straight from zip, without first installing emby kodi repo.

That would not work, if I understand correctly.

As I said, its been a long while since I had to install kodi+ E4K from scratch.

 

Looking at the process as a whole, is not meant for average / below avg user.

If I may, I suggest a video in a pinned thread showing "how to clean install Emby for Kodi"  from start to finish would be great to get more people on the E4K bandwagon and help keep it alive and kicking.

Link to comment
Share on other sites

quickmic
11 hours ago, CharleyVarrick said:

Spoke too quickly, original issue is back, here's a grab of Emby latest Show followed by  Kodi Recently added Show.

9 hours and counting between Emby and Kodi

image.thumb.png.d9adc480dea5fda2d78b9edf40682851.png

image.thumb.png.8926d1688264731e80472fbefd6c9480.png

image.thumb.png.8f2c0ecc4788465866e92c12a2aa9732.png

 

I'll perform some tests, and please send me a log when not synced.

Did you watch an episode of the same TVShow in the same Kodi session (no reboot) which not updating new content?

 

btw You are comparing latest Episodes (Kodi) with latest TV-Shows (Emby). It's not the same.

 

Edited by quickmic
Link to comment
Share on other sites

CharleyVarrick
44 minutes ago, quickmic said:

btw You are comparing latest Episodes (Kodi) with latest TV-Shows (Emby). It's not the same.

The intent is the same but yes, they each proceed with a slight difference.

Should I add only individual new episodes, I expect they show exact same thing.

Since yesterday's  crop included a whole season of Calls (2021), Emby Latest tv show displays only 1 thumb for all new 9 episodes of Calls (2021), 

while Kodi displays all individual episodes thumbs.

After exiting and reopening Kodi, Recently added episodes caught up in a second with Emby's latest

So Emby did not change from my last screen captures, but Kodi did

I have not added new episodes since yesterday, and this is what I got:after restarting Kodi.

Basically,. Kodi does not refresh its display dynamically like Emby, and I believe it never really did so.

image.thumb.png.fc8f6591f87de09d0d2b49ebd7e30fed.png

 

Edited by CharleyVarrick
Link to comment
Share on other sites

quickmic

Please check the kodi.log for the following line:

ERROR <general>: JSONRPC: Failed to parse '{ "jsonrpc": "2.0", "method" : "VideoLibrary.GetTvShows", "params": b'{"properties": [ "file", "title", "year", "imdbnumber", "art", "genre", "cast", "studio", "uniqueid" ] }', "id":1 }'

 

This could be related to the issue. Currently I try to fix it.

Link to comment
Share on other sites

CharleyVarrick
11 minutes ago, quickmic said:

Please check the kodi.log for the following line:



ERROR <general>: JSONRPC: Failed to parse '{ "jsonrpc": "2.0", "method" : "VideoLibrary.GetTvShows", "params": b'{"properties": [ "file", "title", "year", "imdbnumber", "art", "genre", "cast", "studio", "uniqueid" ] }', "id":1 }'

 

This could be related to the issue. Currently I try to fix it.

I used notepad search feature and could not locate that line, but dont trust me on it.

 

I've read somewhere its preferable to pm the log as they contains sensible info,

 

It would be totally AWESOME if you could address this

at the risk of repeating myself, when I see Kodi catching up with Emby, I know at a glance everything is running smoothly

Edited by CharleyVarrick
Link to comment
Share on other sites

CharleyVarrick
1 hour ago, quickmic said:

I'll perform some tests, and please send me a log when not synced.

 

I'll be glad to, but saturday is a slow (dead) day as per new episodes

Link to comment
Share on other sites

quickmic

 

Please use latest beta for testing. There are issues in the log I already fixed.

Probably don't update your main devices.

Do you have a spare Laptop?

Link to comment
Share on other sites

CharleyVarrick
17 minutes ago, quickmic said:

 

Please use latest beta for testing. There are issues in the log I already fixed.

Probably don't update your main devices.

Do you have a spare Laptop?

I'm running Kodi on 2 different pc, they're both running the same stable versions at the moment.

I can and will update one on beta (will be the same desktop I just sent you the logs from).

Good?

 

  • Like 1
Link to comment
Share on other sites

CharleyVarrick

I install beta repo from zip, then e4k 5.2.0.1 from that repo

Do I need local db reset + perform adding library

Link to comment
Share on other sites

CharleyVarrick

image.png.6b51731b1283077592f0908f864d203c.png

almost there

 

add on mode selected

asking to choose emby views to sync to kodi

This will take a while

 

EDIT: I chose not to (Later) and media is present and accessible

Please confirm this is OK

Edited by CharleyVarrick
Link to comment
Share on other sites

CharleyVarrick

I have no new media to throw to emby (and kodi), not expecting to for the day

Want a fresh log or should I wait until I add new content ?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...