Jump to content

Emby no me funciona desde fuera de red local


loreentee20
 Share

Recommended Posts

loreentee20

Tengo un servidor hp proliant dl380 g7 con windows server 2019 donde tengo instalado el servidor de emby. En el windows tengo puesto en el firewall el permiso de embyserver con sus respectivos puertos y en el router idem de lo mismo. Por lo que no llego a entender el por que desde fuera de la red local no se conecta. Estuve investigando un poco y a una persona con un router de orange como el que yo tengo resulta que era por el tema puertos que el router no los abría o algo por el estilo por lo que he probado varios puertos pero nada sigue sin funcionar. Toda ayuda es buena y gracias de antemano.

CapturaEFEFE.PNG

Captura.PNG

Link to comment
Share on other sites

Mibok

Saludos, Primero que nada asegúrate que tienes un IP publica ya que no todos los proveedores de internet dan IP publica en sus paquetes básicos. y esto es esencial para que puedas conectarte desde fuera de tu red. En ese windows server tienes instalado también un servidor web? intenta usar https://canyouseeme.org para ver si estan visibles los puertos desde internet.

Link to comment
Share on other sites

loreentee20

IP pública si tengo además es fija, ya tengo varios servicios desde el Server incluso el web. En esa página me salen los puertos de emby cerrados por lo que sigo pensando que es el router que aunque le haya puesto que se utilicen los sigue teniendo cerrados. Voy a probar más puertos a ver si alguno funciona. Gracias

Link to comment
Share on other sites

Mibok

Quizas puedas desactivar el firewall completamente en el servidor de manera temporal, solo para quitar de la ecuacion si es el Firewall de windows el que esta dando problemas.

Link to comment
Share on other sites

loreentee20
31 minutes ago, Mibok said:

Quizas puedas desactivar el firewall completamente en el servidor de manera temporal, solo para quitar de la ecuacion si es el Firewall de windows el que esta dando problemas.

He quitado el firewall completamente y nada sigue sin ir, yo sigo pensando que esta en los puertos del router que por algún motivo no se abren.

Link to comment
Share on other sites

loreentee20

He activado dmz para el servidor, he quitado el firewall del router a parte del del servidor. Y nada, estoy pensando en mirar el dns del servidor.

Link to comment
Share on other sites

Mibok

Intenta configurar el Emby en otro puerto, cabe la posibilidad de que tu ISP tenga bloqueados esos puertos.

Link to comment
Share on other sites

loreentee20

He probado a utilizar otros puertos y también reinstalando, me ha saltado una pregunta que puede que me llames idiota jajaja. Se necesita emby premium para acceder desde fuera de la red?

Link to comment
Share on other sites

Mibok
3 hours ago, loreentee20 said:

He probado a utilizar otros puertos y también reinstalando, me ha saltado una pregunta que puede que me llames idiota jajaja. Se necesita emby premium para acceder desde fuera de la red?

No es necesario, puedes reproducir perfectamente desde el navegador sin emby premier. Lo que si te bloquea ademas de algunas funciones avanzadas es el poder reproducir desde dispositivos multimedia (smartphones, apps de tv, roku, etc...) 

Link to comment
Share on other sites

Mibok

Sospecho que es tu isp el que te esta bloqueando los puertos. Intenta asignarle al emby el puerto de tu servidor web (el puerto 80) que es el único del que tienes constancia que funciona a ver si funciona desde ahí. Tambien intenta contactar con tu isp a ver que dicen.

Link to comment
Share on other sites

loreentee20

Ya se donde esta el problema, he probado a instalar el servidor en mi ordenador personal y en el Router cambiarle el enrutamiento y FUNCIONA así que el problema es del servidor pero ahora toca buscar el por que ya que el firewall no era, tiene que ser algo de la red aunque el servidor este directamente conectado al router sin pasar por ningún repetidor ni segundo router no como mi ordenador personal que pasa por dos routers, así que por descarte tendrá que ser del windows server, voy a ir metiendo me en los servicios que tengo como por ejemplo el dns a ver si falta algo. Muchas gracias por la ayuda.

Link to comment
Share on other sites

  • 3 weeks later...
loreentee20

Si, resulta que mi router no abre bien los puertos y tuve que quitar y poner la regla un montón de veces hasta que le diera la gana de funcionar.

  • Like 1
Link to comment
Share on other sites

Maybe show it the hammer and scare it a bit next time. :)

I've had that happen as well in remote sessions with people where you do the same things over and over and it decides to take it.  It can certainly be very frustrating!

Link to comment
Share on other sites

loreentee20

Es horroroso, por que ahora estoy intentando abrir varios puertos para varios servidor de Minecraft que tengo y no hay manera. Es un asco. Estoy por llamar a la compañía y decirle que me cambien el router que no funciona adecuadamente pero es que me da una pereza después configurar de nuevo toda la red e la casa con todos los dispositivos, tengo una lucha mental abierta jajaja

Link to comment
Share on other sites

Mibok
4 hours ago, loreentee20 said:

Es horroroso, por que ahora estoy intentando abrir varios puertos para varios servidor de Minecraft que tengo y no hay manera. Es un asco. Estoy por llamar a la compañía y decirle que me cambien el router que no funciona adecuadamente pero es que me da una pereza después configurar de nuevo toda la red e la casa con todos los dispositivos, tengo una lucha mental abierta jajaja

Es por eso que se recomienda comprar un router que cumpla tus nececidades y usar el de tu ISP en modo DMZ solamente. Asi te ahorraras muchos dolores de cabeza. Como sea que bueno que diste con el problema. 

 

Edited by Mibok
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...