Jump to content

Nothing showing up in top shelf (Apple TV Home Screen)


NorthDegree
 Share

Recommended Posts

2 hours ago, NorthDegree said:

Ver. 1.5.1 (10)

That's the apple tv app. What version of emby server are you running?

Link to comment
Share on other sites

NorthDegree

thanks for the quick reply, so I was on a older version but I just updated to 4.5.4.0 ...   but unfortunately still nothing in top shelf.

Link to comment
Share on other sites

45 minutes ago, NorthDegree said:

just a quick update, not sure why but no longer having this as of today.  

Thanks for the feedback.

Link to comment
Share on other sites

sross44

@NorthDegree if it happens again, what I've found to be successful for me is deleting the app and reinstalling. Kind of a pain in the ass but it works every time. Easy to log back in to your Emby Server as well. 

Link to comment
Share on other sites

sross44
6 hours ago, NorthDegree said:

As a matter of fact I have , it’s not working again.

Have you tired reinstalling the app? Do you have the most up to date app? 

Link to comment
Share on other sites

sross44

If it happens again, go ahead and delete the app and reinstall it. Not sure why but I had to do that once and haven’t had any issues since. Sadly I’ve found myself using Infuse more and more as a front end for my Emby server when using Apple TV. The hope is that the Apple TV app eventually catches up to the Android and Roku apps!!! FINGERS CROSSED. 

Link to comment
Share on other sites

unisoft

Happened to me on the latest version.

 

Even uninstalled Emby app and re-installed (after the initial upgrade!). Still blank. Working fine before version update. always populated.

 

Also the new version removed login details and had to reconfigure - not good if family using Apple TV remotely in another location.

And 'bwdif' is giving odd results on PAL 50hz 1920x1080i content. Sometimes it shows the video with clear "combing" artefacts where deinterlacing not working. Other similar content at other times is fine, yet they are encoded all the same using same app - (Level 4.0 High Profile 11mbps Interlaced 25 frames per second constant, MP4, AVC, BT709)

Album Artists set as a sticky for MUSIC library, does not "stick" but only on Apple TV app

Photos & Videos did not stick on "Folders" - only on Apple TV app

Images in Channels or Guide too large as the code does not scale channel logos down to fit a certain size, see image.

 

IMG_20210319_134910.jpg

Edited by unisoft
Link to comment
Share on other sites

NorthDegree

It happened again... i restarted Apple TV and it disappeared after reboot.  

I tried deleting the app this time and no luck then I tried the unplug Apple TV, neither worked.  

Link to comment
Share on other sites

  • 2 weeks later...
unisoft
On 26/03/2021 at 13:53, unisoft said:

Happened to me on the latest version.

 

Even uninstalled Emby app and re-installed (after the initial upgrade!). Still blank. Working fine before version update. always populated.

 

Also the new version removed login details and had to reconfigure - not good if family using Apple TV remotely in another location.

And 'bwdif' is giving odd results on PAL 50hz 1920x1080i content. Sometimes it shows the video with clear "combing" artefacts where deinterlacing not working. Other similar content at other times is fine, yet they are encoded all the same using same app - (Level 4.0 High Profile 11mbps Interlaced 25 frames per second constant, MP4, AVC, BT709)

Album Artists set as a sticky for MUSIC library, does not "stick" but only on Apple TV app

Photos & Videos did not stick on "Folders" - only on Apple TV app

Images in Channels or Guide too large as the code does not scale channel logos down to fit a certain size, see image.

 

IMG_20210319_134910.jpg

Luke / Corey - is there anything you add?

Thank you.

Link to comment
Share on other sites

corey

@unisoftand @NorthDegree -- The only possibility that I can think of is that a specific set of media is causing the Top Shelf extension to crash. The only way I can effectively troubleshoot this is with direct access to a server that is having this issue so I can try and identify the specific issue.

Link to comment
Share on other sites

  • 1 month later...
unisoft
On 06/04/2021 at 18:01, Luke said:

@unisoft @NorthDegree

Can you send a PM to Corey and I containing your Emby Server url, username and password that we can test with? Thanks !

Luke,

Nothing would fix the top shelf issue, uninstalling Emby and re-installing, rebooting server, rebooting Apple TV.

I applied the tvOS 14.5 update and it fixed itself immediately after reboot and top shelf now populates. The other issues like channel logo resizing properly still exist (as I think thats simply code that doesn;t resize to a defined regime on Apple TV App.)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...