Jump to content

Emby kills Kodi database


Regotz
 Share

Recommended Posts

Regotz

Emby sync kills very often - at least once a week - the entire database of kodi. Mostly after an update, the entire database is empty. I tried reinstallation, restore a backup etc. but nothing works. This is quite shit!!!

Link to comment
Share on other sites

CharleyVarrick

That sounds like a total pain indeed, but nothing like this has ever happened to me and I've been using xbmc/Kodi for almost 8 years and Emby for Kodi 5 years on.

Mind you if its a Kodi update a local database reset is needed so those 2 link properly again.

Please note the latest Kodi version 19 requires a new emby add on called emby-next-gen (and then a local database reset).

I guess its the price to pay to enjoy the best of both worlds (Kodi's superb interface along with a single Emby server for all clients)

 

 

Edited by CharleyVarrick
  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
Regotz

Hi,

Thanks for the answer. I still use Kodi 18 as the emby plugin cannot handle .strm files. It is all set up properly. But almost everey sync of new content kills the database insinde kodi. Stull strange...

Link to comment
Share on other sites

quickmic

Have you tried emby-next-gen plugin?

Link to comment
Share on other sites

Regotz

Not yet as emby-next-gen does not support .strm files, as far as I know.

Link to comment
Share on other sites

quickmic

Who tells that. It's not true.

If you give it a try, use the stable version not the beta.

Link to comment
Share on other sites

Regotz

So, installed emby-next-gen. Then, the kodi databases gets killed every night! It’s even worser than before. May this issue be related to the Netflix addon exporting to the library?

Link to comment
Share on other sites

quickmic
Quote

every night

Seems something is triggered on a schedule. Can you please upload a log.

Best case tracing the issue, can you initiate the DB wipe on a pattern?

I've to determine what causes the issue.

Link to comment
Share on other sites

Regotz

Now, emby-next-gen stucks at every sync and produces a memory leak on the server side on my mac mini. So, actually not even an initial sync is working. The old emby addon has no problems with the initial sync. However, my nerves are at an end and I'm going back to a MySQL setup. 

Link to comment
Share on other sites

quickmic
7 hours ago, Regotz said:

Now, emby-next-gen stucks at every sync and produces a memory leak on the server side on my mac mini. So, actually not even an initial sync is working. The old emby addon has no problems with the initial sync. However, my nerves are at an end and I'm going back to a MySQL setup. 

ok, good luck

Link to comment
Share on other sites

Regotz

I stopped Netflix library export as well as automatic backup. Then reinstalled normal emby addon. Other than emby-next-gen, the initial sync goes without any problem. Until now, all is working as expected. Let's see if the Netflix and backup addons caused the problems...

  • Like 1
Link to comment
Share on other sites

Regotz
Posted (edited)

Until today, no more kills of the kodi database. So, it seems that really either the Netflix addon or the backup addon has caused the problem. Family is pleased again ;)

Now, next task is to find out which addon causes the kill of the database.

Many thanks to quickmic for the hint with the schedule task. That led me to the 2 addons 

Edited by Regotz
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...