Jump to content

Emby-Next-Gen will not open


donfrenchiano
 Share

Recommended Posts

donfrenchiano

I just updated to Kodi 19 and found out there is a new emby plugin. I'm on windows so i deleted my Kodi folder from AppData so on startup its like a fresh install. Everything is stock. I go to install Emby-Next-Gen from the repo and it installs but it will not open up. It says it fails and to check the log. Here is what my log says when i try to start it

 

2021-02-27 13:13:17.894 T:2856     INFO <general>: Python interpreter stopped
2021-02-27 13:13:55.145 T:5252     INFO <general>: initializing python engine.
2021-02-27 13:13:56.461 T:5252    ERROR <general>: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                                    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                                   Error Type: <class 'ModuleNotFoundError'>
                                                   Error Contents: No module named 'queue'
                                                   Traceback (most recent call last):
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\plugin.video.emby-next-gen\events.py", line 21, in <module>
                                                       import core.artwork
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\plugin.video.emby-next-gen\core\artwork.py", line 11, in <module>
                                                       import requests
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\script.module.requests\lib\requests\__init__.py", line 43, in <module>
                                                       import urllib3
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\script.module.urllib3\lib\urllib3\__init__.py", line 7, in <module>
                                                       from .connectionpool import HTTPConnectionPool, HTTPSConnectionPool, connection_from_url
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\script.module.urllib3\lib\urllib3\connectionpool.py", line 28, in <module>
                                                       from .packages.six.moves import queue
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\script.module.urllib3\lib\urllib3\packages\six.py", line 91, in __get__
                                                       result = self._resolve()
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\script.module.urllib3\lib\urllib3\packages\six.py", line 113, in _resolve
                                                       return _import_module(self.mod)
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\script.module.urllib3\lib\urllib3\packages\six.py", line 82, in _import_module
                                                       __import__(name)
                                                   ModuleNotFoundError: No module named 'queue'
                                                   -->End of Python script error report<--
                                                   
2021-02-27 13:13:56.505 T:5252     INFO <general>: Python interpreter stopped
2021-02-27 13:17:28.381 T:8960    ERROR <general>: Control 55 in window 10025 has been asked to focus, but it can't
2021-02-27 13:17:28.404 T:6428     INFO <general>: initializing python engine.
2021-02-27 13:17:29.508 T:6428    ERROR <general>: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                                    - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                                   Error Type: <class 'ModuleNotFoundError'>
                                                   Error Contents: No module named 'queue'
                                                   Traceback (most recent call last):
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\plugin.video.emby-next-gen\events.py", line 21, in <module>
                                                       import core.artwork
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\plugin.video.emby-next-gen\core\artwork.py", line 11, in <module>
                                                       import requests
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\script.module.requests\lib\requests\__init__.py", line 43, in <module>
                                                       import urllib3
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\script.module.urllib3\lib\urllib3\__init__.py", line 7, in <module>
                                                       from .connectionpool import HTTPConnectionPool, HTTPSConnectionPool, connection_from_url
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\script.module.urllib3\lib\urllib3\connectionpool.py", line 28, in <module>
                                                       from .packages.six.moves import queue
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\script.module.urllib3\lib\urllib3\packages\six.py", line 91, in __get__
                                                       result = self._resolve()
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\script.module.urllib3\lib\urllib3\packages\six.py", line 113, in _resolve
                                                       return _import_module(self.mod)
                                                     File "C:\Users\lr-htpc\AppData\Roaming\Kodi\addons\script.module.urllib3\lib\urllib3\packages\six.py", line 82, in _import_module
                                                       __import__(name)
                                                   ModuleNotFoundError: No module named 'queue'
                                                   -->End of Python script error report<--
                                                   
2021-02-27 13:17:29.520 T:5452     INFO <general>: CActiveAESink::OpenSink - initialize sink
2021-02-27 13:17:29.564 T:6428     INFO <general>: Python interpreter stopped
2021-02-27 13:17:29.573 T:5664    ERROR <general>: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.emby-next-gen/
2021-02-27 13:17:29.586 T:8960    ERROR <general>: CGUIMediaWindow::GetDirectory(plugin://plugin.video.emby-next-gen/) failed

 

 

 

Link to comment
Share on other sites

I'll perform a test on Windows, actually this issue is not directly related to emby next-gen plugin.

Looks like an issue of it's dependencies. "requests" loads "six" and that one crashed.

Link to comment
Share on other sites

donfrenchiano

I don't know if this helps but I went back to 18.9 with a fresh install and installed emby-next-gen. This time it worked and it showed me all of the deps that it was going to install which it did not do on 19. Once it was installed and i made sure everything worked I upgraded to 19 and everything seems to be working. 

  • Thanks 1
Link to comment
Share on other sites

I have 2 Nvidia shields. When the first one was updated i had borrowed out my second one to my father in law because of the IPTV he wanted to try i also have installed there.

On the one i had home i did get Next-Gen installed without any issues. This was a relief since i cant live without emby tbh :)

Anyways, i got the second box home today and tried to install it, which failed horribly because it wouldn't install script.module.requests and script-module.datautil.

I then tried to just copy both of these folders over from the working one. Which made one of them disappear. But the second one was still showing as needed to be installed.

So in the end i tried to just copy the whole Kodi folder from working one to the non working and presto it worked. 

But why could i install it on one of them like 3 days ago and today i couldnt?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...