Jump to content

No transport controls on remote player


mistercoffee
 Share

Go to solution Solved by Luke,

Recommended Posts

mistercoffee

Server: 4.5.4.0 on MacOS 10.13 High Sierra

On my server I'm also running the web player in Chrome. I use the Android app and the web app on other devices to remote control the web player on my server (because my server broadcasts audio to several airplay devices around the house). I should mention I only use Emby for music, no video.

Prior to server 4.5, I would get a scrub bar and basic transport controls on my remote devices as soon as I selected my server's player from the "Play On" dropdown. The transport would include play/pause, stop and previous/next. It would appear at the bottom of the screen the same as if I was playing locally (not remote controlling).

Immediately upon updating the server version, I no longer get that upon using the "Play On" menu. If I go to the "Play On" menu a second time and click "Remote Control" I get a full-screen player, of sorts, but the only thing that works on that screen is the "stop" control. "Play/Pause" has no effect and there are no "previous/next" icons. So if I want to, for example, go to the next track, I have to click the "Play On" menu, click "Remote Control," press "stop," press the back button, then manually select the next track.

This is identical using the Android player or the web player to remote control the web player on my server.

Is this now expected?

 

thanks

Link to comment
Share on other sites

wesselnv

I have the same issue. I'm new to Emby so don't know how it was previously, but this doesn't seem to be working as intended. 

Mac Air with 10.15.4 Catalina, running 4.5.4.0. There is a Yamaha network receiver to which I aiming to cast the music using dlna.  

For instance:
Via mac air: Browser interface. play file or playlist locally (on mac air), a play bar appears at the bottom, with access to playlist and controls. While this is playing I can cast to DLNA device (Yamaha). Audio stops on mac air and continuous on DLNA device (Yamaha). Once I go back to other parts of the server interface the player is gone (music still playing). When trying to go to "remote control" menu of emby for DLNA device (Yamaha), it does not show any information on what is currently being played. The reverse sequence, first indicating to play to DLNA device (Yamaha) and then selecting the music, get's me to the same point.

Via android app (version 3.1.73): browse to playlist, hit play, plays locally. Cast to Yamaha, sound plays on with the app, but also starts on Yamaha. Player is gone, remote control function of DLNA device (Yamaha) shows no information on current playing activity.  Music on DLNA device (Yamaha) can be stopped using remote control. Music playing on android app can be stopped by closing the app.
First indicating the DLNA device (Yamaha) and then starting the playlist plays the music on Yamaha but a player screen never appears, and the "remote control" option does not show information on what is currently being played, or playlist controls, but can stop the music.

I can access Emby also through the Musiccast app as a dlna server. This works well to play albums of pre-existing playlists, arguably better than the emby app, but the playlist/queue options have of Musiccast have their own issues.

 

Link to comment
Share on other sites

mistercoffee

@wesselnv What you' re describing sounds like a different, though similar issue. Here are some screenshots of my issue:

My server is on a Mac Mini, High Sierra, server 4.5.4.0. Also on the server Chrome is open with Emby web player loaded in a tab.

1. Playing a song on Emby web player, Macbook Pro Mojave, Chrome, connected to the above server. Note the full transport controls. The track is playing from the Macbook.

2. Same thing after I click the "now playing/play queue" icon.

3. I click the "play on" menu and select the remote chrome player that is running on my Mac Mini server.

4. The track is playing (I can hear it coming from the Mac Mini, no longer from the Macbook) but there are no transport controls and no "now playing/play queue" icon. This is different than it was before I updated to from server 4.3.x to server 4.5.4.0 -- before, the transport would still be there.

5. I click the "play on" menu again and click "remote control."

6. I get a limited transport/now playing screen where the only button that works is "stop." There's no way to advance to the next track, scrub, pause or anything. This is different than it was before I updated to from server 4.3.x to server 4.5.4.0 -- before, there would the same rudimentary controls but they would all work.

The result is that there's no way now to change tracks without many many clicks -- click on "play on," click on "remote control," click "stop," click the back arrow, click the next song. And no way at all to pause or scrub.

 

1.png

2.png

3.png

4.png

5.png

6.png

Link to comment
Share on other sites

wesselnv

I can't really replicate this without having two macs at hand. I tried to see if using the android app on my phone would give a different behaviour. It seems it does, the app is slightly better in keeping track of what is being send out to other players. Can you try that as well?

The current beta version 4.6.0.10-beta has the following listed:

  • Support manipulating the play queue of remote controlled players

https://github.com/MediaBrowser/Emby.Releases/releases/tag/4.6.0.10
https://emby.media/community/index.php?/topic/90247-emby-beta-server-release-note-history-460x/&tab=comments#comment-928406
 

Unfortunately, there is no installer of the beta version for OSX. Given the regular release pattern, our issue might well be dealt with with the next release. 🤞

 

Link to comment
Share on other sites

  • Solution

Hi, I just tested and it seems to work just fine. As a test can you try another browser on the server machine, such as safari?

Link to comment
Share on other sites

mistercoffee
21 hours ago, Luke said:

Thanks for the feedback.

@Luke I've just realized that the pause button still doesn't work -- if you press pause on a playing track, the track goes back to the beginning and plays.

Link to comment
Share on other sites

10 hours ago, mistercoffee said:

@Luke I've just realized that the pause button still doesn't work -- if you press pause on a playing track, the track goes back to the beginning and plays.

Seems to be working OK from here in my testing, but will keep an eye out for it. Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...