Jump to content

Error when upgrading to 4.5.4


bizarro252

Recommended Posts

bizarro252

Hello!

Upgrading I am getting this mismatch warning, my FreeNAS server claims that it is up to date so unsure what to do about this:

I am on FreeNAS-11.3-U5

 

[emby] Installing emby-server-4.5.4.0_1...
Newer FreeBSD version for package emby-server:
To ignore this error set IGNORE_OSVERSION=yes
- package: 1104001
- running kernel: 1103000
Ignore the mismatch and continue? [y/N]:
 

Link to post
Share on other sites
bizarro252

Hi Luke,

I am following the directions here:

Specifically: 

iocage console emby-server
service emby-server stop
pkg add -f https://github.com/MediaBrowser/Emby.Releases/releases/download/4.5.4.0/emby-server-freebsd11_4.5.4.0_amd64.txz
service emby-server start

 

I also just tried to install in a new jail (as an experiment) via the plugin feature since it was also going to install the latest version.  That worked to install (after fighting with an error that had to do with the mac prefix on the network tab, it defaulted to "b42e99" but the error stated the second 'digit' needed to be an "A" or "E"...)

Once that fresh install via a plugin instead of a manual install finished i attempted to 'upgrade' it just to see if the error went away and nope, same thing.

Perhaps has to do with the jail versions?  Both my original install as well as the fresh install via the plugin are on jail version: 11.3-RELEASE-p14.  A fresh manually created jail (just an empty jail) will create as: 11.4-RELEASE-p6

Edited by bizarro252
Link to post
Share on other sites
  • 2 weeks later...
bizarro252

Hi @Luke, any ideas here?  I upgraded my server and got the error in my OP and as far as I can tell everything is still working fine, just not sure if there is some dependency I may be missing that will break something in the future.

Link to post
Share on other sites
MRobi

@bizarro252You're safe to hit Y there and continue with the package install. It's only because the Emby package was built with a newer kernal (11.4) than the one you have installed (11.3). 

I would also recommend adding a pkg update and pkg upgrade in there to update the dependencies.

Edited by MRobi
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...