Jump to content

Can't login


justinrh
 Share

Recommended Posts

justinrh

I installed the WMC plugin.  When it launches it shows my user name, I select my user, then it asks for the PIN.  I type in the PIN and it says 'access denied, incorrect password'.  What is wrong?  Is there a log file that might give a clue?

I use the same PIN to access the Emby web interface.

Link to comment
Share on other sites

Hi.  Exactly what PIN are you entering?  In Emby for WMC the "PIN" means the local password for the user you are trying to log in with.  Not an Emby Connect PIN for instance...

Link to comment
Share on other sites

justinrh

I'm using the PIN I set for the user account in Emby.  That is the only PIN I have.   I don't even know what "the local password for the user you are trying to log in with" means.  I selected the Emby user in the WMC window; there is no local password for an Emby user.

embyWMC.PNG.49ac411f9b6effe9ea111e8029468e56.PNG

Link to comment
Share on other sites

2 hours ago, justinrh said:

I'm using the PIN I set for the user account in Emby

Exactly where did you set this?

Can you please post the server log from when you try to log in?

Link to comment
Share on other sites

justinrh

@ebr is there another place than manage\{user}\Password?

 

2020-11-24 19:27:04.499 Info HttpServer: HTTP GET http://192.168.2.151:8096/emby/System/Info/Public?format=Json. UserAgent:
2020-11-24 19:27:04.535 Info HttpServer: HTTP Response 200 to 192.168.2.165. Time: 37ms. http://192.168.2.151:8096/emby/System/Info/Public?format=Json. ConnectionId: 0HM4GS2B9S9NE
2020-11-24 19:27:04.570 Info HttpServer: HTTP GET http://192.168.2.151:8096/emby/Users/Public?isDisabled=False&format=Json. UserAgent:
2020-11-24 19:27:04.571 Info HttpServer: HTTP Response 200 to 192.168.2.165. Time: 1ms. http://192.168.2.151:8096/emby/Users/Public?isDisabled=False&format=Json. ConnectionId: 0HM4GS2B9S9NE
2020-11-24 19:27:10.758 Info HttpServer: HTTP POST http://192.168.2.151:8096/emby/Users/84744d33-2e03-4d1c-853f-dbc1c422c39f/Authenticate?format=Json. Content-Type=application/x-www-form-urlencoded, Authorization=MediaBrowser UserId="84744d33-2e03-4d1c-853f-dbc1c422c39f", Client="MB-Classic", Version="3.0.307.0", DeviceId="2a81c2641ade467ab58f14edc8b9dece", Device="HP4415S/jose", Expect=100-continue, Host=192.168.2.151:8096, Content-Length=49
2020-11-24 19:27:10.774 Error UserManager: Error authenticating with provider Default
    *** Error Report ***
    Version: 4.5.2.0
    Command line: C:\Users\admin\AppData\Roaming\Emby-Server\system\EmbyServer.dll
    Operating system: Microsoft Windows 10.0.19041
    Framework: .NET Core 3.1.8
    OS/Process: x64/x64
    Runtime: C:/Users/admin/AppData/Roaming/Emby-Server/system/System.Private.CoreLib.dll
    Processor count: 4
    Data path: C:\Users\admin\AppData\Roaming\Emby-Server\programdata
    Application path: C:\Users\admin\AppData\Roaming\Emby-Server\system
    System.Exception: System.Exception: Invalid username or password
       at Emby.Server.Implementations.Library.DefaultAuthenticationProvider.Authenticate(String username, String password, User resolvedUser)
       at Emby.Server.Implementations.Library.UserManager.AuthenticateWithProvider(IAuthenticationProvider provider, String username, String password, User resolvedUser, CancellationToken cancellationToken)
    Source: Emby.Server.Implementations
    TargetSite: System.Threading.Tasks.Task`1[MediaBrowser.Controller.Authentication.ProviderAuthenticationResult] Authenticate(System.String, System.String, MediaBrowser.Controller.Entities.User)
    
2020-11-24 19:27:10.776 Info HttpClient: POST https://connect.emby.media/service/user/authenticate
2020-11-24 19:27:11.040 Info UserManager: Authentication request for theadmin has been denied.
2020-11-24 19:27:11.042 Warn HttpServer: AUTH-ERROR: 192.168.2.165 - Invalid username or password entered.
2020-11-24 19:27:11.042 Error HttpServer: Invalid username or password entered.
2020-11-24 19:27:11.042 Info HttpServer: HTTP Response 401 to 192.168.2.165. Time: 284ms. http://192.168.2.151:8096/emby/Users/84744d33-2e03-4d1c-853f-dbc1c422c39f/Authenticate?format=Json. ConnectionId: 0HM4GS2B9S9NE

 

Link to comment
Share on other sites

justinrh

The Beta build allowed me to sign in. (Might want to scrap the stable build!)

Why do I get this when I play media?  What does it mean?  The media plays, so access errors don't make sense.

emby_wmc.png.b12cc02a6d612ed36adbc8593b374d63.png

Link to comment
Share on other sites

The items are probably playing at reduced quality and things like seeking may or may not work.  Definitely look into what Luke pointed to above.

  • Like 1
Link to comment
Share on other sites

Yea we wrote that message probably five years ago, so yes it could be friendlier at this point. Thanks for the feedback.

Link to comment
Share on other sites

  • 2 years later...
jump007

Hi, I am using Version 4.7.11.0 and have suddenly the same problem. When trying to access Emby in WMC, I can select the profile and then a PIN is requested (I never had that before). I have tried the Password I have set in Emby; no luck (access denied). I don't actually have a PIN for users in Windows (the HTPC is set up to start windows without password).

Please help.

Link to comment
Share on other sites

2 minutes ago, jump007 said:

Hi, I am using Version 4.7.11.0 and have suddenly the same problem. When trying to access Emby in WMC, I can select the profile and then a PIN is requested (I never had that before). I have tried the Password I have set in Emby; no luck (access denied). I don't actually have a PIN for users in Windows (the HTPC is set up to start windows without password).

Please help.

Hi, are you able to sign out and then back in to your Emby web interface? By sign out I mean explicitly signing out so that you have to login again next time. 

Link to comment
Share on other sites

jump007

Hi Luke,

After signing out (web interface), I can just sign in by clicking on sign in (without password). I have the setting " don't require a password on the local network"...

However, in WMC it asks me to select a profile and then a PIN (which I don't have)...

Link to comment
Share on other sites

5 hours ago, jump007 said:

Hi Luke,

After signing out (web interface), I can just sign in by clicking on sign in (without password). I have the setting " don't require a password on the local network"...

However, in WMC it asks me to select a profile and then a PIN (which I don't have)...

Did you try leaving the pin blank?

Emby for Wmc is not compatible with emby server 4.7.11. you'll need to use an older version of emby server.

Have you tried our emby theater app?

https://emby.media/download.html

Link to comment
Share on other sites

jump007

Yes, I did leave it blank. Same result.

I have not tried the emby theater app. I would be happy to replace WMC, but as far as I understand, Emby Theater does not support the Australian EPG and my existing 4 Tuners: (AVerMedia A188 and Winfast DVT 2000 DS)  - is this correct?.

Where can I find an older version of Emby Server?

Cheers

 

 

Link to comment
Share on other sites

Happy2Play
1 hour ago, jump007 said:

Where can I find an older version of Emby Server?

Linked in pinned topic.

But may run into issues downgrading do to upgrade changes.

Link to comment
Share on other sites

jump007

Thanks for the link.

Just on my questions regarding compatibility: "I would be happy to replace WMC, but as far as I understand, Emby Theater does not support the Australian EPG and my existing 4 Tuners: (AVerMedia A188 and Winfast DVT 2000 DS) 

Is this correct?

 

Link to comment
Share on other sites

On 1/3/2023 at 3:28 AM, jump007 said:

Thanks for the link.

Just on my questions regarding compatibility: "I would be happy to replace WMC, but as far as I understand, Emby Theater does not support the Australian EPG and my existing 4 Tuners: (AVerMedia A188 and Winfast DVT 2000 DS) 

Is this correct?

 

Hi @jump007 yes, but you could install NextPVR, and then import those into Emby Server Live TV using the Next PVR plugin for Emby Server. Please let us know if this helps. Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...