Jump to content

Alexa now requiring secure connection on port 443?


TulsaTV
Go to solution Solved by TulsaTV,

Recommended Posts

As of 17Nov2020 or before, I cannot get Alexa to use herself as the Emby player. It still works to set a Chrome browser as player. When I try to change player to "this device", I get this message from Alexa:

"Your server must provide a secure connection with a public https port number 443 and a valid SSL certificate to play directly on this device."

My SSL cert was working fine for remote connection when this problem started. The cert was due for renewal soon, so I just renewed it, same results,

Just for kicks, I changed https port 8920 both local and public in Emby to 443, and set a rule in the router to forward 443 external to 443 internal. Alexa was then willing to accept "this device" as the player, and accepted a request to play a song, but no music came out. So it seems she really does want a secure connection with 443. Reverted to the settings that had worked for a couple of years until just recently.

So, has Amazon made a change to require the use of port 443?

 

 

Link to post
Share on other sites

Mp3. It had worked perfectly for a couple of years (as long as the SSL cert was valid), then stopped, despite no changes made in the setup.

Port 8920 is the standard https port for Emby. Not sure where 443 entered into the picture the last 2 years, since it was never included explicitly in the network settings.

Edited by TulsaTV
Clarity
Link to post
Share on other sites
11 hours ago, TulsaTV said:

Port 8920 is the standard https port for Emby. Not sure where 443 entered into the picture the last 2 years, since it was never included explicitly in the network settings.

Yes it is the default but now it looks like you will need to use 443 if you want to be able to play directly on your alexa device.

Link to post
Share on other sites

Hi.  Keep in mind, you can map only the external port on your router to 443 and keep the internal Emby one at 8920 if you wish.

Link to post
Share on other sites
  • 2 months later...
TulsaTV
On 11/23/2020 at 10:08 AM, ebr said:

Hi.  Keep in mind, you can map only the external port on your router to 443 and keep the internal Emby one at 8920 if you wish.

I tried having the router forward external 443 to internal 8920, keeping Emby set at 8920 local and public https. Did not work.

If I set the router to forward 443 external to 443 internal, and set Emby local and public https to 443, I do have remote access from the Dashboard, and Alexa works so far as to announce the song playing, but no sound. The Activity log shows only "has finished playing" the song rather than a "started playing' message followed by a "finished playing" one.

I don't understand what this means in the Network section:

"Public https port number:
(e.g., 8920)
The public port number that should be mapped to the local https port."

So, is it saying the mapping must occur in the router, or is it saying that it will do this?

Could you restate your advice in terms of what the the Emby local/public https ports should be, and then what the router mapping should be for that setting?

Edited by TulsaTV
Clarity
Link to post
Share on other sites
cayars

You should keep the LOCAL set to 8096 and 8920.

On your router forward port WAN/443 to Emby IP/8920.
Then in Emby network section use port 443 for "Public https port number:"

Link to post
Share on other sites
TulsaTV
On 2/18/2021 at 8:58 AM, cayars said:

You should keep the LOCAL set to 8096 and 8920.

On your router forward port WAN/443 to Emby IP/8920.
Then in Emby network section use port 443 for "Public https port number:"

So far, no luck with getting remote access in a way other than forwarding 8920 to 8920 and setting 8920 as public https in Emby. I set the router rule as external 443 forward to internal 8920 in the router, and Emby as 443 for public https.

Maybe I am missing something on the Windows Firewall, Tried 443 as public, 8920 as private, and each as both public and private, neither works.

Any other suggestions? I think Angelblue05 has worked on this app most recently.

Edited by TulsaTV
Clarity
Link to post
Share on other sites
  • Solution
TulsaTV
On 2/18/2021 at 8:58 AM, cayars said:

You should keep the LOCAL set to 8096 and 8920.

On your router forward port WAN/443 to Emby IP/8920.
Then in Emby network section use port 443 for "Public https port number:"

Here is what just worked (i.e., allows Emby remote access AND Alexa not only announces music playing, but actually plays it):

In Emby:
Local http: 8096
Local https: 443
Public http: 8096
Public https: 443

Router:
External 443 forwarded to internal 443.

Firewall:
443 allowed as both public and private.

Could this be changed in a way to make it simpler or better, and still work?

Edited by TulsaTV
Clarity
Link to post
Share on other sites
cayars

That's a little strange and suggests the forward rule put in place for 443 to 8920 didn't work or wasn't setup correctly but if the above setup works, call it a day, mission accomplished!

Link to post
Share on other sites
TulsaTV
6 minutes ago, cayars said:

That's a little strange and suggests the forward rule put in place for 443 to 8920 didn't work or wasn't setup correctly but if the above setup works, call it a day, mission accomplished!

Yeah, I just don't have enough experience with all this to have any hard expectations about what should, could, or would work, but it's great having Emby back on Alexa!

I am able to use Alexa with Plex the same way, but Plex' "play some music" pulls from only the music library you specify, not all of them as Emby can be set. Also, Emby seems to select more truly randomly when you ask Alexa to "play music". So, good to have them both for me.

Thanks for the help!

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...