Jump to content

Emby unreachable from outside


Go to solution Solved by Q-Droid,

Recommended Posts

Hello people, 

i have emby running on a docker container on my raspberry pi 4 for quite some time now. I like it a lot. Yesterday I subscribed to emby premiere in order to be able to stream to my phone, when i am away from home. However i was unable to get it to work. I will provide as much information as i can... I should also mention that i am running a nextcloud container as well, which is working well.

here is my container config:

image.thumb.png.c99378a759310cabfa91244a8bd2c5f5.png

i added the 8920 port yesterday.

My emby network settings are as follows:

image.png.e8c1296df1ca9f77883a1e968cd61fb4.png

here i find it weird that only http protocol is displayed, but nothing about https, even though i set the "required for all remote connections".

image.png.6dcb27d8bd69c8e28620ab4128c48521.png

so i tried to inspect the network activity. The network interfaces are routable:

image.png.465612793ee36482ff1a88dd4699901d.png

The 8920 port is being listened to:

image.thumb.png.dea6c60257e0c1ba70629bfc5660bb46.png

Where i call the domain sub.mydomain.com:8920 i get an "ERR_CONNECTION_REFUSED", so i look at tcpdump and see this:

image.thumb.png.37f3a32d942379d40c4538641c53df66.png

it does look normal, doesn't it?

My iptables shows:

image.png.f917193879a338477635444888af27c3.png

The emby server log is attached. As far as i can tell (according to timestamps), nothing is getting logged when i try to open the url.

I hope somebody can help with this

Thank you

 

image.png

embyserver.txt

Edited by Alebbo
added info
Link to post
Share on other sites
Luke

I think your certificate is failing to load. Can you connect remotely with plain http on the http port?

Link to post
Share on other sites
Luke

Try restarting the server after doing that. If it's still happening then you must have something else causing the redirect.

Link to post
Share on other sites

yeah, it is still happening... do you mean something else on the server side of things? or my browser? 

i tried 4 different browsers, deleted dns cache in my OS, disabled https redirects in firefox and chrome. Nothing works. So could be something in the emby server config? Is there something there i could look into? 

As mentioned i have a nextcloud container running with apache, but that only listens to ports 80, 443 and 4443.

Thanks for the support so far Luke :)

Link to post
Share on other sites
Luke

It's a useful test to help narrow down general connectivity problems vs problems with your certificate.

Link to post
Share on other sites

i got the http thing to work by changing the network in docker from bridge to host! Now i can visit emby remotley with myip:8096

The current problem is that Emby is not listening to port 8920, only 8096 is working. I set the ports in the Emby settings...

image.png.94998ba9fd2af1a6741800fa300dfb12.png

image.png.3dbc9152103921668eebf180f8b9a0d7.png

Link to post
Share on other sites
  • Solution

Ownership and permissions show user emby can't open the cert file. 

Also path to cert looks different. 

Edited by Q-Droid
Link to post
Share on other sites

This was it. I changed the permissions from root to the emby user and now everything is fine.

Would you recommend protecting the p12 file with a password? I plan to keep the file in it's current location only... 

Thank you both for your help 🙂

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...