Jump to content

MB Media Centre: Crash on Spotlight


Tanamur
 Share

Recommended Posts

Tanamur

Hi All - MBMC for Roku has updated to V2.9. Now when I try to disable the Spotlight display on the main screen, it does not disappear. Also, regardless of the enabled or disabled status in preferences, selecting one of the movies or TV series causes the channel to crash out to the home screen. Thanks, Tanamur

Edited by Tanamur
Link to comment
Share on other sites

im85288

Hi.

 

Are you saying you cannot disable the spotlight section? And are you saying selecting a movie or tv show in the spotlight is causing the app to crash?

Link to comment
Share on other sites

Tanamur

Hi.

 

Are you saying you cannot disable the spotlight section? And are you saying selecting a movie or tv show in the spotlight is causing the app to crash?

Yes on both counts. Toggling the enable/disable Spotlight option in Preferences has no effect on the main screen. I have tried both the enabled and disabled settings and both result in a crash when entering a Spotlight movie or TV entry.

Link to comment
Share on other sites

im85288

You need to restart the app for the changes to disable/enable the rows etc to take effect.

 

Can you try again, then after making the change restart and see if your still getting crashing? 

 

Tested here and working as expected.

Link to comment
Share on other sites

Tanamur

You need to restart the app for the changes to disable/enable the rows etc to take effect.

 

Can you try again, then after making the change restart and see if your still getting crashing? 

 

Tested here and working as expected.

Hi @@im85288 - I am on V2.9 which I think is the latest and I have power cycled the Roku 3. I have just done a complete reinstall of Official Server Release Version 3.0.5309.26857 so this should be stable and I have only added a small library for testing. When I enter MBMC the Spotlight row is present by default. Yet when I look at the Preferences settings they indicate both are disabled. I tested as follows:

 

Status Both: Enabled

Exit Channel and Re-enter

Select either Spotlight Row item or drill down to grid views

Result=Crash every time

 

Status Both: Disabled

Exit Channel and Re-enter

Select either Spotlight Row item or drill down to grid views

Result=Crash every time

 

So....I can't use them and I can't get rid of them I'm afraid.

 

Cheers, Tanamur

Link to comment
Share on other sites

im85288

Hi,

 

So just to confirm you go to the option to enable/disable rows on the home page..change spotlight to DISABLED..restart and the row is still shown?

 

I have tried it on a few Rokus where it's worked as expected.

 

Can you disable other rows successfully?

 

Cheers

Link to comment
Share on other sites

Tanamur

Hi,

 

So just to confirm you go to the option to enable/disable rows on the home page..change spotlight to DISABLED..restart and the row is still shown?

 

I have tried it on a few Rokus where it's worked as expected.

 

Can you disable other rows successfully?

 

Cheers

Hi @@im85288 - I'm sorry but I think I have overlooked the correct setting. In Preferences I was adjusting:

 

Enable/Disable Rows on Spotlight Page

 

instead of...

 

Enable/Disable Rows on Home Page

 

So, when I disable Spotlight in Enable/Disable Rows on Home Page it is gone so this is good since I don't use it. However, disabling Movies and TV in Enable/Disable Rows on Spotlight Page doesn't make much sense to me.

 

Cheers, Tanamur

Link to comment
Share on other sites

hoxtonia

@"Tanamur"

 

to disable the spotlight row select

 

Preferences

Show Views Preferences

Enable/Disable rows on Home page

Spotlight Row: Disabled

 

if you try and do it by

 

Preferences

Show Views Preferences

Enable/Disable rows on Spotlight page

Trending Movies Row: Disabled

Trending Shows Row: Disabled

 

it doesn't work -  too cannot get them to disable. But I also don't get a crash......

Edited by hoxtonia
  • Like 1
Link to comment
Share on other sites

hoxtonia

@im85288 

 

There is a bug here though. I would like to disable Trending TV shows as I only use spotlight to add movies to couch potato. Would you be able to have a look at the disable Spotlight Trending shows row functionality....

Link to comment
Share on other sites

im85288

@im85288 

 

There is a bug here though. I would like to disable Trending TV shows as I only use spotlight to add movies to couch potato. Would you be able to have a look at the disable Spotlight Trending shows row functionality....

 

Hi, I tried it out and it worked fine for me... there was a typo in the title which is now fixed but I doubt that makes a difference. 

Maybe worth trying again in 2.10 though.

Link to comment
Share on other sites

hoxtonia

updated retested and still cannot get this to work - disabling either Spotlight tv or movies row appears to have no effect - even after reboot of app - however this is not really important to me at all and quite happy to live with how it functions....I am sure there are more important things to spend development time on.....

Link to comment
Share on other sites

Happy2Play

I was seeing the same with Spotlight enabled - crash, but had no issues disabling Spotlight.

Roku 3

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...