Jump to content

firewall keeps popping up when Embyserver starts


mini__me
 Share

Recommended Posts

I'm getting prompted on every single start of the Emby server to allow inbound access through the firewall, despite it being listed and added in the allowed applications. Try looking in there to see if EmbyServer is added?

 

This has only recently started and is pretty annoying. I've tried removing Emby from my login items, removed the entry from the firewall list, shutting down the Mac, booting up the Mac adding EmbyServer manually to the Firewall list, shutting down, starting up, checking EmbyServer is in the allowed list, starting EmbyServer .... and I'm prompted to allow incoming connections!!!

 

Is this because the EmbyServer app isn't signed?

@Happy2Play please move my postings from this topic into a new thread because it's not related to this. Thanks.

Link to comment
Share on other sites

On 10/9/2020 at 4:40 AM, mini__me said:

I'm getting prompted on every single start of the Emby server to allow inbound access through the firewall, despite it being listed and added in the allowed applications. Try looking in there to see if EmbyServer is added?

 

This has only recently started and is pretty annoying. I've tried removing Emby from my login items, removed the entry from the firewall list, shutting down the Mac, booting up the Mac adding EmbyServer manually to the Firewall list, shutting down, starting up, checking EmbyServer is in the allowed list, starting EmbyServer .... and I'm prompted to allow incoming connections!!!

 

Is this because the EmbyServer app isn't signed?

Hi, that's strange. Did you follow the instructions on the website to drag it into the Applications folder?

@levander are you seeing this?

Link to comment
Share on other sites

Hi,

Well, my problem is in the title already. At every start of the Emby Server app, I see the dreaded: 

"Do you want the application Embyserver.app to accept incoming network connections" message popping up.

Of course, it's annoying to have to allow that message every time. Does anyone know what to do about it? I've looked in the Emby Settings, but can't find a solution over there.

I'm seeing this popup for a couple of weeks now. In the Meanwhile, there was an Emby update, but that didn't resolve the issue. 

In my Mac Firewall, Embyserver is listed as  'allow incoming connections'.

I read about a solution on StackOverflow, but that seems a little dodgy: https://stackoverflow.com/questions/17527700/do-you-want-the-application-to-accept-incoming-network-connection

Would it be advisable?

 

Thanks for helping out..

Dan

 

MacOS 10.13.6 / Emby Server 4.5.2.0

Link to comment
Share on other sites

On 10/15/2020 at 6:28 PM, Luke said:

Hi, that's strange. Did you follow the instructions on the website to drag it into the Applications folder?

@levander are you seeing this?

No. But I’m not using Catalina. 

Link to comment
Share on other sites

Superb, no more popups.. thanks a lot!

A question though: when there's an update to Emby, should I pass on that, and hold on to this version?

Link to comment
Share on other sites

On 15/10/2020 at 17:28, Luke said:

Hi, that's strange. Did you follow the instructions on the website to drag it into the Applications folder?

@levander are you seeing this?

Absolutely, been running versions of the server for at least a year now if not longer, running latest macOS Catalina 10.15.7

Edited by mini__me
Link to comment
Share on other sites

For anyone else who runs into this, I've replaced the 4.5.2 build on our website with a patched version that has a fix for this. You can simply install it on top of your existing version. Thanks.

  • Thanks 1
Link to comment
Share on other sites

On 21/10/2020 at 22:22, Luke said:

For anyone else who runs into this, I've replaced the 4.5.2 build on our website with a patched version that has a fix for this. You can simply install it on top of your existing version. Thanks.

Will give this a go tonight 👍🏼 Cheers Luke

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...