Jump to content
stwarr

Emby Theater [windows desktop] - Refresh Rate Change

Recommended Posts

stwarr

When using Emby Theater desktop on win10, the refresh rate change prior to starting video playback seems to work very nicely, but the app doesn't seem to restore the original refresh rate when playback ends. This means that the Emby home screen and indeed the win10 desktop get rendered in whatever the video mode of the last played video was. Any chance of getting this addressed?

Also I have a large number of .ts recordings in my Emby library. Here in the UK, the OTA broadcasters tend to change the transmission mode based on content, so for example, sports might be broadcast as 1080i50, versus films as 1080p25. When playing an interleaved recording, Emby Theater seems to want to switch the TV display mode into 50Hz interleaved, even though the software/GPU is going to remove the interleaving and display a progressive image. This seems wrong - if the app is going to do the deinterleaving then the display mode should always be progressive. Perhaps the  refresh code should just ignore the interleave flag altogether and only use the rate?

Finally, is the refresh rate code able to work with a live TV stream (mpegts)? Maybe the correct metadata isn't present on the stream definition provided by the NextPVR plugin that I use, but I never see a refresh change when I initiate live TV.

Edited by stwarr

Share this post


Link to post
Share on other sites
stwarr

That version seems to be 3.0.11.0 which is the version I was already running

Share this post


Link to post
Share on other sites
Luke
1 hour ago, stwarr said:

That version seems to be 3.0.11.0 which is the version I was already running

Hi, no, the test version is 3.0.12.

Share this post


Link to post
Share on other sites
Milldor

The newest version does fix the problem but creates another... 

The refresh rate does change back after stopping a video which is great. 

There is huge audio delay after the refresh rate change on this version so it's basically unusable again. 

When starting the video the old version used to have a pause before playback to allow the refresh rate to change. This version starts the video then blanks out for the change and is a bit jarring. 

Edited by Milldor

Share this post


Link to post
Share on other sites
Milldor

Another large problem with the newest version. 

Hdr content just shows a blue screen. 

Share this post


Link to post
Share on other sites
sooty234

You need to switch the renderer from libmpv to gpu if you want to use HDR passthrough. And use D3D for hardware acceleration.

Share this post


Link to post
Share on other sites
Luke
On 10/18/2020 at 5:58 AM, Milldor said:

The newest version does fix the problem but creates another... 

The refresh rate does change back after stopping a video which is great. 

There is huge audio delay after the refresh rate change on this version so it's basically unusable again. 

When starting the video the old version used to have a pause before playback to allow the refresh rate to change. This version starts the video then blanks out for the change and is a bit jarring. 

https://emby.media/community/index.php?/topic/46763-theater-mpv-test/&do=findComment&comment=938629

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...