Jump to content

Unable to install from installer


Ungraid
 Share

Go to solution Solved by Ungraid,

Recommended Posts

Hi, I'm new to Emby (trying to switch over from Plex) and I cannot get your service installed from your installer. I have attached an image of the error I get when trying to install. I have tried almost everything I can think of, running as admin, disabling firewall, and even putting my PC in DMZ temporarily.

I am able to use the portable version, however I also get network errors. No plugins can be installed/updated, and the application itself cannot reach the update server. I'm quite perplexed by this issue, and am hoping someone will be able to help me out. I'll provide log files as requested (not too keen on posting uncensored log files online and I don't currently have time to go through each line and ensure there's nothing identifiable). Thanks.

Capture.PNG

Capture1.PNG

Capture2.PNG

Edited by Ungraid
Link to comment
Share on other sites

HI, the error message needs to be improved, but something is blocking the installer from being able to reach the internet. This is typically caused by firewall, security software, or VPN. Can you look into this? You can also try the portable download that we have on our downloads page.

Link to comment
Share on other sites

6 minutes ago, Luke said:

HI, the error message needs to be improved, but something is blocking the installer from being able to reach the internet. This is typically caused by firewall, security software, or VPN. Can you look into this? You can also try the portable download that we have on our downloads page.

As I stated in my OP, I already tried disabling all firewalls and even placed my PC into a DMZ from my EdgeRouter.

Again, as I already stated in my OP, I have tried using the portable version but it cannot reach any update servers or update/install any plugins. I feel these issues are related, which is why I included that info in the original post.

 

Link to comment
Share on other sites

8 minutes ago, Luke said:

Yea probably. What security software are you running?

Only Windows Defender, which I have also tried disabling. I get the same results with it off.

Link to comment
Share on other sites

You image is showing it's trying to download a very old version of Emby Server V 3.0

This is what I get with the setup downloaded just now from the website. V 4.5.1.0

aaa.png.545e0a796f972c9add69e36b1e09ce65.png

An old installer isn't going to find the files to continue an installation that old.  You need to download a version of setup off our website and use that.

Move the installer to an empty directory with no other files and run it from there.

Link to comment
Share on other sites

1 minute ago, cayars said:

You image is showing it's trying to download a very old version of Emby Server V 3.0

This is what I get with the setup downloaded just now from the website. V 4.5.1.0

aaa.png.545e0a796f972c9add69e36b1e09ce65.png

An old installer isn't going to find the files to continue an installation that old.  You need to download a version of setup off our website and use that.

Move the installer to an empty directory with no other files and run it from there.

Wow that's bizarre. Do you mind uploading your setup.exe file somewhere for me to download? It doesn't matter what browser I download from, I keep getting the 3.0 version.

Link to comment
Share on other sites

Just download it from https://emby.media/windows-server.html like I just did.  Big green button.

MOVE the setup file to an empty directory and run it.  If you're running it from the download directory you could have older Emby files in that directory causing problems.

Try this and let us know if you still have a problem and if so I can remote in and help you, send you my setup file or whatever you would like to try next.

But give the download, install from an empty directory first.

Carlo

Link to comment
Share on other sites

3 minutes ago, cayars said:

Just download it from https://emby.media/windows-server.html like I just did.  Big green button.

MOVE the setup file to an empty directory and run it.  If you're running it from the download directory you could have older Emby files in that directory causing problems.

Try this and let us know if you still have a problem and if so I can remote in and help you, send you my setup file or whatever you would like to try next.

But give the download, install from an empty directory first.

Carlo

I've run it from the Downloads and Desktop folders, as well as from the root C drive. The results are the same.

Edited by Ungraid
Link to comment
Share on other sites

Happy2Play
9 minutes ago, Ungraid said:

I've run it from the Downloads and Desktop folders, as well as from the root C drive. The results are the same.

Last resort have you tried to get the portable and extract it to a location of your choice and manually recreate a shortcut for EmbyServer.exe.

11 minutes ago, cayars said:

MOVE the setup file to an empty directory and run it.  If you're running it from the download directory you could have older Emby files in that directory causing problems.

It does not matter where the setup.exe is as it is a installer that puts Emby in the users appdata folder.

Link to comment
Share on other sites

3 minutes ago, Happy2Play said:

Last resort have you tried to get the portable and extract it to a location of your choice and manually recreate a shortcut for EmbyServer.exe.

It does not matter where the setup.exe is as it is a installer that puts Emby in the users appdata folder.

Yes, using the portable in a different location with a shortcut is my current workaround, however it doesn't fix the fact that I cannot check for application updates or plugin updates. Like I said earlier I feel like they're probably related to me being unable to reach the server. Can one of you guys help me read the server's log files to maybe see where the issues are?

Quote

2020-09-29 18:41:15.249 Error HttpClient: Error getting response from https://api.github.com/repos/MediaBrowser/Emby.Releases/releases
	*** Error Report ***
	Version: 4.5.1.0
	Command line: C:\Program Files (x86)\Emby Server\system\EmbyServer.dll
	Operating system: Microsoft Windows 10.0.19041
	Framework: .NET Core 3.1.8
	OS/Process: x64/x64
	Runtime: C:/Program Files (x86)/Emby Server/system/System.Private.CoreLib.dll
	Processor count: 12
	Data path: C:\Program Files (x86)\Emby Server\programdata
	Application path: C:\Program Files (x86)\Emby Server\system
	System.Net.Http.HttpRequestException: System.Net.Http.HttpRequestException: An error occurred while sending the request.
	 ---> System.IO.IOException: Cannot determine the frame size or a corrupted frame was received.
	   at System.Net.Security.SslStream.ReadAsyncInternal[TReadAdapter](TReadAdapter adapter, Memory`1 buffer)
	   at System.Net.Http.HttpConnection.FillAsync()
	   at System.Net.Http.HttpConnection.ReadNextResponseHeaderLineAsync(Boolean foldedHeadersAllowed)
	   at System.Net.Http.HttpConnection.SendAsyncCore(HttpRequestMessage request, CancellationToken cancellationToken)
	   --- End of inner exception stack trace ---
	   at System.Net.Http.HttpConnection.SendAsyncCore(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.SendWithNtConnectionAuthAsync(HttpConnection connection, HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.SendWithRetryAsync(HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken)
	   at System.Net.Http.RedirectHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.DecompressionHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpClient.FinishSendAsyncUnbuffered(Task`1 sendTask, HttpRequestMessage request, CancellationTokenSource cts, Boolean disposeCts)
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod)
	Source: System.Net.Http
	TargetSite: Void MoveNext()
	InnerException: System.IO.IOException: Cannot determine the frame size or a corrupted frame was received.
	Source: System.Net.Security
	TargetSite: Void MoveNext()
	   at System.Net.Security.SslStream.ReadAsyncInternal[TReadAdapter](TReadAdapter adapter, Memory`1 buffer)
	   at System.Net.Http.HttpConnection.FillAsync()
	   at System.Net.Http.HttpConnection.ReadNextResponseHeaderLineAsync(Boolean foldedHeadersAllowed)
	   at System.Net.Http.HttpConnection.SendAsyncCore(HttpRequestMessage request, CancellationToken cancellationToken)
	
2020-09-29 18:41:15.254 Error TaskManager: Error
	*** Error Report ***
	Version: 4.5.1.0
	Command line: C:\Program Files (x86)\Emby Server\system\EmbyServer.dll
	Operating system: Microsoft Windows 10.0.19041
	Framework: .NET Core 3.1.8
	OS/Process: x64/x64
	Runtime: C:/Program Files (x86)/Emby Server/system/System.Private.CoreLib.dll
	Processor count: 12
	Data path: C:\Program Files (x86)\Emby Server\programdata
	Application path: C:\Program Files (x86)\Emby Server\system
	System.Net.Http.HttpRequestException: System.Net.Http.HttpRequestException: An error occurred while sending the request.
	 ---> System.IO.IOException: Cannot determine the frame size or a corrupted frame was received.
	   at System.Net.Security.SslStream.ReadAsyncInternal[TReadAdapter](TReadAdapter adapter, Memory`1 buffer)
	   at System.Net.Http.HttpConnection.FillAsync()
	   at System.Net.Http.HttpConnection.ReadNextResponseHeaderLineAsync(Boolean foldedHeadersAllowed)
	   at System.Net.Http.HttpConnection.SendAsyncCore(HttpRequestMessage request, CancellationToken cancellationToken)
	   --- End of inner exception stack trace ---
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod)
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsync(HttpRequestOptions options, String httpMethod)
	   at MediaBrowser.Common.Updates.GithubUpdater.CheckForUpdateResult(String organzation, String repository, Version minVersion, PackageVersionClass updateLevel, String assetFilename, String packageName, String targetFilename, TimeSpan cacheLength, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.ApplicationHost.CheckForApplicationUpdate(CancellationToken cancellationToken, IProgress`1 progress)
	   at Emby.Server.Implementations.ScheduledTasks.SystemUpdateTask.Execute(CancellationToken cancellationToken, IProgress`1 progress)
	   at Emby.Server.Implementations.ScheduledTasks.ScheduledTaskWorker.ExecuteInternal(TaskOptions options)
	Source: System.Net.Http
	TargetSite: Void MoveNext()
	InnerException: System.IO.IOException: Cannot determine the frame size or a corrupted frame was received.
	Source: System.Net.Security
	TargetSite: Void MoveNext()
	   at System.Net.Security.SslStream.ReadAsyncInternal[TReadAdapter](TReadAdapter adapter, Memory`1 buffer)
	   at System.Net.Http.HttpConnection.FillAsync()
	   at System.Net.Http.HttpConnection.ReadNextResponseHeaderLineAsync(Boolean foldedHeadersAllowed)
	   at System.Net.Http.HttpConnection.SendAsyncCore(HttpRequestMessage request, CancellationToken cancellationToken)

These seem like the update errors, but I'm not experienced enough to understand what they mean.

Link to comment
Share on other sites

Happy2Play

It is a matter of figuring out what on that system is blocking these connections.  Do you have another machine to test on?

Link to comment
Share on other sites

25 minutes ago, Ungraid said:

I've run it from the Downloads and Desktop folders, as well as from the root C drive. The results are the same.

Now can you try it from an Empty folder you create just for this purpose without using other folders?

Link to comment
Share on other sites

1 minute ago, Happy2Play said:

It is a matter of figuring out what on that system is blocking these connections.  Do you have another machine to test on?

Nothing is being blocked.  It's trying to install V3 not 4.5 of the server and the files don't exists for download.

Link to comment
Share on other sites

Happy2Play
1 minute ago, cayars said:

Nothing is being blocked.  It's trying to install V3 not 4.5 of the server and the files don't exists for download.

Sure it is look at the provide log from portable.

Link to comment
Share on other sites

1 minute ago, cayars said:

Now can you try it from an Empty folder you create just for this purpose without using other folders?

I downloaded it to a newly created folder and got the same results. I understand where you're coming from, but wouldn't those files be kept in a Temp folder instead of being hidden inside a previously used folder?

Link to comment
Share on other sites

4 minutes ago, Happy2Play said:

It is a matter of figuring out what on that system is blocking these connections.  Do you have another machine to test on?

Let my try it on my brother's machine.

Link to comment
Share on other sites

Installed without a hitch on my brother's machine on the same network. Checked for updates and installed plugins with no issue. Something is blocking on my machine, but the errors don't seem to point to what. I'm not really sure where to go from here...

Link to comment
Share on other sites

When you go to install you should see a link on the installer to "Show more info".

Click the link and you will see where the setup program is going to download/install from.

You should be able to rename that directory to force Emby Setup to create it fresh.

I'm betting there is old setup files in that directory causing you the issues.

Link to comment
Share on other sites

2 minutes ago, Happy2Play said:

My guess would be a Windows install issue, but just a guess.

He's on the exact same build of Windows as me, so it must be something like that. I don't want to do a fresh install of Windows though 😅

Link to comment
Share on other sites

Happy2Play

@Luke can you provide any more insight on the error?

	System.Net.Http.HttpRequestException: System.Net.Http.HttpRequestException: An error occurred while sending the request.
	 ---> System.IO.IOException: Cannot determine the frame size or a corrupted frame was received.

	InnerException: System.IO.IOException: Cannot determine the frame size or a corrupted frame was received.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...