Jump to content

EmbyCon direct smb?


Wheemer
 Share

Recommended Posts

Hello;

I can't find the direct smb settings for file access. I don't use transcoding and just want the files served as fast as possible. Is everything only http now? Reason I ask is I thought Kodi had more issues with htttp rather than direct access?

Link to comment
Share on other sites

it is called "Allow direct file playback"

you can turn this on in the add-on settings : EmbyCon Settings -> playback -> Allow direct file playback

If the server reports that direct file playback is possible then the client will then try to use the Path the server responds with to play the file.

Link to comment
Share on other sites

To add - you need to ensure you add the UNC path in the Libraries - or it will report it is not available.

ie - (Optional) Shared network folder = \\SERVER\SHARE_NAME

 

 

Link to comment
Share on other sites

Set up a file source to your smb share using the kodi file manager, use the exact same server host and share name. Kodi should then remember your creds.

Link to comment
Share on other sites

30 minutes ago, Wheemer said:

Seems like a regression, you've added an extra step when what was there before was working well.

Totally agree with you.

Link to comment
Share on other sites

I am upgrading the server hardware, it will be back into production tomorrow. But how am I supposed to tell if it is working? I just notice buffering and slow loading with this new version of the plugin vs the old one that had smb built in and did not buffer near as much.

Link to comment
Share on other sites

There is still SMB (direct PATH) access to files.

You can check the OSD info when something is playing and the first line of the synopsis/description will be the playback type, DirectPlay, DirectStream or Transcode

Also the server dashboard should tell you what type of playback is occurring for a playing item.

Edited by TeamB
Link to comment
Share on other sites

It says DirectStream, even though I mapped the share already.

Edited by Wheemer
Link to comment
Share on other sites

yep it is still DirectStreaming over HTTP.

If you turned on the "Allow direct file playback" and the file is within the network bandwidth limitation you have set in the client then it should try Direct Path Playback.

To help track down if this is an issue or not I would need a Kodi log.

- Turn on EmbyCon debug logging in the EmbyCon add-on settings under advanced
- Restart Kodi
- Reproduce the issue
- Send me the logs (PM me the if you want)

 

Link to comment
Share on other sites

The setup I was experiencing the problem with has been redone to where Kogi and Emby are now local on the same machine. I do not see the issue any longer.

I have another setup that does seem to be working properly and says directplay. So I guess my issue is resolved.

I will say that maybe the shares mapped in kodi have to be the same path as the ones in emby... Since I had mapped those paths previously and it just works. When I was testing earlier I only mapped a downloads folder, not the direct paths I needed. That may have been my error.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...