Jump to content

JPG not showing up


gtrguy

Recommended Posts

Just uploaded a new directory of jpg's. I can see them when browsing the directory with a file manager but they don't show up in Emby regardless of client whether it's a PC, chromebook or Roku.  Just shows an icon and when you select the image it just another broken icon. JPG's that were there before are still showing up...I've re-scanned the library, restarted Emby, restarted the server itself..

Running server ver 4.4.3 on linux

Thoughts?

Link to post
Share on other sites
mastrmind11
System.UnauthorizedAccessException

You need to set proper permissions for the directories/files you want emby to have access to.  ie, you need to add the emby user to whatever group has read access to the folders/files.  probably easier to look at a folder or file that emby can see, and just reuse those permissions for the new files.

Edited by mastrmind11
Link to post
Share on other sites

I was thinking that last night as well. Everything was done under the same account and nothing has changed relative to users & groups.

First screen shot is a directory that works..second one is the one that doesn't.

I just installed 4.5 a few minutes ago. No change.

image.png.878b5417cd49140f791dc3550ed6274f.png

 

image.png.af580b553145a982f193e714df0eaf92.png

Link to post
Share on other sites
Luke

Have you made sure the emby system user has permissions for the file(s)? You can learn how to do that by consulting our file permissions guide:

 

Link to post
Share on other sites

Well.. it's fixed but kind of odd. Permissions on the folder appeared to be identical to the others but it still didn't work. I moved some files into another folder and they showed up. 

 

Thanks for the assist

Link to post
Share on other sites
mastrmind11
22 hours ago, gtrguy said:

Well.. it's fixed but kind of odd. Permissions on the folder appeared to be identical to the others but it still didn't work. I moved some files into another folder and they showed up. 

 

Thanks for the assist

sounds like you have an ACL set up then that you don't know about.  I'd look into those.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...