Jump to content

Found a bug when specifying recording path for DVR


Recommended Posts

I am running emby version 4.4.3.0

I am running emby inside if docker using image image: linuxserver/emby from here https://fleet.linuxserver.io/image?name=linuxserver/emby

 

 

 

 

I am trying to make emby save Movies and TV shows captured from my HDHomeRun PRIME (Model: HDHR3-CC) to separate folders.

 

Right now its saving perfectly fine using the following settings but its saving both movies and TV shows into the "Recordings" folder

++++++++++++++++++++++++++++++++++++++++++++++

Default recording path:
/media/user/smbshare/Recordings

Specify the default location to save recordings. If left empty, the server's program data folder will be used.
Movie recording path (optional):
 

Series recording path (optional):

+++++++++++++++++++++++++++++++++++++++++++++++++

 

 

I changed the settings to this

+++++++++++++++++++++++++++++++++++++++++++++++++

Default recording path:
/media/user/smbshare/Recordings


Specify the default location to save recordings. If left empty, the server's program data folder will be used.

Movie recording path (optional):
/media/user/smbshare/Recordings/Movies

Series recording path (optional):
/media/user/smbshare/Recordings/TV
++++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

 

and now it created 3 Folders in the library instead of 2

I now have

1 x Recorded Movies

2 x Recorded Shows

instead of 

1 x Recorded Movies

1 x Recorded Shows

 

Why do i have 2  x Recorded Shows instead of one

 

 

 

 

changed my settings back to normal and the 3 extra folders got removed automatically 

1 x Recorded Movies

2 x Recorded Shows

 


 

before.png

after.png

Edited by Eddie
Link to post
Share on other sites
mickle026

 

Not a new bug.  Its been around for ages.

You have to let the library scan complete successfully before adding or deleteing any libraries, if not you'll get multiple libraries. 

When you set up the DVR libraries, set up ONE at a time and click only ONCE!!!  If no response do not click again, close the browser, reopen and WAIT for the library scan to COMPLETE.  It might take a while to even start.  Set up the scond path and allow it to scan again and complete again.

For each path you create it can create 3 libraries.  The Main, The New TVSHows and The new TV Movies paths,  There a 3 seperate threads running in the background,  ALL OF THEM trying to create the libraries, thats why you can get 3 for each !!! Sometimes a total of up to 9....

There should be a test to see if it exists, and skip it in the seperate threads, but there doesn't appear to be.

If it has still created multiples then remove the others and ALLOW the scan to complete FULLY.

 

It will fix itself then.  It just takes a while.

@Luke Tagged you Luke just in case you were not aware that every build up to 4.6.0.1 beta still does this

Edited by mickle026
Tagged Luke
  • Like 1
  • Thanks 1
Link to post
Share on other sites

Thank you for your response, should i delete my default recording path  and leave it blank if i am going to specify location for TV and movies?

Link to post
Share on other sites
mickle026

I am not sure if it affects anything, but my default recording path is blank.  Blank will default to Emby original setup path.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...