Jump to content

Collections no longer adding movies back in


invader
 Share

Recommended Posts

Hi there. I migrated server a few weeks ago and only recently noticed the issue where all libraries were "mixed content". I noticed this because I was having issues with some movies I had re-added, weren't going into their collections. The issue with "mixed content" is a known issue and has since been resolved.

In my case, before I knew how to fix it, I re-created all my libraries. This has now complete, I removed all the old ones, uninstalled and re-installed the Auto Box set plugin.

I'm still having a "Collections" issue.

The issue is, I only have one movie in the "Matrix Collection".

When I check their metadata in Emby I see:

Movie Emby Metadata edit: TheMovieDb Collection Id:
The Animatrix 2344
The Matrix 2344
The Matrix Reloaded 2344
The Matrix Revolutions 2344

 

  • I ran "Scan all library files"
  • I ran "refresh box sets" in Auto Box Sets plugin
  • I clicked each movies context menu in the library and clicked "refresh metadata" > Replace all metadata > Refresh
  • Refresh metadata on Movies and Collections libraries ( "refresh metadata" > Replace all metadata > Refresh )

Any ideas? Thanks.

  • Like 1
Link to comment
Share on other sites

rbjtech

If it's just the one collection - then I would remove the XML file, re-scan and then run the Auto-Box sets again to recreate it.

"<your emby location>\programdata\data\collections\The Matrix Collection [boxset]\collection.xml"

You can open the XML file in notepad etc and see the file paths - probably worth checking what it says before you delete it to see if it only has the one movie in it.

 

 

Edited by rbjtech
  • Like 1
Link to comment
Share on other sites

Thanks for the suggestion rbjtech.

I've only noticed the Matrix but there could be more so if this works I might delete/recreate them all.

I had a look at the xml file and it did only have the Animatrix in it.

I've just deleted:

/var/lib/emby/data/collections/The Matrix Collection [boxset]

Re-scanned Movies library and "refresh boxsets".

That fixed it! Thanks. I think somthing funny has gone on with it after having to recreate all my libraries again. I think I'll delete them all and re-create to make sure I won't have issues in the future. Thanks 

 

  • Like 3
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...