Jump to content

nVidia Shield


Recommended Posts

...hey guys...I have a question about the nVidia shield...I currently run Emby on a PC, porting out to 4 separate 4k Rokus in my house and it works fine...I have my living room Roku hooked up to both my Samsung 4k Tv as well as my Viewsonic DLP projector, using a 4 input / 2 output matrix...it all works fine, except for the fact that the 4k Roku does NOT support 3D movie output to my projector...so, I had to add a generic Android box, running Emby for Android to my system to achieve that...would the Shield be able to replace the Roku AND the Android box?...does the Shield run Android apps?...would you install Emby for Android on this unit in order to use it this way?...is there any ACTUAL advantage to replacing the Roku and the Android box with the Shield???...thanks in advance for any advice you can provide!!!

Link to post
Share on other sites

The Shield TV is probably the very best box IMHO to run Emby on as it's fully "Android TV" and again IMHO has the best Emby app available.

Emby/Shield TV fully support 3D (any version including half and full).

With that said you may be able to use a MiBox-S as well instead of the Shield TV and it's 1/3 the price and runs the same Android TV Emby app.

Link to post
Share on other sites
BillOatman

Another one to look at is the Tivo stream.  Same price point as the mibox, but it is a much faster device.
I replaced my mibox with the tivo stream.

Neither of those can touch the shield though, which I use on my main TV.  If money is not a big concern, definitely go shield.

Edited by BillOatman
Link to post
Share on other sites
  • 8 months later...
gerry.emm

Hi again guys...

Well, I did end up getting the nVidia Shield TV Pro, and I just LOVE how seamless and how intuitive it is...took a bit of getting used to, but loving how well it works!!!

I purchased the EMBY app for the nVidia streaming box, but I have run into a little snag...I have a LOT of 3D content, and watch it from our Viewsonic DLP projector, as I do NOT have a 3D capable TV.  Prior to the Shield, I had to use a generic (Leelbox) Android box to play 3D content, with the EMBY app installed in order to watch 3D movies, as my regular streaming boxes (Roku 4K streaming boxes in different rooms in the house) are NOT 3D capable.

From the research I have done, the nVidia Shield TV Pro is ***supposed*** to be able to play 3D movies.  Believe me, there's VERY LITTLE information out there with regards to the nVidia Shield TV Pro and it's ability to play 3D movies!!!

So, that  being said, I have tried to play 3D content, which, by the way is *ALL* HSBS content, is properly named using the proper naming convention for EMBY, and it is recognized as 3D content by EMBY.  When I try to play it, and I set my projector's 3D sync to side by side, it looks like it wants to play it properly, but as soon as it starts, it reverts to displaying 2 separate side by side screens instead of overlaying them, as it should.

I have gone through every imaginable setting in my server, in the EMBY app for the nVidia streaming box, and even the nVidia box's settings to try to find what I am doing wrong, and am unable to find what's keeping them from playing properly.

Anyone who owns an nVidia box knows that it comes equipped with its own server software, PLEX.  So, in a desperate effort to get the content to play properly, I tried setting up PLEX on a laptop, and added some of my 3D content to it, and LO & BEHOLD, it plays properly!!!  This leads me to believe that the settings on the nVidia box are correct.  I made no *SPECIAL* changes to PLEX's settings to get them to play, so this leads me to believe I am missing something somewhere, either in the server's settings or the EMBY app for nVidia's settings...

Anyone out there in the community that might have some insight to help me find out what I'm doing wrong, I would GREATLY appreciate if you could at least "point me in the right direction"...I do NOT want to revert to using PLEX instead of EMBY as I *MUCH* prefer EMBY, and I would *HATE* to have to re-install that cheap Android box to be able to enjoy my 3D movies...I am in the process of re-designing my home entertainment system, and would much prefer to have my nVidia Shield TV Pro as the centerpiece of my system with EMBY running the "show" so to say...

I *AM* also prepared to purchase a "lifetime" license for EMBY PREMIERE, just so I don't have to rely on PLEX or that cheap Android box *JUST* so I can enjoy my 3D movies!!!

Sorry to have been so long-winded but I thought it was worth explaining what I have ALREADY done to try to solve this problem...THANKS A MILLION in advance to anyone able and/or willing to help!!!

Gerry

Link to post
Share on other sites
ebr

Hi.  Exactly how is the item playing?  Are there any ffmpeg logs created on the server?

 

Link to post
Share on other sites
gerry.emm

Hi...

 

I have found an ffmpeg log, but I'm not sure I understand your question...

What do you mean by "how is the item playing"?

And again, thanks in advance for your help!!!

Gerry

Link to post
Share on other sites
ebr

Can you please attach the log here?

Thanks.

Link to post
Share on other sites
cayars

Hi, None of those are HSBS videos.

Link to post
Share on other sites
Luke

hi @gerry.emm can you please provide a log example from when you played your 3D HSBS video? Thanks.

Link to post
Share on other sites
gerry.emm

Hi Luke,

Sorry for the delay but we had a serious internet outage over the weekend...I can only play movies on weekends, so I will attempt to play a few 3D movies this COMING weekend and will post the logs afterwards...

And thanks in advance to you also for helping!!!

Gerry

  • Thanks 1
Link to post
Share on other sites
Luke
5 hours ago, gerry.emm said:

Hi Luke,

Sorry for the delay but we had a serious internet outage over the weekend...I can only play movies on weekends, so I will attempt to play a few 3D movies this COMING weekend and will post the logs afterwards...

And thanks in advance to you also for helping!!!

Gerry

Great, thanks !

Link to post
Share on other sites
  • 4 weeks later...
gerry.emm

Hi Luke, and everyone else that may offer help...

 

I have finally been able to try projecting 3 separate 3D movies.
Last night, I tried "Abominable", then I tried "Conan the Barbarian" and lastly, I tried "Godzilla vs Kong".
Again, when I set up the 3D settings for the projector, it "looks" like it's going to project it properly, but then it just displays the 2 screens, side by side.
Here are all the logs for today's date...if any others are required, please let me know...

Thanks again in advance for your help, and here's hoping I "CAN" get my nVidia Shield Pro to display 3D movies as it should!!!
 

Gerry

P.S. - I haven't been able to find any ffmpeg log files anywhere in the logs directory following last night's trial...please let me know if there are any other log files you'd like uploaded...and thanks AGAIN!!

embyserver.txt embyserver-63760363200.txt

Link to post
Share on other sites
CBers

@gerry.emm Have you tried the Android Mobile app on the Shield?

See here for the download - you'll have to sideload it onto your Shield.

Might be worth a try.
 

Link to post
Share on other sites
crusher11
On 6/30/2021 at 11:17 PM, Luke said:

Was it direct playing?

Yes. 

Link to post
Share on other sites
gerry.emm
On 30/06/2021 at 11:17, Luke said:

Was it direct playing?

Yes, it was...

Link to post
Share on other sites
Luke
2 hours ago, gerry.emm said:

Yes, it was...

Can you try what cbers suggested above? Thanks !

Link to post
Share on other sites
  • 2 weeks later...
gerry.emm

I did download EMBY for Android from the Play store as soon as I installed my nVidia Shield Pro TV box, and that *IS* what I am running...I even purchased it outright...and I keep it updated on a weekly basis, even though my nVidia Shield Pro TV box is set to automatically update all apps...

Thanks again for your help in this matter!!!...it truly *IS* appreciated!!!

Gerry

Link to post
Share on other sites
CBers
14 minutes ago, gerry.emm said:

I did download EMBY for Android from the Play store as soon as I installed my nVidia Shield Pro TV box, and that *IS* what I am running...

So you haven't installed the Emby for Android TV app then ?

 

Link to post
Share on other sites
gerry.emm

Well, unless there is some *OTHER* EMBY for Android TV app on the Play store, then, YES, I *HAVE* downloaded it, and that *IS* what I am running...

 

Gerry

Link to post
Share on other sites
CBers
37 minutes ago, gerry.emm said:

Well, unless there is some *OTHER* EMBY for Android TV app on the Play store, then, YES, I *HAVE* downloaded it, and that *IS* what I am running...

Just for clarifications there are 2 Emby Android apps that will work on the Shield.

The most appropriate one is the Emby for Android TV app, for Android TV devices, such as the Shield, Mi Box, Nexus Player and Amazon Fire devices.

The one I suggested above, is the normal Emby for Android app for phones and tablets, although it will also work on the Android TV devices.

So for the Shield, people should really be using the Emby for Android TV app as it has been curated for the platform, but if anyone has problems with it, the Emby for Android app can be used as a comparison.

Hope that makes sense.
 

Edited by CBers
  • Like 2
Link to post
Share on other sites
gerry.emm

Thanks CBers...will have to try my hand at sideloading the other app to see if it makes a difference...

In the meantime, just so you know, I *HAVE* purchased the lifetime license for EMBY Premiere, and am hoping this will also help in solving this problem...

Going to have to try again, now that my server is upgraded to EMBY Premiere to see if it helps...

Stay tuned!!!

 

Gerry

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...