Jump to content
rcoodey

ANSWERED Path substitution from SMB to NFS not happening

Recommended Posts

rcoodey

Hi,

I updated Emby Server on my QNAP NAS to 4.4.3.0 and also wanted to use my existing NFS shares (across several NAS boxes). So I removed all the library paths and recreated with the only way I can get Emby to see the folder is with a UNC path (ex: \\nas\movies) which I am ok with. So I then set the "Shared network folder" to the NFS path (ex: nfs://192.168.1.9/Movies). I reset my local database in Kodi and then restarted Kodi. But when syncing (native path option) it says it cannot find smb://nas/movies/moviename.m2ts.

Why is it trying SMB and not the alternative path that is NFS? I tried enabling the "Use alternative device name" option but that did nothing. Not real sure how it works or if it is needed for this.

Any ideas on getting Kodi to use the alternative path? Thanks a lot!

Edited by rcoodey

Share this post


Link to post
Share on other sites
rcoodey

It started working with the NFS optional paths after I set the folder to smb://nas instead of a UNC \\nas. Not sure why. Also learned Kodi does not like DNS for NFS shares so had to use the IP in the optional paths. But seems to be working fine now. Thanks.

  • Like 1

Share this post


Link to post
Share on other sites
Luke

Glad to hear you figured it out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...