Jump to content
rkirchhof

Blu-ray Disc plugin missing

Recommended Posts

rkirchhof

I'm in the process of migrating my emby media server from Windows to Centos 8 Docker container.  Everything has gone very well so far, but I'm unable to locate the "Blu-ray Disc" plugin I was using in the source server. (The plugin description says "Bluray Folder Support 1.0.0.0"

Share this post


Link to post
Share on other sites
Luke

Hi, yes I need to add this to the catalog for manual installation but the server includes this plugin out of the box. Did you uninstall it?

Share this post


Link to post
Share on other sites
rkirchhof
no, but I'm seeing this in the logs.
 
2020-08-09 10:03:27.320 Error App: Error loading assembly /config/plugins/BlurayMounter.dll
*** Error Report ***
Version: 4.4.3.0
Command line: /system/EmbyServer.dll -programdata /config -ffdetect /bin/ffdetect -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartexitcode 3
Operating system: Unix 4.18.0.193
64-Bit OS: True
64-Bit Process: True
User Interactive: True
Runtime: file:///system/System.Private.CoreLib.dll
System.Environment.Version: 3.1.2
Processor count: 4
Program data path: /config
Application directory: /system
System.BadImageFormatException: System.BadImageFormatException: An attempt was made to load a program with an incorrect format.

Share this post


Link to post
Share on other sites
Luke

Try deleting that file and then restart the server.

Share this post


Link to post
Share on other sites
rkirchhof
Posted (edited)

Yep, that did it! Thank you.

 

Edited by rkirchhof
Update
  • Like 1

Share this post


Link to post
Share on other sites
tznemet

Hi guys, i have remove the plugin, how can i get it again?
regards

Emby on LibreElec (Kodi)

Share this post


Link to post
Share on other sites
Happy2Play
6 minutes ago, tznemet said:

Hi guys, i have remove the plugin, how can i get it again?
regards

Emby on LibreElec (Kodi)

This option is maintained you your system.xml and you have to manually copy the "BlurayMounter.dll" from your Emby system plugin folder to your /config/plugin folder.

example from one of my system.xml, but the difference with these two are the reside in the catalog.

  <UninstalledPlugins>
    <string>OpenSubtitles.dll</string>
    <string>Emby.Server.CinemaMode.dll</string>
  </UninstalledPlugins>

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...