Jump to content
VapingSkull

Foto Bibliothek korrekt einstellen

Recommended Posts

VapingSkull

Hi zusammen,

ich steh gerade vor einem Problem welches ich einfach nicht verstehe und deswegen auch nicht gelöst bekomme.

Also frage ich mal hier und hoffe jemand hat ne Idee.

 

Ich habe unmengen an Fotos in .gif .jpg .jpeg .png usw. Diese würde ich gerne in eine Bibliothek nutzen und auch darstellen.

Also Ordner angelegt auf der Platte, Rechte vergeben (da ich ubuntu nutze, Rechte entsprechen angepaßt, Benutzer Emby ist der Besitzer)
Admin Oberfläche von Emby Neue Bibliothek mit dem Typ Heimvideos und Fotos erstellt.

So,  entsprechenden Ordner auf der Platte angewählt.

Fotos erkennen eingestellt.

Dateien reinkopiert . Es werden die Ordner angezeigt, aber keinerlei Inhalte.

Ordnerstruktur :

Pictures/2020/pic1.jpg

Pictures/2019/pic4245.jpg

 

usw. usw. Kopiere ich dort Handyvideos rein in einen Ordner Namens  Handyvideos, werden diese angezeigt. Die kann ich auch abspielen. Nur Bilder nicht.

Gibts da nen Trick ? Habe ich was vergessen zu installieren ? Also Serverseitig ?

 

Serversoftware : Ubuntu Server 20.04 LTS
Muß ich noch was an Software nachinstallieren für Emby damit er mit Bildern klarkommt ?

Bin für jede Hilfe Dankbar.

 

Grüße

VapingSkull


 

Share this post


Link to post
Share on other sites
VapingSkull

Keiner ne Idee dazu ? Warum ich nur Leere Foto Ordner sehe ?

Share this post


Link to post
Share on other sites
serpi

Klingt so weit eigentlich alles in Ordnung, vielleicht hat Emby ja ein Problem mit den reinen Zahlen als Ordnernamen.

Benenne einen Ordner doch mal z.B. "2020 - Bilder".

Bei mir funktioniert es, da heißen die Ordner z.B. "2017-08-01 - Legoland".

Ciao, Alfred

Share this post


Link to post
Share on other sites
cayars

Might also want to double check the privs on the files themselves you copy over to the new library.

Share this post


Link to post
Share on other sites
VapingSkull
Posted (edited)
On 04/08/2020 at 18:36, serpi said:

Klingt so weit eigentlich alles in Ordnung, vielleicht hat Emby ja ein Problem mit den reinen Zahlen als Ordnernamen.

Benenne einen Ordner doch mal z.B. "2020 - Bilder".

Bei mir funktioniert es, da heißen die Ordner z.B. "2017-08-01 - Legoland".

Ciao, Alfred

Hi, 

Erstmal vielen dank für den tip. Hat aber leider nichts gebracht. 

Problem war tatsächlich, daß der Ordner wo die medien drinliegen, also quasi das Hauptverzeichnis, falsche Berechtigungen hatte. 

Komisch dabei ist, Videos usw die ebenfalls in unterordnern liegen, werden erkannt und auch aufgenommen. Muss man nicht verstehen oder? 

Gruss

Vapingskull

Edited by VapingSkull

Share this post


Link to post
Share on other sites
VapingSkull
3 hours ago, cayars said:

Might also want to double check the privs on the files themselves you copy over to the new library.

Hi there, 

Well the rootfolder has wrong privs. But thats a Problem by emby. Because all other folders unser this rootfolder was scanned and added. 

Just the photo library makes trouble

Greetings

Vapingskull

Share this post


Link to post
Share on other sites
Luke

Hi, if the root folder has the wrong privileges, why do you think this is an Emby problem?

Share this post


Link to post
Share on other sites
VapingSkull
6 hours ago, Luke said:

Hi, if the root folder has the wrong privileges, why do you think this is an Emby problem?

Hi Luke,

i try to explain that.

My Folder Structure for Emby under Ubuntu 20.04 LTS Server looks like :

/srv/medien/Movies -> For Movies = works

/srv/medien/Music -> For Music = works

/srv/medien/Serien -> For Serien = works

/srv/medien/Photos -> For my Pictures = Dont Work

All Folders under /srv/medien have the same rights and the owner and ownergroup is emby  with full read/write/delete access for these Folders.

In all Librarys it works fine and without any problems. But under Photos nothing shows up. After i give the /srv/ Folder 0777 Photos shows up. Owner and Ownergroup for /srv/ is root.

Thats because i mean that emby has a problem.

 

Regards

VapingSkull

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...