Jump to content
Cydios

ANSWERED Best streaming device that you don't need to transcode uhd files

Recommended Posts

Cydios
Posted (edited)

I've been using the newest nvidia shield. A lot of the newer mkv files I have has been transcoding.  Been trying to figure out which codex I don't have.. Is there a suggestion on the best streaming device to get where you don't have to worry about not being compatible. Even Kodi is transcoding them. Thoughts?

Edited by Cydios

Share this post


Link to post
Share on other sites
Luke
Quote

A lot of the newer mkv files I have has been transcoding

What does it say as the reason for transcoding?

Share this post


Link to post
Share on other sites
cayars

That is about as good as it gets device wise.  Really the only way to do better is with an HTTP setup but that still doesn't mean files won't transcode. Transcoding can take place for reasons other then the file itself, like bandwidth.

What's the reason for the transcode as Luke asked.  Here is one way you can tell from the DASHBOARD view in web admin.

Click the "i" that's in the red box below for the trancode reason.

dash.png.158ebd361ebd56481428983a7123806c.png

Share this post


Link to post
Share on other sites
Cydios

It's not a bandwidth issue, I've got windows server with nic teaming at full speed and all wired. Running complete network and not your typical home router. It's file related. It's usually related to a 265 file. Thanks for the tip on the "i" that'll at least point me to what to avoid. 

Share this post


Link to post
Share on other sites
Cydios
Posted (edited)

Do you see which one of these is the issue?

 

20200801_133059.jpg

20200801_133311.jpg

20200801_133541.jpg

Edited by Cydios

Share this post


Link to post
Share on other sites
Luke

You're using an strm file pointing to an mkv?

Share this post


Link to post
Share on other sites
Cydios
9 minutes ago, Luke said:

You're using an strm file pointing to an mkv?

Just saw that and no. That was the screenshot from Kodi, but maybe that's rename for the temp transcode file? Looking at what it's transcoding appears to be the audio. The movie is 6.1 and it's converting to 5.1. There's no other audio options for it. My 7.1 ones play fine. Receiver is 6.1 compatible. I wonder if the shield supports it. 

Share this post


Link to post
Share on other sites
cayars

Pick a file that causes Transcoding or Direct Streaming.

From the web admin go to the detail screen of that video, scroll down to the bottom and you should see the meta data for the file.

Take a snapshot and upload that info for the file

Share this post


Link to post
Share on other sites
cayars

Need to see the metadata from the detail screen for Office Space. See message above for where to find this info.

Share this post


Link to post
Share on other sites
Cydios

Also oddly, it stops transcoding after about 2-3 mins and the movie just stops. 

Share this post


Link to post
Share on other sites
cayars
27 minutes ago, Cydios said:

Also oddly, it stops transcoding after about 2-3 mins and the movie just stops. 

Did you mean direct streaming like in the pic you posted above or was it actually transcoding and said that?  Just wondering if you switched devices in testing as that changes things a lot.

Share this post


Link to post
Share on other sites
Cydios
Posted (edited)
1 hour ago, cayars said:

Did you mean direct streaming like in the pic you posted above or was it actually transcoding and said that?  Just wondering if you switched devices in testing as that changes things a lot.

Nope, didn't switch.. just stopped coding and the as if I hit the stop button, the server registers it as stopped.

Edited by Cydios

Share this post


Link to post
Share on other sites
cayars

What I meant was when playing looking at the DASHBOARD does it say TRANSCODING or DIRECT STREAMING?

Share this post


Link to post
Share on other sites
Happy2Play

Can you post the ffmpeg log for these played items.

Share this post


Link to post
Share on other sites
Cydios
37 minutes ago, cayars said:

What I meant was when playing looking at the DASHBOARD does it say TRANSCODING or DIRECT STREAMING?

Transcoding. 

Screenshot_20200801-162449_Microsoft Remote Desktop.jpg

Share this post


Link to post
Share on other sites
cayars

Are you uploading the wrong picture?  You're typing Transcoding but the picture says Direct Streaming

Don't look at the part I crossed off on the left but look at what is in the yellow section.

We should probably change the wording on the left side to remove "transcode" from that.

 

111.jpg

Share this post


Link to post
Share on other sites
cayars

If you click the "i" icon on that screen above what is the reason for the Direct Stream?

Share this post


Link to post
Share on other sites
Cydios
1 minute ago, cayars said:

Are you uploading the wrong picture?  You're typing Transcoding but the picture says Direct Streaming

Don't look at the part I crossed off on the left but look at what is in the yellow section.

We should probably change the wording on the left side to remove "transcode" from that.

 

111.jpg

No. lol. I noticed it too, that's why I posted the screenshot. I was going to type it out, but I thought the picture would help better. 

Share this post


Link to post
Share on other sites
Happy2Play
Posted (edited)

Ideally we have to figure out why your are getting "&TranscodeReasons=DirectPlayError"

As this direct stream is converting audio.

16:23:37.477 Stream mapping:
16:23:37.477   Stream #0:0 -> #0:0 (copy)
16:23:37.477   Stream #0:1 -> #0:1 (dts (dca) -> ac3 (native))

 

Edited by Happy2Play

Share this post


Link to post
Share on other sites
Cydios
5 minutes ago, cayars said:

If you click the "i" icon on that screen above what is the reason for the Direct Stream?

 

Screenshot_20200801-163943_Emby.jpg

Share this post


Link to post
Share on other sites
Cydios
2 minutes ago, Happy2Play said:

Ideally we have to figure out by your are getting "&TranscodeReasons=DirectPlayError"

As this direct stream is converting audio.


16:23:37.477 Stream mapping:
16:23:37.477   Stream #0:0 -> #0:0 (copy)
16:23:37.477   Stream #0:1 -> #0:1 (dts (dca) -> ac3 (native))

 

It's happening on 3 movies it appears. So it's converting dts to ac3? Isn't the shield dts?

Share this post


Link to post
Share on other sites
cayars

We should improve the message being given when the info button is used as that message is actually wrong.

What type of sound system do you have connect to the Shield TV?  Does it play DTS?

Is the HDMI from the Shield TV going into the TV or a sound system?  If going to the TV how is your sound system connected to the TV?

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...