Jump to content
MagnusDaMan

Metadata is refreshed and deleted automatically

Recommended Posts

MagnusDaMan

I have created a library named "Directors". To this library I have added folders with directors. Each folder is the name of the director.

In library "Directors", I go to "Folders" in the top menu. For each folder with a director name, I add a picture for that director.

The library is explicitly set to "Never" in the field "Automatically update metadata from the internet".

Still, and this has happened twice now, the metadata is replaced, both on the folder itself, and for all movies inside the folders.

Since Emby refuses to allow dynamic file-naming, I have had to edit each movie individually, and with the size of my collection this has taken MANY hours.

I really can't do this over again, it takes too much time. 

What is missing? Did I do something wrong or is Emby simply doing things randomly?

DSM 6.2.3-25426 Update 2
Emby verison 4.4.3.0-1

Share this post


Link to post
Share on other sites
MagnusDaMan

This seriously drives me crazy.

🤯😬🤢😰

Share this post


Link to post
Share on other sites
Luke

Hi there, can we please look at a specific example? Thanks.

Share this post


Link to post
Share on other sites
MagnusDaMan

Well it is the same for almost all movies. My naming standard does not follow Emby's recommended "name (year)", and so I have had to edit all metadata for each movie myself.

I did that, and set the option to "Never" as described above.

Nevertheless Emby has overwritten and deleted all the metadata I added manually. Now it is gone...

I have a backup from one or two days before it got deleted, but there would be exactly no point in restoring the data. Since I was not the one initiating a refresh-and-delete of all my metadata, this came from Emby, and as I don't understand what initiated this mass-purge, I have to understand first why the purge was initiated.

Share this post


Link to post
Share on other sites
Luke
Quote

Well it is the same for almost all movies. 

That's OK, can we still go over a specific example? Thanks.

Share this post


Link to post
Share on other sites
MagnusDaMan

Well, basically it is the same for all files/movies so one specific example does not matter.

For ALL movies the metadata was suddenly purged.

All my movies are named as follows "2013 - Eddie Meduza - Alcohol.mkv". Since Emby often picks up the wrong name when not following the standard naming convention, or even finds the wrong movie, I had to go in to the web interface and manually do "Identify" with the help of the imdb id.

This worked, but after having done this for MANY movies, they suddenly started getting purged. All metadata was deleted.

The settings under each library is, as mentioned above, set to Never. Still all metadata was deleted.

Now cayars was kind enough to convince me to use the standard naming, and even helped me check my settings, so now it seems to have stabilized. (Very great thanks to cayars for that.).

However, there are some movies that are not correctly identified even when the correct naming standard is used, and these has to be edited manually.

What I am trying to understand is what triggered these metadata changes in the first place. My collection is rather large, and since there are quite a few movies that are not identified automatically, I have to do that manually for all of them. I would very much like to understand how to keep the metadata stable. It would be great to understand what triggers these events that started the deletion of the metadata so I can stop that from happening.

Share this post


Link to post
Share on other sites
gillmacca01

Have you tried locking the metadata?

Share this post


Link to post
Share on other sites
Luke
8 hours ago, gillmacca01 said:

Have you tried locking the metadata?

That's not necessary. It's better to look at what's going on.

Share this post


Link to post
Share on other sites
Luke
9 hours ago, MagnusDaMan said:

Well, basically it is the same for all files/movies so one specific example does not matter.

For ALL movies the metadata was suddenly purged.

All my movies are named as follows "2013 - Eddie Meduza - Alcohol.mkv". Since Emby often picks up the wrong name when not following the standard naming convention, or even finds the wrong movie, I had to go in to the web interface and manually do "Identify" with the help of the imdb id.

This worked, but after having done this for MANY movies, they suddenly started getting purged. All metadata was deleted.

The settings under each library is, as mentioned above, set to Never. Still all metadata was deleted.

Now cayars was kind enough to convince me to use the standard naming, and even helped me check my settings, so now it seems to have stabilized. (Very great thanks to cayars for that.).

However, there are some movies that are not correctly identified even when the correct naming standard is used, and these has to be edited manually.

What I am trying to understand is what triggered these metadata changes in the first place. My collection is rather large, and since there are quite a few movies that are not identified automatically, I have to do that manually for all of them. I would very much like to understand how to keep the metadata stable. It would be great to understand what triggers these events that started the deletion of the metadata so I can stop that from happening.

Can you do a new edit and then get this to happen again?

Share this post


Link to post
Share on other sites
MagnusDaMan

Ok. I will try.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...