Jump to content
SilikG

Raspberry Pi Hardware Decoding

Recommended Posts

SilikG

I have emby running on a Raspberry Pi 4, and have hardware encoding working (although the hardware encoding embeds significantly smaller subtitles than the software encoding does -- is this something I can fix?), but it continues to use software for decoding, without any available decoder options.  I didn't see anything in the setup guide on how to enable this, did I miss something somewhere?

 

emby.thumb.jpg.1acdd17c8d8bccfd5b16956d670f9fe1.jpg

Share this post


Link to post
Share on other sites
Luke

Hi there, did you follow the instructions in the setup guide?

Share this post


Link to post
Share on other sites
SilikG

The instructions I could find.  Couldn't find Raspberry Pi specifically, but the linux ones appear to just say the drivers already exist?

Share this post


Link to post
Share on other sites
Luke

Did you ensure that they're up to date? What driver version?

Share this post


Link to post
Share on other sites
SilikG

apt-get upgrade should update them, so they should be up to date, but I'm not finding anything in the setup documentation to suggest any other way of setting things up.  Not familiar enough with pi and google isn't helping me find what driver is being used to determine what version is loaded.

Share this post


Link to post
Share on other sites
Luke

Please attach the emby server and hardware detection logs. thanks.

Share this post


Link to post
Share on other sites
Luke

Isn't rpi4 arm 64 architecture? I think so, in which case you should be using our arm64 install package. Or are there armhf rpi4 models as well?

Share this post


Link to post
Share on other sites
SilikG

$ uname -a
Linux media 4.19.118-v7l+ #1311 SMP Mon Apr 27 14:26:42 BST 2020 armv7l GNU/Linux
 

Pi runs a 32-bit OS, and (last I checked) the 64-bit isn't recommended yet (lthough the hardware itself is 64 bit since Pi 3, I believe).

Share this post


Link to post
Share on other sites
Luke

Hi, please see the explanation in this topic and let us know if it helps:

Thanks.

Share this post


Link to post
Share on other sites
SilikG

Yeah, that helps (recognize that it's know to not work), thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...