Jump to content
mbarylski

ANSWERED Is there a way to disable creation of the nfo file for DVR'd content?

Recommended Posts

mbarylski
Posted (edited)
3 minutes ago, cayars said:

OK.  If you edit Library Kids is NFO file creation enabled?

Nope

image.png.4f3e5c60012d762058830bd05c689281.png

It was however enabled on my "Recordings" library when I first posted. I've since disabled and restarted the server, but it's still generating an nfo.  

Edited by mbarylski

Share this post


Link to post
Share on other sites
cayars

Besides your Kids library do you have any libraries using these mount points?

D:\MediaCenter\Videos\Television\

D:\MediaCenter\Videos\

D:\MediaCenter\

Share this post


Link to post
Share on other sites
mbarylski

Not those specifically, no, but sub folders of Television, yes.

Share this post


Link to post
Share on other sites
cayars

I've setup on my test system something similar to your layout (I think) and have set a couple of recordings.

In the mean time would you be up for a remote TeamViewer session?  I could do a quick look at your lib setup and layout to see if I see anything that could cause this as well as get a better idea for trying to duplicate your NFO results with testing.

Download and install TeamViewer if you don't have it already and then just send me the ID and one-time use password via PM if this is OK with you.

Carlo

Share this post


Link to post
Share on other sites
cayars

OK now here is something interesting.

I TeamViewed in and took a look.  Besides the "weird" path thing everything looked good. However with NFO turned off and even changing where recordings went to (I created new folder off the root), the NFO appeared.

So on my system I tested by kicking off a brand new recording and got the NFO generated at the start of recording and I have NFO turned off for my Recording Library.

I removed the NFO plugin from my system, restarted and did a recording and the NFO file is again created at the start of recording.

In about a half hour I'll know if the NFO is removed when the recording is complete but the NFO seems to get written regardless if the NFO plugin is installed or not!

  • Haha 1

Share this post


Link to post
Share on other sites
mbarylski

Well this will be a fun one to track down. 😁

Share this post


Link to post
Share on other sites
cayars

@Luke I've been testing this and even without the NFO plugin loaded on the system NFO files are being generated in the DVR recording folder.  There does not seem to be any way to turn this off.  The NFO file is written at the same time the .TS file is generated.

The NFO setting in Recording library does not control this at all obviously with the NFO files still being created without the NFO plugin installed.

  • Thanks 1

Share this post


Link to post
Share on other sites
Luke

That's correct. There's currently no way to turn this off. It's possible for the future.

Share this post


Link to post
Share on other sites
cayars

Is the NFO used for anything?

Would it be safe to delete using a post-processing script?

Share this post


Link to post
Share on other sites
mbarylski

@Luke If there's no way to turn it off, what is the checkbox in the library for?

Share this post


Link to post
Share on other sites
cayars

That's going to be a standard setup option for any library when the NFO plugin is installed.  In this case it seems like there is a reason the NFO needs to be written when Emby starts recording.  It could be a place holder for guide and metadata information.

What we need to find out from Luke is if there is any reason it can't be deleted after the show/movie is done recording.  If so we can delete this via a post-processing script.

Share this post


Link to post
Share on other sites
Luke
10 hours ago, mbarylski said:

@Luke If there's no way to turn it off, what is the checkbox in the library for?

For the normal metadata fetched by the library scan. This nfo contains the metadata from the guide used by the recording process.

Share this post


Link to post
Share on other sites
mbarylski
9 hours ago, Luke said:

For the normal metadata fetched by the library scan. This nfo contains the metadata from the guide used by the recording process.

But the checkbox doesn't do anything for the DVR. The nfo gets written no matter what. So, take the DVR out of the equation for a second. What is the nfo checkbox for in the library if there's no DVR? If I check the box is it supposed to generate nfo's for my 1,000's of existing video files?

Share this post


Link to post
Share on other sites
ebr
1 hour ago, mbarylski said:

What is the nfo checkbox for in the library if there's no DVR?

Exactly what it is labelled to do: save metadata for your items in an NFO file.  The issue here is that the DVR is a separate system depositing not only the content but also the NFO into the library you pointed it to - so it "bypasses" that option.

1 hour ago, mbarylski said:

If I check the box is it supposed to generate nfo's for my 1,000's of existing video files?

Yes, but only when they are saved.  It isn't going to take off and create those just by turning on the option.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...